Add folder doesn´t work

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Add folder doesn´t work

Postby tbach » Wed Apr 29, 2009 6:28 pm

Hello,

first of all, i´m a llitle bit confused about the different versions. I´m absolut new with open sources, sorry.

I have downloaded an installed the version 1.11 from the link
http://otmanix.de/2009/04/18/java-ps3-m ... iguration/

Now, i have seen, that the last release is 1.10.51. Because i have a lot of problems, i tried deninstall the version 1.11 and reinstall the version 1.10.51 . After that, it´s not possible to add any folder. I get the following error:

This happens also, hen i reinstal the version 1.11.

[main] TRACE 19:26:57.525 Starting Java PS3 Media Server v1.10.5
[main] TRACE 19:26:57.525 by shagrath / 2008-2009
[main] TRACE 19:26:57.525 http://ps3mediaserver.blogspot.com
[main] TRACE 19:26:57.525 http://code.google.com/p/ps3mediaserver
[main] TRACE 19:26:57.540
[main] TRACE 19:26:57.540 Java 1.6.0_12-Sun Microsystems Inc.
[main] TRACE 19:26:57.540 OS Windows XP x86 5.1
[main] TRACE 19:26:57.540 Encoding: Cp1252
[main] TRACE 19:26:57.540 Temp folder: C:\Users\TBACH\AppData\Local\Temp\javaps3media
[main] TRACE 19:26:57.540 Found AviSynth plugins dir: C:\Program Files\AviSynth 2.5\plugins
[main] TRACE 19:26:57.540 !!! It seems VSFilter.dll is not installed into the AviSynth plugins dir ! It could be troublesome for playing subtitled videos with AviSynth !!!
[main] TRACE 19:26:57.540 Found VideoLAN version 0.9.9 at: C:\Program Files\VideoLAN\VLC\vlc.exe
[main] TRACE 19:26:57.556 Registering transcoding engine AviSynth/FFmpeg
[main] TRACE 19:26:57.556 Registering transcoding engine FFmpeg Audio
[main] TRACE 19:26:57.556 Registering transcoding engine MEncoder
[main] TRACE 19:26:57.556 Registering transcoding engine Avisynth/MEncoder
[main] TRACE 19:26:57.556 Registering transcoding engine MPlayer Audio
[main] TRACE 19:26:57.556 Registering transcoding engine MEncoder Web
[main] TRACE 19:26:57.556 Registering transcoding engine MPlayer Video Dump
[main] TRACE 19:26:57.556 Registering transcoding engine MPlayer Web
[main] TRACE 19:26:57.556 Registering transcoding engine TsMuxer
[main] TRACE 19:26:57.556 Registering transcoding engine Audio High Fidelity
[main] TRACE 19:26:57.556 Registering transcoding engine VideoLan Audio Streaming
[main] TRACE 19:26:57.572 Registering transcoding engine VideoLan Video Streaming
[main] TRACE 19:26:57.572 Registering transcoding engine FFmpeg DVR-MS Remux
[main] TRACE 19:26:57.572 Registering transcoding engine Raws Thumbnailer
[main] TRACE 19:26:57.837 Scanning network interface lo / Software Loopback Interface 1
[main] TRACE 19:26:57.837 Scanning network interface net0 / WAN Miniport (SSTP)
[main] TRACE 19:26:57.852 Scanning network interface net1 / WAN Miniport (IKEv2)
[main] TRACE 19:26:57.852 Scanning network interface net2 / WAN Miniport (L2TP)
[main] TRACE 19:26:57.852 Scanning network interface net3 / WAN Miniport (PPTP)
[main] TRACE 19:26:57.852 Scanning network interface ppp0 / WAN Miniport (PPPOE)
[main] TRACE 19:26:57.852 Scanning network interface eth0 / WAN Miniport (IPv6)
[main] TRACE 19:26:57.852 Scanning network interface eth1 / WAN Miniport (Network Monitor)
[main] TRACE 19:26:57.852 Scanning network interface eth2 / WAN Miniport (IP)
[main] TRACE 19:26:57.868 Scanning network interface ppp1 / RAS Async Adapter
[main] TRACE 19:26:57.868 Scanning network interface eth3 / Intel(R) 82567LM-3 Gigabit Network Connection
[main] TRACE 19:26:57.868 Using address /192.168.178.105 found on network interface: name:eth3 (Intel(R) 82567LM-3 Gigabit Network Connection) index: 11 addresses: /192.168.178.105;
[main] TRACE 19:26:57.868 Created socket: /192.168.178.105:5001
[Thread-5] TRACE 19:26:57.868 Starting DLNA Server on host 192.168.178.105 and port 5001...
[main] TRACE 19:26:57.868 Sending ALIVE...
[main] TRACE 19:26:57.899 Using following UUID: 0a45a88a-1392-3b44-b724-388ac3602323
[Thread-5] TRACE 19:27:00.280 Receiving a request from: 192.168.178.101
[main] TRACE 19:27:02.007 It's ready! You should see the server appears on XMB
[AWT-EventQueue-0] TRACE 19:27:05.143 Exception in thread "AWT-EventQueue-0" java.lang.ArrayIndexOutOfBoundsException: 3184
[AWT-EventQueue-0] TRACE 19:27:05.143 at sun.awt.shell.Win32ShellFolder2.getFileChooserIcon(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.143 at sun.awt.shell.Win32ShellFolderManager2.get(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.143 at sun.awt.shell.ShellFolder.get(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.143 at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$LazyWindowsIcon.createValue(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.143 at javax.swing.UIDefaults.getFromHashtable(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.UIDefaults.get(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.MultiUIDefaults.get(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.UIDefaults.getIcon(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.UIManager.getIcon(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.plaf.basic.BasicFileChooserUI.installIcons(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.plaf.basic.BasicFileChooserUI.installDefaults(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.plaf.basic.BasicFileChooserUI.installUI(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at com.sun.java.swing.plaf.windows.WindowsFileChooserUI.installUI(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.JComponent.setUI(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.JFileChooser.updateUI(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.JFileChooser.setup(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.JFileChooser.<init>(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.JFileChooser.<init>(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at net.pms.newgui.FoldTab$14.actionPerformed(FoldTab.java:419)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.Component.processMouseEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at javax.swing.JComponent.processMouseEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.Component.processEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.Container.processEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.Component.dispatchEventImpl(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.Container.dispatchEventImpl(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.Component.dispatchEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.Container.dispatchEventImpl(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.Window.dispatchEventImpl(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.Component.dispatchEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.EventQueue.dispatchEvent(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
[AWT-EventQueue-0] TRACE 19:27:05.158 at java.awt.EventDispatchThread.run(Unknown Source)
[Thread-9] TRACE 19:27:12.023 Sending ALIVE...
tbach
 
Posts: 5
Joined: Mon Apr 27, 2009 3:06 pm

Re: Add folder doesn´t work

Postby tbach » Thu Apr 30, 2009 6:56 pm

Very curiuos,

yesterday, i reinstalled different versions with deleting all files, checking the registry restarting the system, update java .... Nothing works. It was allways the same error by changing the locations.

Now, i started the Setup with right mouse click and use 'run as Administrator' . And it works with all available versions.
tbach
 
Posts: 5
Joined: Mon Apr 27, 2009 3:06 pm

Re: Add folder doesn´t work

Postby meskibob » Thu Apr 30, 2009 7:02 pm

You had to use "Run as Administrator" on a WinXP Admin account? First I've heard that for XP, although Vista has this issue due to the UAC security. Are you running this on an account with custom permissions, and how is your firewall set up?
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4739
Joined: Mon Jan 19, 2009 4:11 pm

Re: Add folder doesn´t work

Postby tbach » Thu Apr 30, 2009 7:25 pm

Sorry, i forgotten describe my system.

I´m using Windows 7. UAC is off. Windows Firewall on.

I´m not shure, if the 'Running as administrator' has solved the problem. But since yesterday, i have not changed anything else.
tbach
 
Posts: 5
Joined: Mon Apr 27, 2009 3:06 pm


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 10 guests