Sees Videos, doesn't see music?

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Sees Videos, doesn't see music?

Postby woffle99 » Tue Apr 14, 2009 10:13 pm

Been using the PS3 MS quite happily to watch videos for a while now and it works great :D

I thought I'd add my music folder to the list of shared folders so I could also listen to my MP3 collection on the PS3 but nothing appears on the PS3 and I'm a bit bemused.

I've set my sharing folders to be:

G:\Video
G:\Music

both have subfolders, but while I can see the Video folder and all of it's files and subfolders in the Video part of the XMB, the Music folder never appears. Saving, restarts all make no difference.

I'm not using the Media Library option (videos work quite happily without it) - do I have to use this to see MP3's for some reason? I've read that it can be quite slow and have a large database if you have a large media collection and mine isn't small.

Can anyone shed any light please?
woffle99
 
Posts: 8
Joined: Wed Feb 25, 2009 11:58 pm

Re: Sees Videos, doesn't see music?

Postby woffle99 » Tue Apr 14, 2009 11:03 pm

OK, so to answer my own question somewhat :? , I read somewhere that if you have PS3 MS installed as a service then running the program as well does not run it as a front end (as I thought) but something else entirely. Therefore I stopped the service, then started the program from the pms.exe and lo, the music folder appeared.

However when I quit the program and restarted the service, the music folder had gone again.

I tried stopping the service, running the program, saving the settings, stopping the program and then starting the service - no effect.

I then tried clicking the button to install the windows service again, thinking maybe it would reinstall it with the new settings - it came up with an error and nothing happened

I then had a rummage around in the Program Folder, found the pms.conf file and opened it in wordpad. I saw that the folders line only had G:\\Video listed so I added ,G:\\Music, saved and restarted the service and finally the music folder appeared.

I then had more of a read around the forums here and found that there are issues with UAC on Vista. I then found a second PMS.Conf file in C:\Users\username\AppData\Roaming\PMS which already had the music folder entry in it. It looks as though the service was referencing the pms.conf file in C:\Program Files\PS3 Media Server and running it from PMS.exe meant it referenced (and updated) one in C:\Users\........... (because UAC meant it could not save to the C:\Program Files location I presume)

The thing I'd like to point out here, hopefully to Shagrath, is that while other settings I had changed when running the console/program/whatever you want to call it as a non-admin did actually take (for instance I changed the thumbnail generation and hid the video settings folder) but adding another folder to the shared folders list didn't.

Having two pms.conf files in two different locations obviously isn't ideal and leads to confusion (though UAC obviously shoulders some of the blame here). Hopefully there is some way that users running PMS as a service and also running UAC on Vista can make changes via the GUI, that update and use only a single pms.conf file - maybe automatically have the pms.exe run as an administrator if UAC is detected to be turned on?
woffle99
 
Posts: 8
Joined: Wed Feb 25, 2009 11:58 pm


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 14 guests