java.lang.UnsatisfiedLinkError: com.sun.jna.Memory.malloc

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

java.lang.UnsatisfiedLinkError: com.sun.jna.Memory.malloc

Postby symon » Sun Mar 30, 2014 5:47 pm

Hi

i have started to see the bellow error:

java.lang.UnsatisfiedLinkError: com.sun.jna.Memory.malloc

i am also not able to see any files in ps3, i see the ps3 media server but when i enter it i get a dlna error 2104

how can i fixed it?

this is the full error:
DEBUG 2014-03-30 19:25:39.556 [New I/O server worker #1-4] Caught exception
java.lang.UnsatisfiedLinkError: com.sun.jna.Memory.malloc(J)J
at com.sun.jna.Memory.malloc(Native Method) ~[pms.jar:1.90.1]
at com.sun.jna.Memory.<init>(Memory.java:78) ~[pms.jar:1.90.1]
at com.sun.jna.ptr.ByReference.<init>(ByReference.java:33) ~[pms.jar:1.90.1]
at com.sun.jna.ptr.LongByReference.<init>(LongByReference.java:21) ~[pms.jar:1.90.1]
at com.sun.jna.ptr.LongByReference.<init>(LongByReference.java:17) ~[pms.jar:1.90.1]
at net.pms.io.WinUtils.getDiskLabel(WinUtils.java:179) ~[pms.jar:1.90.1]
at net.pms.dlna.RealFile.getName(RealFile.java:127) ~[pms.jar:1.90.1]
at net.pms.dlna.DLNAResource.addChild(DLNAResource.java:640) ~[pms.jar:1.90.1]
at net.pms.dlna.RootFolder.discoverChildren(RootFolder.java:106) ~[pms.jar:1.90.1]
at net.pms.dlna.DLNAResource.discoverWithRenderer(DLNAResource.java:803) ~[pms.jar:1.90.1]
at net.pms.dlna.DLNAResource.getDLNAResources(DLNAResource.java:734) ~[pms.jar:1.90.1]
at net.pms.network.RequestV2.answer(RequestV2.java:643) ~[pms.jar:1.90.1]
at net.pms.network.RequestHandlerV2.writeResponse(RequestHandlerV2.java:300) ~[pms.jar:1.90.1]
at net.pms.network.RequestHandlerV2.messageReceived(RequestHandlerV2.java:258) ~[pms.jar:1.90.1]
at org.jboss.netty.handler.stream.ChunkedWriteHandler.handleUpstream(ChunkedWriteHandler.java:149) ~[pms.jar:1.90.1]
at org.jboss.netty.handler.codec.http.HttpChunkAggregator.messageReceived(HttpChunkAggregator.java:116) ~[pms.jar:1.90.1]
at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:302) ~[pms.jar:1.90.1]
at org.jboss.netty.handler.codec.replay.ReplayingDecoder.unfoldAndFireMessageReceived(ReplayingDecoder.java:527) ~[pms.jar:1.90.1]
at org.jboss.netty.handler.codec.replay.ReplayingDecoder.callDecode(ReplayingDecoder.java:506) ~[pms.jar:1.90.1]
at org.jboss.netty.handler.codec.replay.ReplayingDecoder.messageReceived(ReplayingDecoder.java:443) ~[pms.jar:1.90.1]
at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:274) ~[pms.jar:1.90.1]
at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:261) ~[pms.jar:1.90.1]
at org.jboss.netty.channel.socket.nio.NioWorker.read(NioWorker.java:351) ~[pms.jar:1.90.1]
at org.jboss.netty.channel.socket.nio.NioWorker.processSelectedKeys(NioWorker.java:282) ~[pms.jar:1.90.1]
at org.jboss.netty.channel.socket.nio.NioWorker.run(NioWorker.java:202) ~[pms.jar:1.90.1]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) ~[na:1.7.0_25]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) ~[na:1.7.0_25]
at java.lang.Thread.run(Unknown Source) ~[na:1.7.0_25]
symon
 
Posts: 1
Joined: Sun Mar 30, 2014 5:40 pm

Re: java.lang.UnsatisfiedLinkError: com.sun.jna.Memory.mallo

Postby rainnz » Mon Mar 31, 2014 11:44 am

I have exactly the same problem. Everything was working fine yesterday, just started getting the problem today, only change to the system was that there were some updates installed to Microsoft Security Essentials via Windows Update. I get the same error even if i disable MSE.

When selecting PS3 media server on the PS3 to view folders I get DLNA Error 2114 on the PS3.

Debug log: http://pastebin.com/f7AeV28z

EDIT:
I have also tried the latest snapshot build, same error.

EDIT 2:
I have worked out how to get around the issue. I removed all my shared drives and added 1 folder as shared. I now get the folder/file list, but when i play a file I get a HTTP Error (500) on the PS3. This time the error is PMS is
Code: Select all
java.lang.NoClassDefFoundError: Could not initialize class net.pms.io.WindowsNamedPipe$Kernel32


Heres the debug log trace.

http://pastebin.com/X368YKx0
rainnz
 
Posts: 1
Joined: Mon Mar 31, 2014 11:14 am


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 14 guests