Web Streams Aspect Ratio PMSEncoder

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Web Streams Aspect Ratio PMSEncoder

Postby Paradox75 » Sat Dec 21, 2013 5:27 pm

Right firstly my prior setup...
PS3 Media Server version 1.50, PMSencoder 1.6.3, Sony Bravia KDL40-EX403 TV (Using this configuration along with the
-vf softskip,expand=::::1:16/9:2,scale=1283:720 -lavcopts aspect=16/9
tweak to the conf file everything played back 100% perfect).

Now the problem...
I have just done a long overdue upgrade to PS3 Media Server (AKA PMS) from version 1.50 to the latest 1.90.1. PMSEncoder 1.6.3 refused to work with version 1.90.1 of PMS, so i also upgraded PMSencoder to the latest 2.0.0rc3 release.

Now i am having nothing but problems playing back web streams.

As an example i have this in my web.conf file...
videofeed.Web,Revision3=http://revision3.com/hdnation/feed/mp4-hd30


which previously with the old setup mentioned above would stream back flawlessly with the PMS 1.50 and PMSencoder 1.6.3 combo.

However now all the web streams play back with the wrong aspect ratio. Its almost like PMSencoder now just totally ignores custom settings such as -vf softskip,expand=::::1:16/9:2,scale=1283:720 -lavcopts aspect=16/9 for web streams which is required on my sony tv. OR PMS just does not pass custom settings when playing back Web Streams.

That code WORKS 100% fine still for local stored content JUST NOT web streams.

When played back through PMS on my Bravia web streams all end up being displayed with black bars top and bottom (presented on the scream as if it is 2.40 aspect or thereabouts). The image is vertically squashed (IE everyone looks fat or a circle will end up looking like an oval shape). The same thing happens to local stored files without the -vf conf tweak, with it local files are fine.

Ive configured everthing EXACTLY as i had it before with the exception of new versions of the programs obviously and no matter what i try i can not fix the issue. The same problem occurs on the competition UMS and ive even asked over there for advice. I actually prefer PMS for a few reasons (one of which PMSencoder still being supported :) ). I have even tried various Bravia.conf files and even attempted to create my own custom one by going through the PS3.conf file and configuring it with what my Bravia TV needs, with no luck. What is even worse is i can not revert back as it appears sourceforge no longer has old versions of PMS on there.

Can anyone help fix this issue?

If chocolateboy is reading could he perhaps have a look at changes to the code when he gets time between PMS and PMSencoder between the versions ive mentioned to see if anything serious has changed with regards to passing webstreams.

One or the other appears to not be listening to the -vf softskip,expand=::::1:16/9:2,scale=1283:720 -lavcopts aspect=16/9 command with regards to playing back webstreams when it certainly did in earlier revisions.

Thanks to anyone that can help in advance.

EDIT:
PS I still have the old PMSencoder 1.6.3.jar on my system if that should be needed to compare to the newer 2.0.0rc3 version but no longer have the old version of PS3 Media Server 1.50.
Paradox75
 
Posts: 4
Joined: Sat Dec 21, 2013 2:58 am

Re: Web Streams Aspect Ratio PMSEncoder

Postby waker » Thu Jan 09, 2014 6:33 am

i have the same error with PS3 MS 1.90.1 and KDL-60EX700, black bars at TOP & Bottom, error aspect ratio... :(

Why ?

scuse for my english but i'm french...
waker
 
Posts: 3
Joined: Thu Jan 09, 2014 6:26 am

Re: Web Streams Aspect Ratio PMSEncoder

Postby Paradox75 » Sat Jan 18, 2014 2:00 am

Later versions of PMS and UMS for Sony and some Panasonic devices are messed up.

When playing webstreams even if you use mencoder web engine custom commands such as -vf softskip,expand=::::1:16/9:2,scale=1283:720 -lavcopts aspect=16/9 are not passed when processing the stream. Custom FFMpeg commands do not get passed properly either and it wants to treat everything as VOB/DVDFormat transcoding.

PMSEncoder now seems to rely on FFmpeg rather than Mencoder and thus there is no universal command (at least what i can figure out) to get webstreams of various aspect ratios to display correctly. If you have one 16:9 channel/webstream and another 2.35:1 there is no way to get them both to play perfectly as there is no universal fix like the above Mencoder command.

Ive actually now taken to Plex to process just webstreams which works but its annoying having to have 2 DLNA servers running (hate plex for my local stored content as it trys to process some of my weird named files with its brain dead metadata engines).
Paradox75
 
Posts: 4
Joined: Sat Dec 21, 2013 2:58 am


Return to General Help and Support

Who is online

Users browsing this forum: Yahoo [Bot] and 22 guests