Xbox One: Works Partially. Mencoder Question

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Xbox One: Works Partially. Mencoder Question

Postby hav » Sat Nov 30, 2013 10:48 pm

Hi There.

I'm currently using PMS 1.90.1 and Bubble UPNP as my DLNA Controller to send files to the Xbox One.

I have NO codecs installed unless any were installed via the PMS install. Otherwise none.

Currently, videos work, though somewhat laggy. That's not my main nor important question though.

My real issue here is that I don't know how to get the transcoded videos working on Xbox One. I'm also not sure how the renderer should appear to PMS - but my PMS shows either Android (BubbleUPNP) and iPad/iPhone or Unknown Device which I assume are both the Xbox since I don't own any Apple Devices and my network is closed. (I've checked).

That said, if I use BubbleUPNP and browse to a file, and select the file that's NOT in the transcode folder - for instance a MPEG or MKV, it plays. However, it does not play subtitles. I should also point out, that Mencoder videos in the transcoded folder work. So does the "No Encoding" video in most cases. But in neither of those cases does subtitles work. I've tested all variants available to me from within the Transcoding folder. All go to a black screen with no sound or video.

I've tried a few things (many of which were just tinkering and likely wouldnt help. Note, these were all tested independently, on a fresh server restart.

1. I've disabled Use ASS/SSA subtitle styling. No change. (11/30)
2. in the FFmpeg options I've unchecked Remux videos when possible instead of transcoding. No change. (11/30)
3. I've checked the "folder chapter support" button. No change. (I thought it might be because the file had chapters).(11/30)
4. I've checked to make sure "und" and "eng" were in my subtitle language priority (they are). (11/30)
5. I've tested a different controller with the same issue. Transcoded files won't play (they also seem to not play locally on my android phone).(11/30)
6. Iv'e modified my java heap to 4096M in my pms-64.bat To possibly help with the stuttering.(11/30)
7. I've tried disabling tsMuxeR. No effect / change.(11/30)
8. I've updated my NIC Drivers to the most recent version. (12/1)
9. I've disabled Large Send Offload - though this was for the stuttering. (12/1)

I'm kind of stuck here. I'm fairly sure that if I can get the transcoded videos working (any of them, including MEncoder, but also all other options on a clean 1.90.1 install) then they should work on the Xbox One, however my preferred would be MEncoder as it seems to perform the best out of my tests.


The real thing I'd like to get working here would be the subtitles.

The files I'm working with here are MKV h264 hi10 - Audio: AAC / Japanese. Subtitles: Generic/English (English Subtitles). I've tested some non hi10 MKV's as well with the same issue. Mostly it seems I just get a black screen from anything in the transcoding folder.

I unfortunately don't currently have any other renderers available to me though I've had lots of luck with PMS in the past (streaming to both XBox 360, and PS3).

Thanks for your help. I'd include a dump file here, but mine's huge. If there's a specific test you'd like me to run on a clean restart, let me know and I'll provide the debug log for that instead.

Here are some specs that you might need:

Java version 7 Update 45.
Bubble UPNP (latest version as of 11/29)
Xbox One (Currennt latest version as of 11/29 - not sure)
PC Specs :
Core i7 3.07 GHz 4 Cores 8 Logical 12GB Ram 2 Asus 550 Ti's (SLI Disabled)
Networking: PMS -> Router -> UPNP Controller (Sifka / BubbleUPNP) (Wireless) -> Xbox One (wired to router) or Android (Wireless N I believe) .

One final note: I decided to try to get a clean log of the issue. I cleared my log and pressed play on one of the videos with the subtitles from the Transcode section. However literally nothing came up in the log. But if I select one of the videos that do work (such as the MEncoder video at the top of the transcode folder without subtitles, (the one that just says [MEncoder Video]) things occur in the log. But otherwise no.

Mike


EDIT: (2AM 12/1)

I've tested again using different video players using my phone as the UPNP Controller, and sending the video to my android phone (Galaxy Note 3) using MoboPlayer which supposedly doesn't require codecs. In this player I get sound, but no video when playing transcoded videos.

I suspect there's something wrong with either my video file or PS3 Media server at this point as I've tried a few different UPNP controllers, a few renderers, and various settings, but it seems to me like the video is just not outputting for some reason. In the case of the Xbox,there's no sound though whatsoever.

I'm fairly sure this won't get much of a response from the community, but I'm pretty desperate to figure this out, even if only for my android device at this point.

Here's the pastebin link for my mediainfo text file: http://pastebin.com/uNrcYiwb

though on both Xbox One, and android i've tested different files (non hi10 MKV's) and the results are the same across 10+ videos on both devices.

EDIT 2: (2PM 12/1)

I've tested out the PMS 1.90.2 snapshot build with the same results. Transcoded videos are not working on android via my upnp controllers (sifka / BubbleUPNP) to a range of video playback apps (MX Player, ES Video Player, Mobo Player) - however sound works. The "No Encoding" is literally the only version that works, but it runs pretty poorly.

I should probably add that I've tried plex, and some others as well (serviio) neither of them even worked remotely for MKV's during my tests, but I've heard other reports that they do work for the filetype on XBOX One. I didn't bother trying with Android.
hav
 
Posts: 1
Joined: Sat Nov 30, 2013 10:11 pm

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 9 guests