Dolby Digital/AC3 is being decoded by PS3 and passed as PCM?

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Dolby Digital/AC3 is being decoded by PS3 and passed as PCM?

Postby saltboy » Thu Oct 17, 2013 11:23 pm

Hi all, I'm new and currently using PMS 1.90.1. Great program except for *one* small issue that I'd like to have addressed, if possible.

I notice that with MKV files containing DTS, the DTS audio is passed straight through by my PS3 to my amp for decoding (seen as LPCM 2.0 by the PS3, but the Amp shows DTS and it still sounds legit/5.1 channels, etc.).

MKV files containing Dolby Digital/AC3, however, do NOT pass the audio all the way through to my Amp. While the PS3 info screen correctly interprets the audio as being Dolby Digital, the audio is being decoded by the PS3 and ultimately passed to my amp in PCM format. I can confirm this is the case because I am able to change the audio's volume within the on-screen PS3 video settings. And of course, the Amp doesn't show Dolby Digital but rather the PCM equivalent (MultiChannel in my case)

Is there any way to configure my setup so that the Dolby Digital audio gets completely passed through by the PS3 to my Amp so that the Amp can do the decoding rather than the PS3?

Here's my Transcoding Settings -> Common Transcode Settings -> Audio settings:

Maximum number of audio channels = 6 (5.1)
Use LPCM for audio = unchecked
Keep AC-3 tracks = checked
Keep DTS tracks = checked
AC-3 reencode bitrate = 640

I'm using txMuxeR as the video engine and have disabled all other muxers. The decoder settings for txMuxeR engine are:

Force FPS parsed from FFmpeg = checked
Mux all audio tracks = checked

It does seem to me that the "Keep AC-3 tracks = checked" setting *should* pass the audio through, but I imagine that could also mean that no decoding is done on the stream before it's sent to the PS3. I can confirm that the bitrate on some of these files is NOT 640 (per the reencode bitrate settings above), so no reencoding appears to be happening server-side.

Also, on my PS3's #video settings# folder (that PMS creates), I can see a lot of settings (including the option to check/uncheck "Keep DTS tracks") but I don't see any option to check/uncheck "Keep AC-3 tracks".

If it's the PS3 that's causing this problem overall, then I'm not sure why - the DD audio from regular DVDs are being passed to and decoded properly by the Amp.

Any Help you can offer would be most appreciated!! :-)
saltboy
 
Posts: 2
Joined: Thu Oct 17, 2013 11:01 pm

Re: Dolby Digital/AC3 is being decoded by PS3 and passed as

Postby saltboy » Fri Oct 18, 2013 4:27 am

Ah, never mind. I found the answer:

viewtopic.php?f=6&t=4646&start=0

worked like a charm....
saltboy
 
Posts: 2
Joined: Thu Oct 17, 2013 11:01 pm


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 12 guests