[SOLVED] PMS Windows Service doesn't work after Java update

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

[SOLVED] PMS Windows Service doesn't work after Java update

Postby cambies » Sun Sep 29, 2013 10:44 am

Hi, i've been searching for someone with a similar problem for the last hour but no joy. Hoping one of you can help me out here.

I run windows 8 pro with PMS 1.90.1 installed as a windows service, it's a small home wired network. After the last Java update i can no longer view the server or devices. The PS3 Media Server service does start but it just doesn't work.

The strange thing is, if i stop the service and start PMS.exe everything works fine.

I have uninstalled and reinstalled and rebooted PMS and Java several times, the only way i've been able to get it to work is to revert back to the old version of Java i had before, this is not ideal as it constantly prompts for updates.

Any help would be appreciated.

cheers, Paul

---------------------------------------------------------------------------------------------------------------------
Solution:

Apparently Java doesn't update windows firewall when it installs updates, or it just didn't on mine for some reason.

I resolved this issue by first stopping the PMS Service, then deleting every PS3 Media Server and Java related rules from the firewall.

I ran Wrapper.exe and then PMS.exe and allowed new exceptions to the firewall for both.

Restarted computer and back in business.

Hope this helps someone else.

Cheers
Last edited by cambies on Sun Sep 29, 2013 12:12 pm, edited 1 time in total.
cambies
 
Posts: 2
Joined: Sun Sep 29, 2013 10:33 am

Re: PMS Windows Service no longer works after last Java upda

Postby mazey » Sun Sep 29, 2013 10:56 am

try running the wrapper.exe file from "c:\program files (x86)\ps3 media server\win32" then you should get a firewall notification popup then hit allow, close the box and then run it as a service again.
PMS 1.90.2 SNAPSHOT - HP Proliant Microserver N54L 2.2Ghz - Windows Home Server 2011 (64bit) 8GB - Bravia KDL55HX750
mazey
 
Posts: 770
Joined: Sat Oct 24, 2009 9:07 am

Re: PMS Windows Service no longer works after last Java upda

Postby cambies » Sun Sep 29, 2013 11:15 am

mazey wrote:try running the wrapper.exe file from "c:\program files (x86)\ps3 media server\win32" then you should get a firewall notification popup then hit allow, close the box and then run it as a service again.


Thanks for the reply.

I did that it opened a console scrolled a bunch of stuff. I didn't get any firewall prompts, also I don't use anti virus either.

BTW also couldn't find the server after doing this.

Cheers
cambies
 
Posts: 2
Joined: Sun Sep 29, 2013 10:33 am

Re: [SOLVED] PMS Windows Service doesn't work after Java upd

Postby naufana » Mon Sep 30, 2013 10:22 pm

I am having the same problem but I don't have a "wrapper.exe" Is it supposed to be installed with PMS or do I have to dl it somewhere?
naufana
 
Posts: 1
Joined: Sat Jan 23, 2010 4:55 pm

Re: [SOLVED] PMS Windows Service doesn't work after Java upd

Postby mazey » Tue Oct 01, 2013 12:31 am

naufana wrote:I am having the same problem but I don't have a "wrapper.exe" Is it supposed to be installed with PMS or do I have to dl it somewhere?


you should if your running windows, are you sure you checked the folder "c:\program files (x86)\ps3 media server\win32"
PMS 1.90.2 SNAPSHOT - HP Proliant Microserver N54L 2.2Ghz - Windows Home Server 2011 (64bit) 8GB - Bravia KDL55HX750
mazey
 
Posts: 770
Joined: Sat Oct 24, 2009 9:07 am

Re: [SOLVED] PMS Windows Service doesn't work after Java upd

Postby enchanted » Tue Jan 14, 2014 7:46 am

If you add the program at C:\Program Files (x86)\PS3 Media Server\jre64\bin\java to you firewall most likely "Control Panel\All Control Panel Items\Windows Firewall\Allowed apps" this will fix it. The program calls the java located here. This will create and additional Java(TM) Platform SE binary entry in you firewall.
enchanted
 
Posts: 1
Joined: Tue Jan 14, 2014 7:40 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 6 guests