Problems with MEncoder since migration to Fedora 19

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Problems with MEncoder since migration to Fedora 19

Postby Mokona_qc » Tue Sep 03, 2013 3:16 am

Hi,

I have been using PMS for about a year now without a hitch. I was using it under Fedora 18 with no problems. However, this week, I upgraded to Fedora 19, and although PMS still works, I've been having trouble with playback on my PS3:
Most avi files don't work with MEncoder anymore (not even starting video)
Most mkv files start fine using MEncoder, but the sound is just one big noise

Although I've disabled MEncoder in the config, it still shows as the default encoder for all files.

I can use FFMpeg to play most files ok in the ## TRANSCODE ## folder, however, I can't have sound + subtitles this way on the mkv files, because FFMpeg doesn't allow me to load the subtitles...

Any help is welcome. If I need to copy some info from a config file, let me know.

Thanks in advance.
Mokona_qc
 
Posts: 3
Joined: Tue Sep 03, 2013 3:08 am

Re: Problems with MEncoder since migration to Fedora 19

Postby Mokona_qc » Fri Sep 06, 2013 3:29 am

Hello again,

I managed to run videos with sound using FFMpeg and VLC codecs (Mencoder is still disabled, sound doesn't work when it's activated and is the default encoder).
Now I've run into another problem: FFMpeg won't display embedded subs in mkvs (I think it just can't right now in PMS, so I guess it's ok). I have working embedded subs in mkvs using VLC as the encoder, but for some reason, on select mkvs, the subs won't show (I think it's because they aren't labelled as Eng, Fre, etc. But although I have "und" as a category, they still won't show up...)
Another problem is that I have no sound (not even noise) in mp4 files when using VLC as the encoder (but the sound is fine if FFMpeg is the encoder). Not a huge problem, unless I have a mp4 with subs, which is very unlikely.

Any help is appreciated. Since the problem is kinda different now (i.e. subs not showing in select mkvs using VLC), I may have to start a new thread... I'll see what responses I get on that one first.

Thanks.
Mokona_qc
 
Posts: 3
Joined: Tue Sep 03, 2013 3:08 am

Re: Problems with MEncoder since migration to Fedora 19

Postby d3m0n1q_733rz » Sat Sep 07, 2013 11:18 am

What is the sound format in the mkvs? And you can modify the subtitle language in the embedded subs, but I can't recall the program to demux and remux it. Google MKV demux or remux and it should be easy to find. It's totally lossless so no big deal. You could probably remux it to AVI and have it play on the PS3 outright without transcoding as it's just a container format.

You might just be able to remove en as the forced language format and have it work properly.
d3m0n1q_733rz
 
Posts: 40
Joined: Fri Sep 06, 2013 7:54 am

Re: Problems with MEncoder since migration to Fedora 19

Postby Mokona_qc » Sat Sep 14, 2013 4:02 am

The sound in the mkvs is MPEG-4 AAC. I didn't check all the files, but I'm pretty sure there might be some other formats in other files, and I think the result would still be the same.
I'll keep an eye out for updates of mencoder and check again if the issue is solved over time. In the meantime, the VLC codec does most of what I want.

Thanks for the feedback.
Mokona_qc
 
Posts: 3
Joined: Tue Sep 03, 2013 3:08 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot] and 16 guests