Embedded subtitles don't play, some are too large.

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Embedded subtitles don't play, some are too large.

Postby jusefarabi » Wed Apr 08, 2009 12:34 pm

Here are my specs, although I assume they are irrelevant.

E6850 C2D(3ghz) on evga 680i - 2GB DDR2-800 - 8800GTX - Windows XP Pro SP3.

PS3 Media Server 1.10.51


My problem is that on some of my files subtitles do not play, or that some play at massive font sizes much too large to read.

I Mainly use PS3 Media Server to stream subtitled anime to my PS3.

[SS]_Hyakko_-_04_(1280x720_h264)_[81AE0001].mkv - This file will play the Karaoke opening without issue, but when the dialogue begins during the show the font-size sprawls literally across the entire height and width of the screen. The first three files did not do this, but the font size was still relatively large.

[gg]_Maria+Holic_-_01_[A3E95F38].mkv - This file will not render any subtitles. They are not listed at all in the transcode folder in anyway, they simply do not show. When I peer into the file itself it has embedded ASS and a massive amount of true-type fonts.

Anyways, that my dilemma, otherwise it's a fine program.

If anyone can help me in anyway I'd greatly appreciate it, be it downgraded my OS or upgrading, different PC codecs whatever it might take I'm capable of doing. Thanks I appreciate it!
jusefarabi
 
Posts: 3
Joined: Wed Apr 08, 2009 12:21 pm

Re: Embedded subtitles don't play, some are too large.

Postby Gaia » Wed Apr 08, 2009 2:24 pm

I have Hyakko as well from SS downloaded and I get large subs, but SS subs for that show are large anyway. Try enabling the "Use ASS default style" under the MEncoder settings, I think it will shrink the size of them a bit.

I can't even get the gg Maria Holic 01 to work in PS3 Media Server, it crashes the codec. All other Maria Holic files after 01 play though, with the exception of episode 11, seems to have the same problem as 01.
Gaia
 
Posts: 6
Joined: Wed Apr 08, 2009 3:31 am

Re: Embedded subtitles don't play, some are too large.

Postby jusefarabi » Thu Apr 09, 2009 12:39 am

Okay, well I only mention this for the sake of the developers of PS3MediaServer.

Using Tversity 1.0 RC7 and this playback guide Method A (http://forums.tversity.com/viewtopic.php?f=28&t=8063)

I was able to get fonts to render on Maria Holic in the correct style and size.

Also, the fonts on Hyakko rendered in the correct size.

Sadly the quality and functionality of Tversity is not as good as PS3MediaServer, but I guess switching back and forth is a reasonable solution to my problem right now.


But if taking a look at that playback method can give you developers any clues, hope it helps.
jusefarabi
 
Posts: 3
Joined: Wed Apr 08, 2009 12:21 pm

Re: Embedded subtitles don't play, some are too large.

Postby shagrath » Thu Apr 09, 2009 12:41 am

or you install AviSynth, and launch the AviSynth/Mencoder engine
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Embedded subtitles don't play, some are too large.

Postby jusefarabi » Thu Apr 09, 2009 7:07 am

Will that do the trick, I'll try that then, Thanks for the response.

I wasn't mention Tversity to insult you! dont get mad.


Thanks! Works a charm! Wish I knew all that beforehand could have saved myself a couple hours of fiddling.

One thing I notice is that playback isnt as smooth with avisynth/mencoder, is that due to a higher load on the CPU?
jusefarabi
 
Posts: 3
Joined: Wed Apr 08, 2009 12:21 pm


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot] and 17 guests