Error with PSM/Mencoder, need some help please.

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Error with PSM/Mencoder, need some help please.

Postby resque1980 » Tue Jun 25, 2013 12:42 am

I am getting a very annoying error when transcoding files with mencoder. I cant seem to narrow it down to a particular format or encoding. But I can confirm it happens with a lot of MKVs with subtitles. Mencoder crashes after aprox 10min with the following error:
"[mencoder.exe-2] Process C:\...\mencoder.exe has a return code of -1073741819! Maybe an error occurred... check the log file"

A quick google turns up with access violation:
"-1073741819 = 0xFFFFFFFFC0000005 which is general access violation exception (you are trying to read/write/execute to/from memory which is not allocated for that purpose)."

A had a read through the PMS debug.log, grabed the mencoder line that was being executed and tried to run it manually from "cmd.exe". The only thing I changed was the very last argument from "-o \\.\pipe\mencoder1372114722618" to "-o output.asf". The command worked fine and finished transcoding the movie. I was able to play the movie fine in vlc and on my xbox 360.
mencoder.exe" -ss 0 "D:\Anime\The Melancholy of Haruhi Suzumiya [BD][720p][MP4][AAC]\[DeadFish] The Melancholy of Haruhi Suzumiya - 01 [BD][720p][AAC].mp4" -msglevel statusline=2 -oac lavc -of lavf -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -vf expand=-64:-64:32:32 -lavdopts debug=0:threads=2:skiploopfilter=all -lavcopts autoaspect=1:vcodec=wmv2:acodec=wmav2:abitrate=448:threads=1:keyint=5:vqscale=1:vqmin=2:vrc_maxrate=14000:vrc_buf_size=1835 -nosub -noautosub -ofps 24000/1001 -lavdopts fast -mc 0.1 -af lavcresample=44100 -srate 44100 -o \\.\pipe\mencoder1372114722618

I am running the follow software versions:
PS3 Media Server 1.82.0 Build: 616a9b305 (2013-06-03)
java version "1.7.0_21"
Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)

I also thought it would be helpful to share the PSM log files and mediainfo output for the most recent movie this error is happening with.

MediaInfo -[DeadFish] The Melancholy of Haruhi Suzumiya - 01 [BD][720p][AAC].mp4.txt



I need some help to figure out what to do next and try and resolve this issue. Does anyone know how to fix this issue or what i can do next to narrow the issue down?
Posts: 6
Joined: Tue Dec 11, 2012 10:21 pm

Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 7 guests