After Java Update PMS stopped working (Mac)

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

After Java Update PMS stopped working (Mac)

Postby KasparV » Fri Apr 19, 2013 4:33 pm

This morning there was an update for my Mac available, which included a Java-update. Unluckily though, I also changed some things on my router yesterday, so I am not 100% sure if the update is to blame, I tried different ports, reinstalled and deleted my PMS folder in Application Support, this is what the Traces show:

Code: Select all
INFO  2013-04-19 17:31:10.806 [main] Starting PS3 Media Server 1.80.0
INFO  2013-04-19 17:31:10.808 [main] by shagrath / 2008-2012
INFO  2013-04-19 17:31:10.809 [main] http://ps3mediaserver.org
INFO  2013-04-19 17:31:10.809 [main] https://github.com/ps3mediaserver/ps3mediaserver
INFO  2013-04-19 17:31:10.810 [main]
INFO  2013-04-19 17:31:10.810 [main] Build: a2f3e866b (2013-04-02)
INFO  2013-04-19 17:31:10.811 [main] Java: 1.6.0_45-Apple Inc.
INFO  2013-04-19 17:31:10.811 [main] OS: Mac OS X x86_64 10.8.3
INFO  2013-04-19 17:31:10.812 [main] Encoding: UTF-8
INFO  2013-04-19 17:31:10.812 [main] Memory: 759 MB
INFO  2013-04-19 17:31:10.812 [main]
INFO  2013-04-19 17:31:10.813 [main] Working directory: /Applications/PS3 Media Server.app/Contents/Resources/Java
INFO  2013-04-19 17:31:10.820 [main] Temp directory: /var/folders/bd/8j8hqh1j0458l6f85hgg4hcm0000gn/T/ps3mediaserver
INFO  2013-04-19 17:31:10.821 [main] Logging config file: /Applications/PS3 Media Server.app/Contents/Resources/Java/logback.xml
INFO  2013-04-19 17:31:10.822 [main] debug.log: /Applications/PS3 Media Server.app/Contents/Resources/Java/debug.log
INFO  2013-04-19 17:31:10.823 [main]
INFO  2013-04-19 17:31:10.823 [main] Profile directory: /Users/KasparV/Library/Application Support/PMS
INFO  2013-04-19 17:31:10.823 [main] Profile path: /Users/KasparV/Library/Application Support/PMS/PMS.conf
INFO  2013-04-19 17:31:10.824 [main] Profile permissions: rw
INFO  2013-04-19 17:31:10.825 [main] Profile name: macbook-pro-van-kaspar.fritz.box
INFO  2013-04-19 17:31:10.825 [main]
INFO  2013-04-19 17:31:10.828 [main] Loading MediaInfo library
INFO  2013-04-19 17:31:10.896 [main] Loaded MediaInfoLib - v0.7.61
INFO  2013-04-19 17:31:10.907 [main] Loading renderer configurations from /Applications/PS3 Media Server.app/Contents/Resources/Java/renderers
INFO  2013-04-19 17:31:10.907 [main] Loading configuration file: AirPlayer.conf
INFO  2013-04-19 17:31:10.912 [main] Loading configuration file: Android.conf
INFO  2013-04-19 17:31:10.916 [main] Loading configuration file: Bravia4500.conf
INFO  2013-04-19 17:31:10.920 [main] Loading configuration file: Bravia5500.conf
INFO  2013-04-19 17:31:10.925 [main] Loading configuration file: BraviaEX.conf
INFO  2013-04-19 17:31:10.932 [main] Loading configuration file: BraviaHX.conf
INFO  2013-04-19 17:31:10.939 [main] Loading configuration file: DirecTVHR.conf
INFO  2013-04-19 17:31:10.945 [main] Loading configuration file: DLinkDSM510.conf
INFO  2013-04-19 17:31:10.949 [main] Loading configuration file: FreeboxHD.conf
INFO  2013-04-19 17:31:10.954 [main] Loading configuration file: FreecomMusicPal.conf
INFO  2013-04-19 17:31:10.958 [main] Loading configuration file: iPad-iPhone.conf
INFO  2013-04-19 17:31:10.962 [main] Loading configuration file: Kuro.conf
INFO  2013-04-19 17:31:10.967 [main] Loading configuration file: LGST600.conf
INFO  2013-04-19 17:31:11.003 [main] Loading configuration file: N900.conf
INFO  2013-04-19 17:31:11.008 [main] Loading configuration file: OPPOBDP83.conf
INFO  2013-04-19 17:31:11.011 [main] Loading configuration file: OPPOBDP93.conf
INFO  2013-04-19 17:31:11.015 [main] Loading configuration file: Panasonic.conf
INFO  2013-04-19 17:31:11.021 [main] Loading configuration file: Philips.conf
INFO  2013-04-19 17:31:11.025 [main] Loading configuration file: PhilipsPFL.conf
INFO  2013-04-19 17:31:11.035 [main] Loading configuration file: PopcornHour.conf
INFO  2013-04-19 17:31:11.037 [main] Loading configuration file: PS3.conf
INFO  2013-04-19 17:31:11.046 [main] Loading configuration file: Realtek.conf
INFO  2013-04-19 17:31:11.050 [main] Loading configuration file: Samsung-SMT-G7400.conf
INFO  2013-04-19 17:31:11.058 [main] Loading configuration file: SamsungAllShare.conf
INFO  2013-04-19 17:31:11.060 [main] Loading configuration file: SamsungWiseLink.conf
INFO  2013-04-19 17:31:11.062 [main] Loading configuration file: Showtime3.conf
INFO  2013-04-19 17:31:11.065 [main] Loading configuration file: SMP-N100.conf
INFO  2013-04-19 17:31:11.069 [main] Loading configuration file: SonyBluray.conf
INFO  2013-04-19 17:31:11.074 [main] Loading configuration file: Streamium.conf
INFO  2013-04-19 17:31:11.077 [main] Loading configuration file: WDTVLive.conf
INFO  2013-04-19 17:31:11.079 [main] Loading configuration file: WMP.conf
INFO  2013-04-19 17:31:11.082 [main] Loading configuration file: XBMC.conf
INFO  2013-04-19 17:31:11.084 [main] Loading configuration file: XBOX360.conf
INFO  2013-04-19 17:31:11.087 [main] Loading configuration file: YamahaRXA1010.conf
INFO  2013-04-19 17:31:11.089 [main] Loading configuration file: YamahaRXV671.conf
INFO  2013-04-19 17:31:11.090 [main] Checking MPlayer font cache. It can take a minute or so.
DEBUG 2013-04-19 17:31:11.091 [main] launching: osx/mplayer
INFO  2013-04-19 17:31:11.143 [main] Done!
INFO  2013-04-19 17:31:11.150 [main] Searching for plugins in /Applications/PS3 Media Server.app/Contents/Resources/Java/plugins
INFO  2013-04-19 17:31:11.151 [main] No plugins found
INFO  2013-04-19 17:31:11.162 [main] Registering transcoding engine: FFmpeg Audio
INFO  2013-04-19 17:31:11.166 [main] Registering transcoding engine: MEncoder
INFO  2013-04-19 17:31:11.167 [main] Registering transcoding engine: FFmpeg
INFO  2013-04-19 17:31:11.169 [main] Registering transcoding engine: VLC
INFO  2013-04-19 17:31:11.170 [main] Registering transcoding engine: MPlayer Audio
INFO  2013-04-19 17:31:11.170 [main] Registering transcoding engine: FFmpeg Web Video
INFO  2013-04-19 17:31:11.171 [main] Registering transcoding engine: MEncoder Web
INFO  2013-04-19 17:31:11.171 [main] Registering transcoding engine: MPlayer Video Dump
INFO  2013-04-19 17:31:11.172 [main] Registering transcoding engine: MPlayer Web
INFO  2013-04-19 17:31:11.174 [main] Registering transcoding engine: tsMuxeR
INFO  2013-04-19 17:31:11.175 [main] Registering transcoding engine: Audio High Fidelity
INFO  2013-04-19 17:31:11.176 [main] Registering transcoding engine: VLC Audio Streaming
INFO  2013-04-19 17:31:11.177 [main] Registering transcoding engine: VLC Video Streaming
INFO  2013-04-19 17:31:11.177 [main] Registering transcoding engine: dcraw Thumbnailer
INFO  2013-04-19 17:31:11.271 [main] Using address /192.168.178.41 found on network interface: name:en1 (en1)
INFO  2013-04-19 17:31:11.273 [main] Created socket: /192.168.178.41:5001
DEBUG 2013-04-19 17:31:11.434 [main] Sending ALIVE...
DEBUG 2013-04-19 17:31:11.442 [main] Error sending ALIVE message
java.net.SocketException: Can't assign requested address
   at java.net.PlainDatagramSocketImpl.socketSetOption(Native Method) ~[na:1.6.0_45]
   at java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:309) ~[na:1.6.0_45]
   at java.net.MulticastSocket.setNetworkInterface(MulticastSocket.java:536) ~[na:1.6.0_45]
   at net.pms.network.UPNPHelper.getNewMulticastSocket(UPNPHelper.java:222) ~[pms-1.80.0.jar:na]
   at net.pms.network.UPNPHelper.sendAlive(UPNPHelper.java:169) ~[pms-1.80.0.jar:na]
   at net.pms.PMS.init(PMS.java:550) [pms-1.80.0.jar:na]
   at net.pms.PMS.createInstance(PMS.java:795) [pms-1.80.0.jar:na]
   at net.pms.PMS.main(PMS.java:869) [pms-1.80.0.jar:na]
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.6.0_45]
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) ~[na:1.6.0_45]
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) ~[na:1.6.0_45]
   at java.lang.reflect.Method.invoke(Method.java:597) ~[na:1.6.0_45]
   at apple.launcher.LaunchRunner.run(LaunchRunner.java:116) [na:na]
   at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51) [na:na]
   at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52) [na:na]
INFO  2013-04-19 17:31:11.696 [main] The server should now appear on your renderer
ERROR 2013-04-19 17:31:11.696 [UPNPHelper] UPNP network exception
java.net.SocketException: Can't assign requested address
   at java.net.PlainDatagramSocketImpl.socketSetOption(Native Method) ~[na:1.6.0_45]
   at java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:309) ~[na:1.6.0_45]
   at java.net.MulticastSocket.setNetworkInterface(MulticastSocket.java:536) ~[na:1.6.0_45]
   at net.pms.network.UPNPHelper$2.run(UPNPHelper.java:363) ~[pms-1.80.0.jar:na]
   at java.lang.Thread.run(Thread.java:680) [na:1.6.0_45]
ERROR 2013-04-19 17:31:12.701 [UPNPHelper] UPNP network exception
java.net.SocketException: Can't assign requested address
   at java.net.PlainDatagramSocketImpl.socketSetOption(Native Method) ~[na:1.6.0_45]
   at java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:309) ~[na:1.6.0_45]
   at java.net.MulticastSocket.setNetworkInterface(MulticastSocket.java:536) ~[na:1.6.0_45]
   at net.pms.network.UPNPHelper$2.run(UPNPHelper.java:363) ~[pms-1.80.0.jar:na]
   at java.lang.Thread.run(Thread.java:680) [na:1.6.0_45]


The error message keeps repeating itself constantly, can anyone tell me if I did something wrong or it is just the Java-update?
Appreciate the help :)
KasparV
 
Posts: 8
Joined: Sun Aug 21, 2011 5:17 pm

Re: After Java Update PMS stopped working (Mac)

Postby KasparV » Fri Apr 19, 2013 5:02 pm

Actually found another topic in the Mac specific forum so if this looks familiar to anyone, here's the link to that topic:
viewtopic.php?f=7&t=16638&start=20
KasparV
 
Posts: 8
Joined: Sun Aug 21, 2011 5:17 pm

Re: After Java Update PMS stopped working (Mac)

Postby Larlok » Fri Apr 19, 2013 5:59 pm

Have the same problem.
Larlok
 
Posts: 1
Joined: Fri Apr 19, 2013 5:57 pm

Re: After Java Update PMS stopped working (Mac)

Postby PhillyGuy » Sun Apr 21, 2013 7:41 pm

Same here too, drove me nuts for 2 days, trying to roll back the Java last night with no success (darn Java!)
ANYWAY..If you havn't already, the 1.81 update is now available that fixes this problem. ( viewtopic.php?f=8&t=16669 )

I just installed it on my Mac, loaded it up. Everything is back to normal.
Hope it helped. :D
User avatar
PhillyGuy
 
Posts: 2
Joined: Sun Apr 21, 2013 7:20 pm


Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 21 guests