Audio Video Sync Issues

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Audio Video Sync Issues

Postby catsfall » Tue Mar 19, 2013 12:51 am

Hello all-

Although this is my first post, I've been all over the forums and there does not seem to be a consolidated answer to my current issues.

-- And while I was troubleshooting to build all this, I had to install mediainfo- which seems to have solved the main problem of audio out of sync. MediaInfo is found from the link on the About tab in PMS under helpful links. However, now the same movies that had out of sync audio are showing frame jumping- debug.txt indicates there is a duplicate frame every few frames. Also, those files were playing 5.1 but are now playing stereo (other files are still playing 5.1).

DEBUG 2013-03-18 19:35:59.566 [Thread-42] 1 duplicate frame(s)!
DEBUG 2013-03-18 19:36:00.494 [Thread-42]
DEBUG 2013-03-18 19:36:00.494 [Thread-42] 1 duplicate frame(s)!
DEBUG 2013-03-18 19:36:00.566 [Thread-42]
DEBUG 2013-03-18 19:36:00.566 [Thread-42] 1 duplicate frame(s)!
DEBUG 2013-03-18 19:36:00.941 [Thread-42]
DEBUG 2013-03-18 19:36:00.941 [Thread-42] 1 duplicate frame(s)!
DEBUG 2013-03-18 19:36:01.011 [Thread-42]
DEBUG 2013-03-18 19:36:01.011 [Thread-42] 1 duplicate frame(s)!
DEBUG 2013-03-18 19:36:01.088 [Thread-42]
DEBUG 2013-03-18 19:36:01.088 [Thread-42] 1 duplicate frame(s)!
DEBUG 2013-03-18 19:36:01.167 [Thread-42]
DEBUG 2013-03-18 19:36:01.167 [Thread-42] 1 duplicate frame(s)!

I'm leaving everything below because it might be helpful to anyone having Audio video sync issues... More to follow if I can solve the duplicate frames.
------------- Below for reference only -----------------
I have PMS running just fine on a Windows Vista machine- I only started working with it in mid February. After spending a lot of time configuring and tweaking, most of my movies are streaming well from a NAS device to the PS3. However, a few movies just will not sync audio and video. Audio lags video significantly and the video appears to be playing much too fast (but not so fast as to be stuck on ff). The lag gets worse- I think- as the movie plays. Because I can play the same rips locally on the PC, this appears to be a PMS setting or transcode issue.

The overall goal here is to get these movies to successfully stream with best quality sound and video, preferably 5.1 where available, without negatively affecting anything that is already working. I am not using any Blu-Ray or high-def content at this stage of my implementation.

Details:
All movies were ripped using DVDFab (8.2.2.8) and encoded using Handbrake (0.9.8).
I am using the .mkv container, x264 video engine, and have tried almost all of the audio engines in Handbrake.
Before attempting to serve any encode, I check that it plays correctly on the local PC using VLC (2.0.5).
The PS3 is the only client renderer in use on my network (other renderers created different issues, which I'll cover later if I get around to properly troubleshooting).
The network is wired, gigabit ethernet to all devices, via a TrendNet switch with adequate backplane to guarantee bandwidth.
I have used the same techniques on other DVD media successfully.

I have played a LOT with the PMS settings and have not noticed any changes to behavior on the affected rips- the audio lags on these titles no matter what. Note that some settings changes did cause issues, and for the benefit of others who are having issues I will outline my experiences below.

Here are the various devices, logs, and sample files that are causing problems:

All devices are on a local network, TrendNet TEG-S80G gigabit switch.

Server:
Toshiba Satellite P200, Core 2 Duo T5500 @1.66GHz, gigabit ethernet, 4 GB RAM.
Running PMS 1.72.0, build d9fd0a44c, 2012-11-18. No add-ins. See below for specific settings.
OS: Windows Vista Home Basic 32-bit, up to date with all service packs and updates as of 3/17/2013.
The OS was built clean from manufacturer install disc; bloatware removed but all other OS items intact.

Storage:
PMS is serving files on the local network through persistent network connections (Windows managed), on an iomega storcenter ix2-dl. The Twonky media server on the Iomega is disabled (it interfered with PMS during early implementation). I have no evidence that the storage media or method is any part of the problem but am including for accuracy.

Renderer:
PS3 Version 4.31 software. This is one of the newer, all-black thin PS3 units.

Network:
PMS ->Realtek GBE ExpressCard -> TrendNet TEG-S80g GBE switch-> iomega storcenter ix2-dl -> PS3 (via TrendNet switch)

Current PMS settings have all transcode engines except MEncoder disabled. I tried using FFmpeg and tsMuxer- forcing- by disabling others- with no change in symptoms.
I saved and restarted PMS between all settings changes below. I can't promise there was a PC restart between each settings change but I did try to be disciplined about doing that as well.
I tried making adjustments to PMS-> Transcoding settings -> MEncoder as follows:
A/V Sync alternative method -> on or off makes no difference (off seems to make the problem worse, but I can't tell for sure)
Force framerate parsed from ffMPEG -> on or off makes no difference (can't tell a difference)
Both above on, both above off, no difference
Currently both are on

Adjusted PMS -> Transcoding settings -> General as follows (independent and in combination with above):
Buffer maximum currently set at 400. I had a lot of problems with skipping when it was set to 600; I have not since taken it above 400. Buffer fills normally when playing affected files.
Use LPCM for audio -> off or on, no changes. Currently off.
Keep AC-3 track -> on or off, no changes. Currently on.
Keep DTS track -> off. Did not adjust due to warning and the fact that other movies work with this off.
Remux DVD ISO video track -> on (no changes; appears this should only affect ISO files which I am not using)

Specific files are not working; most files are working just fine. I believe there is a common symptom in the files, possibly in the source media. I am attaching logs per recommendations (debug log, media info, and a file sample where it's easy to tell).

Also tried this fix: viewtopic.php?f=7&t=3997
which seems closely related but I think my framerate is 23.976 and being interpreted as 23.97 according to debug.log

viewtopic.php?f=7&t=16065
This was no help but seems to be very closely related. I will roll backwards if I need to but the fine folks here seem to have put so much work into going from version 1.54 to version 1.72.


To everyone that is working on this project- PMS does exactly what I need it to but it's not Plug and Play yet, and the forums/ help files need cleaning up quite a bit. Still- job well done.
catsfall
 
Posts: 1
Joined: Mon Mar 18, 2013 7:17 pm

Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 23 guests