Please Help - Configuration error: java.lang.NoClassDefFound

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Please Help - Configuration error: java.lang.NoClassDefFound

Postby swamanator » Sat Mar 16, 2013 3:40 pm

Hello,

I have been trying to solve this issue since 3 days now. I have tried to reference every post on the forum so far to fix this issue, reinstalled PS3MS like 4 times, reinstalled JRE/JDK around 2 times each. Still I am having no luck....

I was running an older version of PMS (1.6x) and that was working like a charm. Now that I upgraded to latest...I am getting errrors :-(

Thank you!

Code: Select all
INFO  2013-03-16 10:37:11.055 [main] Starting PS3 Media Server 1.72.0
INFO  2013-03-16 10:37:11.080 [main] by shagrath / 2008-2012
INFO  2013-03-16 10:37:11.086 [main] http://ps3mediaserver.org
INFO  2013-03-16 10:37:11.088 [main] https://github.com/ps3mediaserver/ps3mediaserver
INFO  2013-03-16 10:37:11.091 [main]
INFO  2013-03-16 10:37:11.092 [main] Build: d9fd0a44c (2012-11-18)
INFO  2013-03-16 10:37:11.097 [main] Java: 1.7.0_17-Oracle Corporation
INFO  2013-03-16 10:37:11.100 [main] OS: Windows 7 amd64 6.1
INFO  2013-03-16 10:37:11.102 [main] Encoding: UTF-8
INFO  2013-03-16 10:37:11.104 [main] Memory: 682 MB
INFO  2013-03-16 10:37:11.105 [main]
INFO  2013-03-16 10:37:11.106 [main] Working directory: C:\Program Files (x86)\PS3 Media Server
INFO  2013-03-16 10:37:11.114 [main] Temp directory: C:\Users\Swami\AppData\Local\Temp\ps3mediaserver
INFO  2013-03-16 10:37:11.117 [main] Logging config file: C:\Program Files (x86)\PS3 Media Server\logback.xml
INFO  2013-03-16 10:37:11.117 [main] debug.log: C:\Users\Swami\AppData\Local\Temp\\debug.log
INFO  2013-03-16 10:37:11.118 [main]
INFO  2013-03-16 10:37:11.118 [main] Profile directory: C:\ProgramData\PMS
INFO  2013-03-16 10:37:11.118 [main] Profile path: C:\ProgramData\PMS\PMS.conf
INFO  2013-03-16 10:37:11.119 [main] Profile permissions: rw
INFO  2013-03-16 10:37:11.120 [main] Profile name: Illmatic
INFO  2013-03-16 10:37:11.120 [main]
INFO  2013-03-16 10:37:11.123 [main] Loading MediaInfo library
INFO  2013-03-16 10:37:11.145 [main] Error loading MediaInfo library: C:\Users\Swami\AppData\Local\Temp\jna5504580855640747707.dll: Access is denied
INFO  2013-03-16 10:37:11.147 [main] The server will now use the less accurate ffmpeg parsing method
INFO  2013-03-16 10:37:11.150 [main] Loading renderer configurations from C:\Program Files (x86)\PS3 Media Server\renderers
INFO  2013-03-16 10:37:11.151 [main] Loading configuration file: AirPlayer.conf
INFO  2013-03-16 10:37:11.156 [main] Loading configuration file: Android.conf
INFO  2013-03-16 10:37:11.160 [main] Loading configuration file: Bravia4500.conf
INFO  2013-03-16 10:37:11.165 [main] Loading configuration file: Bravia5500.conf
INFO  2013-03-16 10:37:11.171 [main] Loading configuration file: BraviaEX.conf
INFO  2013-03-16 10:37:11.176 [main] Loading configuration file: DirecTVHR.conf
INFO  2013-03-16 10:37:11.181 [main] Loading configuration file: DLinkDSM510.conf
INFO  2013-03-16 10:37:11.185 [main] Loading configuration file: FreeboxHD.conf
INFO  2013-03-16 10:37:11.187 [main] Loading configuration file: FreecomMusicPal.conf
INFO  2013-03-16 10:37:11.191 [main] Loading configuration file: iPad-iPhone.conf
INFO  2013-03-16 10:37:11.195 [main] Loading configuration file: Kuro.conf
INFO  2013-03-16 10:37:11.200 [main] Loading configuration file: LGST600.conf
INFO  2013-03-16 10:37:11.205 [main] Loading configuration file: N900.conf
INFO  2013-03-16 10:37:11.208 [main] Loading configuration file: OPPOBDP83.conf
INFO  2013-03-16 10:37:11.211 [main] Loading configuration file: OPPOBDP93.conf
INFO  2013-03-16 10:37:11.215 [main] Loading configuration file: Panasonic.conf
INFO  2013-03-16 10:37:11.221 [main] Loading configuration file: Philips.conf
INFO  2013-03-16 10:37:11.226 [main] Loading configuration file: PhilipsPFL.conf
INFO  2013-03-16 10:37:11.232 [main] Loading configuration file: PopcornHour.conf
INFO  2013-03-16 10:37:11.235 [main] Loading configuration file: PS3.conf
INFO  2013-03-16 10:37:11.243 [main] Loading configuration file: Realtek.conf
INFO  2013-03-16 10:37:11.248 [main] Loading configuration file: Samsung-SMT-G7400.conf
INFO  2013-03-16 10:37:11.255 [main] Loading configuration file: SamsungAllShare.conf
INFO  2013-03-16 10:37:11.258 [main] Loading configuration file: SamsungWiseLink.conf
INFO  2013-03-16 10:37:11.261 [main] Loading configuration file: Showtime3.conf
INFO  2013-03-16 10:37:11.266 [main] Loading configuration file: SMP-N100.conf
INFO  2013-03-16 10:37:11.271 [main] Loading configuration file: SonyBluray.conf
INFO  2013-03-16 10:37:11.275 [main] Loading configuration file: Streamium.conf
INFO  2013-03-16 10:37:11.278 [main] Loading configuration file: WDTVLive.conf
INFO  2013-03-16 10:37:11.282 [main] Loading configuration file: WMP.conf
INFO  2013-03-16 10:37:11.285 [main] Loading configuration file: XBMC.conf
INFO  2013-03-16 10:37:11.288 [main] Loading configuration file: XBOX360.conf
INFO  2013-03-16 10:37:11.291 [main] Loading configuration file: YamahaRXA1010.conf
INFO  2013-03-16 10:37:11.295 [main] Loading configuration file: YamahaRXV671.conf
INFO  2013-03-16 10:37:11.297 [main] Checking MPlayer font cache. It can take a minute or so.
DEBUG 2013-03-16 10:37:11.298 [main] launching: win32/mplayer.exe
DEBUG 2013-03-16 10:37:11.561 [main] launching: win32/mplayer.exe
INFO  2013-03-16 10:37:11.755 [main] Done!
INFO  2013-03-16 10:37:11.760 [main] Found VideoLAN version 2.0.1 at: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
INFO  2013-03-16 10:37:11.767 [main] Searching for plugins in C:\Program Files (x86)\PS3 Media Server\plugins
INFO  2013-03-16 10:37:11.769 [main] No plugins found
INFO  2013-03-16 10:37:11.782 [main] Transcoder profile AviSynth/FFmpeg will not be used because AviSynth was not found
INFO  2013-03-16 10:37:11.783 [main] Registering transcoding engine: FFmpeg Audio
INFO  2013-03-16 10:37:11.788 [main] Registering transcoding engine: MEncoder
INFO  2013-03-16 10:37:11.789 [main] Transcoder profile AviSynth/MEncoder will not be used because AviSynth was not found
INFO  2013-03-16 10:37:11.789 [main] Registering transcoding engine: FFmpeg
INFO  2013-03-16 10:37:11.790 [main] Registering transcoding engine: MPlayer Audio
INFO  2013-03-16 10:37:11.790 [main] Registering transcoding engine: FFmpeg Web Video
INFO  2013-03-16 10:37:11.791 [main] Registering transcoding engine: MEncoder Web
INFO  2013-03-16 10:37:11.792 [main] Registering transcoding engine: MPlayer Video Dump
INFO  2013-03-16 10:37:11.792 [main] Registering transcoding engine: MPlayer Web
INFO  2013-03-16 10:37:11.794 [main] Registering transcoding engine: tsMuxeR
INFO  2013-03-16 10:37:11.794 [main] Registering transcoding engine: Audio High Fidelity
DEBUG 2013-03-16 10:37:11.795 [main] Found VLC version 2.0.1 in Windows Registry: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
DEBUG 2013-03-16 10:37:11.795 [main] Found VLC version 2.0.1 in Windows Registry: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
DEBUG 2013-03-16 10:37:11.795 [main] Found VLC version 2.0.1 in Windows Registry: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
DEBUG 2013-03-16 10:37:11.796 [main] Found VLC version 2.0.1 in Windows Registry: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
INFO  2013-03-16 10:37:11.796 [main] Registering transcoding engine: VLC Audio Streaming
DEBUG 2013-03-16 10:37:11.796 [main] Found VLC version 2.0.1 in Windows Registry: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
DEBUG 2013-03-16 10:37:11.796 [main] Found VLC version 2.0.1 in Windows Registry: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
DEBUG 2013-03-16 10:37:11.796 [main] Found VLC version 2.0.1 in Windows Registry: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
DEBUG 2013-03-16 10:37:11.796 [main] Found VLC version 2.0.1 in Windows Registry: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
INFO  2013-03-16 10:37:11.796 [main] Registering transcoding engine: VLC Video Streaming
INFO  2013-03-16 10:37:11.797 [main] Registering transcoding engine: FFmpeg DVR-MS Remux
INFO  2013-03-16 10:37:11.798 [main] Registering transcoding engine: dcraw Thumbnailer
INFO  2013-03-16 10:37:11.799 [main] AviSynth is not installed. You cannot use avsmencoder as a transcoding engine.
INFO  2013-03-16 10:37:11.902 [main] Using localhost address
INFO  2013-03-16 10:37:11.902 [main] Created socket: 0.0.0.0/0.0.0.0:6001
INFO  2013-03-16 10:37:12.060 [main] Configuration error: java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Pointer
Last edited by Raptor399 on Sat Mar 23, 2013 11:39 am, edited 1 time in total.
Reason: Edited for code fragments
swamanator
 
Posts: 4
Joined: Mon Apr 18, 2011 9:57 pm

Re: Please Help - Configuration error: java.lang.NoClassDefF

Postby Raptor399 » Sat Mar 23, 2013 11:42 am

It looks like you are using the latest version of the JDK. There have been a couple of problem reports about PMS and Java 1.7.0_17.
Downgrading to Java 1.7.0_15 was reported to work better.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Please Help - Configuration error: java.lang.NoClassDefF

Postby Raptor399 » Sat Mar 23, 2013 12:03 pm

On second thought, JNA is an external library that we use. It is not part of the JDK itself.

See if you can find the file "jna-3.2.5.jar" on your system, it ought to come with PMS. Check if the file or the directory it is in has the correct access rights.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Please Help - Configuration error: java.lang.NoClassDefF

Postby lisko » Mon Apr 01, 2013 8:26 pm

I have exactly the same problem as swamanator. I've also tried to install-uninstall both PMS and Java with several different version combinations without any luck so far.
Where is this "jna-3.2.5.jar" supposed to be located? I tried searching but couldn't find it.

It seems that others are experiencing the same problem as well..
http://www.ps3mediaserver.org/forum/viewtopic.php?f=6&t=15909
http://www.ps3mediaserver.org/forum/viewtopic.php?f=6&t=14758
lisko
 
Posts: 1
Joined: Sun Apr 03, 2011 10:29 pm

Re: Please Help - Configuration error: java.lang.NoClassDefF

Postby Clack » Thu Apr 11, 2013 8:26 pm

Error loading MediaInfo library: C:\Users\Person\AppData\Local\Temp\jna5504580855640747707.dll: Access is denied

This is my exact same problem. I have to uninstall and reinstall PMS on every use with this same error. If anyone has a solution or idea I'd love to hear it.
Clack
 
Posts: 9
Joined: Thu Apr 11, 2013 4:53 pm

Re: Please Help - Configuration error: java.lang.NoClassDefF

Postby Raptor399 » Thu Apr 11, 2013 8:36 pm

Clack wrote:Error loading MediaInfo library: C:\Users\Person\AppData\Local\Temp\jna5504580855640747707.dll: Access is denied

This is my exact same problem. I have to uninstall and reinstall PMS on every use with this same error. If anyone has a solution or idea I'd love to hear it.

I'm not on Windows myself, but this sounds very much like a problem with access rights.
That temporary JNA .dll probably wants to access MediaInfo.dll, but does not have sufficient rights to do that.

Examine the access rights of that jna.dll (I'm guessing it only exists while PMS runs, seeing that it is in a temp directory), then examine the access rights of MediaInfo.dll (this should be in the PMS program directory) and make sure they are the same.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Please Help - Configuration error: java.lang.NoClassDefF

Postby Clack » Fri Apr 12, 2013 2:53 am

I was able to access the temp jnaxxxxxx.dll and set its permissions to everyone full access, but when I try to change Users permissions to FULL CONTROL from Read & Execute, it says <not inherited>. Does it seem like I'm on the right track?
Clack
 
Posts: 9
Joined: Thu Apr 11, 2013 4:53 pm

Re: Please Help - Configuration error: java.lang.NoClassDefF

Postby Clack » Tue Apr 16, 2013 8:59 pm

Bumpidy Bump!
Clack
 
Posts: 9
Joined: Thu Apr 11, 2013 4:53 pm

Re: Please Help - Configuration error: java.lang.NoClassDefF

Postby meskibob » Tue Apr 16, 2013 9:11 pm

Maybe try reinstalling using Run as Administrator on the installer?
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4788
Joined: Mon Jan 19, 2009 4:11 pm

Re: Please Help - Configuration error: java.lang.NoClassDefF

Postby chandler » Sat Jun 15, 2013 2:16 am

Raptor399 wrote:
Clack wrote:Error loading MediaInfo library: C:\Users\Person\AppData\Local\Temp\jna5504580855640747707.dll: Access is denied

This is my exact same problem. I have to uninstall and reinstall PMS on every use with this same error. If anyone has a solution or idea I'd love to hear it.

I'm not on Windows myself, but this sounds very much like a problem with access rights.
That temporary JNA .dll probably wants to access MediaInfo.dll, but does not have sufficient rights to do that.

Examine the access rights of that jna.dll (I'm guessing it only exists while PMS runs, seeing that it is in a temp directory), then examine the access rights of MediaInfo.dll (this should be in the PMS program directory) and make sure they are the same.



Running as admin solves the pointer error. This is how you need to fix it, right click ps3 media server, go to properties, click advanced, click run as admin, it will do it by default every time now. Ofc it'll ask you to run the program cause windows is a dick but it solves your problem. I still have a DLNA 2104 error to try and figure out now though :(
chandler
 
Posts: 1
Joined: Sat Jun 15, 2013 2:09 am


Return to General Help and Support

Who is online

Users browsing this forum: Yahoo [Bot] and 15 guests