Transcoding image stretch

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Transcoding image stretch

Postby m477e0 » Wed Jan 30, 2013 9:58 pm

Hi all,

I bought a Plasma TV Panasonic 65" and today I discover that PMS works better than the media server suggested by Panasonic!

The only problem I have is that, even if the MKV format seems to be well accepted by TV directly without transcoding needs, sometimes with transcoding some file works better, but it always appears completely stretched! A 2.35:1 movie become 1.85:1 with horrible effects! Is there some setting I should change in order to avoid this bad problem?

Thanks for your help! Ciao,

m477e0
m477e0
 
Posts: 4
Joined: Wed Jan 30, 2013 9:53 pm

Re: Transcoding image stretch

Postby ExSport » Thu Jan 31, 2013 10:02 pm

If your TV supports MKV natively, change "streamextension=" line in Panasonic.conf to ...=mkv
Your mkv will be streamed automatically without remuxing or transcoding. When file is remuxed, Aspect Ratio will broke.
When file is transcoded, AR can be fixed by special MEncoder parameters. But PMS has a bug so params are not used from Panasonic.conf.
Check other threads how to set it directly in PMS GUI.
Command is if I remember right "-vf expand=::::0:16/9:4,softskip"
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Transcoding image stretch

Postby m477e0 » Fri Feb 01, 2013 10:36 am

Hi ExSport,

first of all thanks for your help!

I have a Panasonic TX-P65ST50E that should support mkv files natively. In fact, when playing the majority of my mkv files directly, no issues at all. But for some files I have playback problems, so I must use transcoding PMS capabilities. The file plays correctly with the exception of the image stretch.

I noted on the Google search that you are the author of Panasonic.conf, but I am a noob, so can you please let me know the exact procedure to insert this config into the PMS?

Thanks a lot! Ciao,
M477e0
m477e0
 
Posts: 4
Joined: Wed Jan 30, 2013 9:53 pm

Re: Transcoding image stretch

Postby ExSport » Fri Feb 01, 2013 2:11 pm

Hello
Default Panasonic.conf file doesn't stream MKV directly but PMS remuxes them (via tsMuxeR).
When container is changed, TV loose AR info so picture is stretched because top/bottom black bars are removed.
So how to stream MKV directly?
Edit this line in Panasonic.conf file from:
Code: Select all
StreamExtensions=
to
Code: Select all
StreamExtensions=mkv

Restart PMS (don't use Restart in GUI but stop PMS and start it again after a while)
If TV doesn't support embedded/external subs, subs can be burned in picture via MEncoder(transcoding).
Because it again changes container type, AR is broken.
Line in Panasonic.conf should fix it but PMS has a bug so settings is ignored:
Code: Select all
CustomMencoderOptions=-vf softskip,expand=::::1:16\/9:4

Because of that add line below to "Transcoding Settings / MEncoder / Custom Options:" in PMS GUI:
Code: Select all
-vf expand=::::0:16/9:4,softskip

It will force adding missing black bars for all renderers (when MEncoder engine is used)
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Transcoding image stretch

Postby m477e0 » Fri Feb 01, 2013 8:25 pm

Thanks a lot my friend!

Very last question, sorry to bother you...

Sometimes also MEncoder fails, while TSMuxer seems to work better, but the image is still streched. Is there some modification I can do in Panasonic.conf file to solve the issue also in TSMuxer transcode?

Many thanks! Ciao,

m477e0
m477e0
 
Posts: 4
Joined: Wed Jan 30, 2013 9:53 pm

ExSport Re: Transcoding image stretch

Postby EC2013 » Sun Feb 03, 2013 1:13 am

ExSport,

You have NO IDEA how much time, effort, and struggling you have saved me! That one little tweak you suggested has made everything perfect. Unbelievable. I've been jerking around with this for about a year. Wondering if the DLNA client on the TV was garbage or I simply didn't know what I was doing (the latter is still possible).

Nice job, thanks for the suggestion.

Outstanding.

Cheers!
EC2013
 
Posts: 1
Joined: Sun Feb 03, 2013 1:09 am

Re: Transcoding image stretch

Postby dorice » Sun Feb 03, 2013 4:16 am

When I change the setting in the GUI, the CPU usage of javaw.exe will increase from less than 10% to more than 30%! The video is lagging, and there are double subtitles in the video! It seems I change any setting of mencoder, javaw.exe will get very high CPU usage! Why?
dorice
 
Posts: 9
Joined: Tue May 01, 2012 11:54 am

Re: Transcoding image stretch

Postby ExSport » Mon Feb 04, 2013 5:47 pm

@m477e0:
Can't be fixed with tsMuxeR but if your TV supports MKV natively PMS can skip using txMuxeR and stream MKV directly to your TV.
If you will edit line to "StreamExtensions=mkv", you should see [NO ENCODE] in #TRANSCODE# folder. Does it work for you?

@EC2013:
No problem 8-)

@dorice:
Adding it in GUI will not use more CPU for javaw.exe but generally when you are transcoding/re-encoding, MEncoder will use almost all CPU time and network bandwidth will grow 2-10x.
So if you are using weak CPU or you are on WIFI, it is problem without using bandwidth limiting or lowering picture quality.
If you will use this settings "-vf expand=::::0:16/9:4,softskip", you should not see double subs (talking about Windows) and if yes, post debug.log.
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Transcoding image stretch

Postby dorice » Thu Mar 28, 2013 4:13 pm

I just saw double subs again! Here is the debug.log and conf file:
debug.zip
(8.72 KiB) Downloaded 77 times
dorice
 
Posts: 9
Joined: Tue May 01, 2012 11:54 am

Re: Transcoding image stretch

Postby ExSport » Thu Mar 28, 2013 6:45 pm

In your log I found:
Code: Select all
-vf softskip,expand=::::1:16/9:4

You should use:
Code: Select all
-vf expand=::::0:16/9:4,softskip

I am not sure if new PMS version already fixed bug that it ignored this line in renderer.conf file:
Code: Select all
CustomMencoderOptions=-vf softskip,expand=::::1:16\/9:4

So if it is fixed, change this line in conf to:
Code: Select all
CustomMencoderOptions=-vf expand=::::0:16\/9:4,softskip

or when it is not fixed, you should set it directly in GUI (for all renderers).
Fill this line to "Custom Options" in transcoding TAB or where is it 8-)
Code: Select all
-vf expand=::::0:16/9:4,softskip

Restart PMS and test again.
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: Majestic-12 [Bot] and 16 guests