Error Init PMS - Heap error Java fun...

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Error Init PMS - Heap error Java fun...

Postby rmleloup » Sun Jan 27, 2013 10:06 am

Ola, i'm sure you've heard this before...

My literal error =

Error initializing PMS!
Configuration error: java.lang.OutOfMemoryError: Java Heap Space.


This is fresh install, fresh windows build.

Prior to installing PMS, Latest java from java.com installed (7.11? I think). Then 1.72 PMS.

Launching pms first run, no problem, no settings changed, just added the shared folders. Rebooted pc accordingly (for java to take properly I assumed).

And voila, error occurs.

Tried fresh install, different folder of pms, tried 32bit java fresh install (reboot between uninstalls), no dice. Tried 64bit, same problem. Tried 32bit again, Just had Error initalizing pms! with BLANK error (literally NOTHING in there). Still no launch properly...

I've uploaded the log, and i've also copy/pasted the log into this post, (whichever is easiest).

Goal is to share with Playstation 3 like I did prior to this windows build when pc crashed. Fully functional now... fully updated as before, windows, drivers, etc.

If anyone can assist, Greatly appreciated.

Regards,

- rmleloup

** Correction, attempted to upload the attachement as txt, no dice... now trying .zip...yay...

** PC Specs **

i7, 920, 3.4ghz, 35 celcius idle, :)
12gb ddr3
Xfire 6870's
Integrated sound
Multiple 1 & 2tb hdd's
All sata II
Gigabit ethernet to router to ps3. PS3 Speed test, 40mbps/3mbps (my inet is 50/3).

Code: Select all
INFO  2013-01-27 01:51:15.005 [main] Starting PS3 Media Server 1.72.0
INFO  2013-01-27 01:51:15.016 [main] by shagrath / 2008-2012
INFO  2013-01-27 01:51:15.018 [main] http://ps3mediaserver.org
INFO  2013-01-27 01:51:15.019 [main] https://github.com/ps3mediaserver/ps3mediaserver
INFO  2013-01-27 01:51:15.020 [main]
INFO  2013-01-27 01:51:15.020 [main] Build: d9fd0a44c (2012-11-18)
INFO  2013-01-27 01:51:15.022 [main] Java: 1.7.0_11-Oracle Corporation
INFO  2013-01-27 01:51:15.023 [main] OS: Windows 7 x86 6.1
INFO  2013-01-27 01:51:15.024 [main] Encoding: UTF-8
INFO  2013-01-27 01:51:15.031 [main] Memory: 742 MB
INFO  2013-01-27 01:51:15.031 [main]
INFO  2013-01-27 01:51:15.031 [main] Working directory: C:\ps3mediaserver
INFO  2013-01-27 01:51:15.035 [main] Temp directory: C:\Users\Peter\AppData\Local\Temp\ps3mediaserver
INFO  2013-01-27 01:51:15.036 [main] Logging config file: C:\ps3mediaserver\logback.xml
INFO  2013-01-27 01:51:15.037 [main] debug.log: C:\ps3mediaserver\debug.log
INFO  2013-01-27 01:51:15.037 [main]
INFO  2013-01-27 01:51:15.037 [main] Profile directory: C:\ProgramData\PMS
INFO  2013-01-27 01:51:15.037 [main] Profile path: C:\ProgramData\PMS\PMS.conf
INFO  2013-01-27 01:51:15.038 [main] Profile permissions: rw
INFO  2013-01-27 01:51:15.038 [main] Profile name: Peter-PC
INFO  2013-01-27 01:51:15.038 [main]
INFO  2013-01-27 01:51:15.040 [main] Loading MediaInfo library
INFO  2013-01-27 01:51:15.075 [main] Loaded MediaInfoLib - v0.7.60
INFO  2013-01-27 01:51:15.078 [main] Loading renderer configurations from C:\ps3mediaserver\renderers
INFO  2013-01-27 01:51:15.079 [main] Loading configuration file: AirPlayer.conf
INFO  2013-01-27 01:51:15.081 [main] Loading configuration file: Android.conf
INFO  2013-01-27 01:51:15.082 [main] Loading configuration file: Bravia4500.conf
INFO  2013-01-27 01:51:15.084 [main] Loading configuration file: Bravia5500.conf
INFO  2013-01-27 01:51:15.085 [main] Loading configuration file: BraviaEX.conf
INFO  2013-01-27 01:51:15.087 [main] Loading configuration file: DirecTVHR.conf
INFO  2013-01-27 01:51:15.090 [main] Loading configuration file: DLinkDSM510.conf
INFO  2013-01-27 01:51:15.091 [main] Loading configuration file: FreeboxHD.conf
INFO  2013-01-27 01:51:15.091 [main] Loading configuration file: FreecomMusicPal.conf
INFO  2013-01-27 01:51:15.092 [main] Loading configuration file: iPad-iPhone.conf
INFO  2013-01-27 01:51:15.093 [main] Loading configuration file: Kuro.conf
INFO  2013-01-27 01:51:15.095 [main] Loading configuration file: LGST600.conf
INFO  2013-01-27 01:51:15.101 [main] Loading configuration file: N900.conf
INFO  2013-01-27 01:51:15.102 [main] Loading configuration file: OPPOBDP83.conf
INFO  2013-01-27 01:51:15.103 [main] Loading configuration file: OPPOBDP93.conf
INFO  2013-01-27 01:51:15.104 [main] Loading configuration file: Panasonic.conf
INFO  2013-01-27 01:51:15.105 [main] Loading configuration file: Philips.conf
INFO  2013-01-27 01:51:15.106 [main] Loading configuration file: PhilipsPFL.conf
INFO  2013-01-27 01:51:15.108 [main] Loading configuration file: PopcornHour.conf
INFO  2013-01-27 01:51:15.109 [main] Loading configuration file: PS3.conf
INFO  2013-01-27 01:51:15.111 [main] Loading configuration file: Realtek.conf
INFO  2013-01-27 01:51:15.111 [main] Loading configuration file: Samsung-SMT-G7400.conf
INFO  2013-01-27 01:51:15.113 [main] Loading configuration file: SamsungAllShare.conf
INFO  2013-01-27 01:51:15.113 [main] Loading configuration file: SamsungWiseLink.conf
INFO  2013-01-27 01:51:15.114 [main] Loading configuration file: Showtime3.conf
INFO  2013-01-27 01:51:15.115 [main] Loading configuration file: SMP-N100.conf
INFO  2013-01-27 01:51:15.116 [main] Loading configuration file: SonyBluray.conf
INFO  2013-01-27 01:51:15.117 [main] Loading configuration file: Streamium.conf
INFO  2013-01-27 01:51:15.118 [main] Loading configuration file: WDTVLive.conf
INFO  2013-01-27 01:51:15.119 [main] Loading configuration file: WMP.conf
INFO  2013-01-27 01:51:15.120 [main] Loading configuration file: XBMC.conf
INFO  2013-01-27 01:51:15.120 [main] Loading configuration file: XBOX360.conf
INFO  2013-01-27 01:51:15.121 [main] Loading configuration file: YamahaRXA1010.conf
INFO  2013-01-27 01:51:15.122 [main] Loading configuration file: YamahaRXV671.conf
INFO  2013-01-27 01:51:15.122 [main] Checking MPlayer font cache. It can take a minute or so.
DEBUG 2013-01-27 01:51:15.123 [main] launching: win32/mplayer.exe
DEBUG 2013-01-27 01:51:15.194 [main] launching: win32/mplayer.exe
INFO  2013-01-27 01:51:15.264 [main] Done!
INFO  2013-01-27 01:51:15.266 [main] Searching for plugins in C:\ps3mediaserver\plugins
INFO  2013-01-27 01:51:15.267 [main] No plugins found
INFO  2013-01-27 01:51:15.274 [main] Transcoder profile AviSynth/FFmpeg will not be used because AviSynth was not found
INFO  2013-01-27 01:51:15.274 [main] Registering transcoding engine: FFmpeg Audio
INFO  2013-01-27 01:51:15.277 [main] Registering transcoding engine: MEncoder
INFO  2013-01-27 01:51:15.277 [main] Transcoder profile AviSynth/MEncoder will not be used because AviSynth was not found
INFO  2013-01-27 01:51:15.278 [main] Registering transcoding engine: FFmpeg
INFO  2013-01-27 01:51:15.278 [main] Registering transcoding engine: MPlayer Audio
INFO  2013-01-27 01:51:15.278 [main] Registering transcoding engine: FFmpeg Web Video
INFO  2013-01-27 01:51:15.279 [main] Registering transcoding engine: MEncoder Web
INFO  2013-01-27 01:51:15.279 [main] Registering transcoding engine: MPlayer Video Dump
INFO  2013-01-27 01:51:15.279 [main] Registering transcoding engine: MPlayer Web
INFO  2013-01-27 01:51:15.280 [main] Registering transcoding engine: tsMuxeR
INFO  2013-01-27 01:51:15.280 [main] Registering transcoding engine: Audio High Fidelity
INFO  2013-01-27 01:51:15.281 [main] Executable of transcoder profile VLC Audio Streaming not found
INFO  2013-01-27 01:51:15.281 [main] Executable of transcoder profile VLC Video Streaming not found
INFO  2013-01-27 01:51:15.281 [main] Registering transcoding engine: FFmpeg DVR-MS Remux
INFO  2013-01-27 01:51:15.281 [main] Registering transcoding engine: dcraw Thumbnailer
INFO  2013-01-27 01:51:15.282 [main] AviSynth is not installed. You cannot use avsmencoder as a transcoding engine.
INFO  2013-01-27 01:51:15.393 [main] Using address /192.168.0.113 found on network interface: name:eth3 (Realtek PCIe GBE Family Controller)
INFO  2013-01-27 01:51:15.393 [main] Created socket: /192.168.0.113:5001
INFO  2013-01-27 01:51:15.435 [main] Checking shared folder: V:\iPad Converted Movies
INFO  2013-01-27 01:51:15.436 [main] Checking shared folder: V:\Cass Movies 1\Grey's Anatomy
INFO  2013-01-27 01:51:15.436 [main] Checking shared folder: R:\Cass Movies 2\Cass Movies
INFO  2013-01-27 01:51:49.947 [main] Configuration error: java.lang.OutOfMemoryError: Java heap space
Attachments
debug.zip
(1.55 KiB) Downloaded 21 times
Last edited by meskibob on Sun Jan 27, 2013 2:16 pm, edited 1 time in total.
Reason: Reformatted
rmleloup
 
Posts: 15
Joined: Mon Oct 15, 2012 8:32 pm

Re: Error Init PMS - Heap error Java fun...

Postby meskibob » Sun Jan 27, 2013 2:20 pm

For the heap error (this should just be it) - viewtopic.php?f=6&t=3507&start=30#p38969
For any other startup issues - viewtopic.php?f=6&t=3507&start=30#p41214

Note: that's a weird spot to get the heap error, and you're using the default heapsize which should be more than sufficient to just load media.
How many movies are in "Cass Movies", and can you post a trace log?
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4779
Joined: Mon Jan 19, 2009 4:11 pm

Re: Error Init PMS - Heap error Java fun...

Postby rmleloup » Sun Jan 27, 2013 6:13 pm

Cass Movies has a secondary sub folder, basically it's a list of seasons of shows i've setup for her. approx 132 files it says. (Cass movies 1\grey's)
Cass movies 2 has At most 14-15 movie files total.

Before I had to rebuild, psm had several hundred movies & almost 200,000mp3's on the fly easily. (Dunno if a limit).

I put up the debug, but that link shows me how to do the debug zip upload. Where do I find mr trace log? (simple obvious example of where it typically is?)
rmleloup
 
Posts: 15
Joined: Mon Oct 15, 2012 8:32 pm

Re: Error Init PMS - Heap error Java fun...

Postby rmleloup » Mon Jan 28, 2013 1:50 pm

Bump
rmleloup
 
Posts: 15
Joined: Mon Oct 15, 2012 8:32 pm

Re: Error Init PMS - Heap error Java fun...

Postby meskibob » Mon Jan 28, 2013 4:33 pm

As the link states, you need to modify the logback.xml file, restart PMS, replicate the issue, and then post the debug.log file (which now contains all trace elements as dictated by the logback config).

However, if you're not interested in diagnosing the issue further, simply modifying the PMS.bat file as directed in the very first link should be sufficient.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4779
Joined: Mon Jan 19, 2009 4:11 pm

Re: Error Init PMS - Heap error Java fun...

Postby rmleloup » Mon Jan 28, 2013 7:23 pm

meskibob wrote:As the link states, you need to modify the logback.xml file, restart PMS, replicate the issue, and then post the debug.log file (which now contains all trace elements as dictated by the logback config).

However, if you're not interested in diagnosing the issue further, simply modifying the PMS.bat file as directed in the very first link should be sufficient.


How do I find this logback.xml file, i'm unsure where this is, (hence confusion).

I've recreated the issue, and uploading a 2nd debug.zip thing. I'm still replicating the issue. It either happens immediately upon loading pms, or shortly after. Sometimes the actual error window is Literally Blank. But here it is.

Image




And no, i'm not saying at any point I don't want to troubleshoot, i'm unfamiliar with troubleshooting and just need to be better directed as your links didn't make sense to a novice user beyond uninstall/reinstalling things for this app.

- rmleloup
Attachments
debug 2nd.zip
(1.65 KiB) Downloaded 22 times
rmleloup
 
Posts: 15
Joined: Mon Oct 15, 2012 8:32 pm

Re: Error Init PMS - Heap error Java fun...

Postby rmleloup » Mon Jan 28, 2013 7:41 pm

Seems I had to make a 2nd post (pardon the spam of posting, seriously) in order to upload a 2nd log file. Found the xml thing finally. Looked for that 769, and tried 1536, same error, I checked the bat file thing also, same error. Decided, well I have 12gb's, why not 6144 (half the ram for kicks) as I had java 64bit installed... Same error. Though this time with 6144 setup... it found the wmp renderer... oddly enough...

- rmleloup



I feel like i'm missing something huge, that a true triple facepalm around the world is needed, but I'm not sure what i'm missing...
Attachments
debug3rd.zip
(2.16 KiB) Downloaded 23 times
rmleloup
 
Posts: 15
Joined: Mon Oct 15, 2012 8:32 pm

Re: Error Init PMS - Heap error Java fun...

Postby rmleloup » Mon Jan 28, 2013 7:53 pm

Ok, after a pc reboot a 2nd time, (first no change, 2nd odd change).

Now getting the java.lang.outofmemoryerror: GC overheadlimit exceeded

Going back to 1536, rebooting pc...

oi...

And here is that error's file..
Attachments
debug-4th.zip
(1.58 KiB) Downloaded 20 times
rmleloup
 
Posts: 15
Joined: Mon Oct 15, 2012 8:32 pm

Re: Error Init PMS - Heap error Java fun...

Postby rmleloup » Mon Jan 28, 2013 8:07 pm

1536 and = java.lang.outofmemoryerror: GC overheadlimit exceeded..

I've tried running the app as admin incase it was permissions error, but no..

Here is the 5th log... and i'm also throwing in a copy of my pms.bat and that win32\service\wrapper.conf file as well



Something strange though... every time i've had to force close in task manager, i've only seen 744,### kb's used. Never above that... it's like we're missing one key file to edit to get past 768mb... even though i've exceeded the settings severely... Might be on to something now...


If your installation of psm is obviously working... Would a simple zip upload of your install make sense to send to me? That would clear up the issue if something else is mixed up. (Not asking for your shared folders, if you have option to remove those, so as not to log them to me to respect your privacy, just thinking here). As this would clear up any conflicts potentially?
Attachments
debug-5th.zip
Any idea what is wrong o_o
(3.69 KiB) Downloaded 21 times
rmleloup
 
Posts: 15
Joined: Mon Oct 15, 2012 8:32 pm

Re: Error Init PMS - Heap error Java fun...

Postby rmleloup » Tue Jan 29, 2013 4:23 pm

Morning, still looking for an idea, if anyone has a working install, can ya zip it up, and send me it? I'll literally see if a copy paste of that... might fix it. Shouldn't work, but... i'm willing to try a n y t h i n g... including rubbing the case like a magic lamp...
rmleloup
 
Posts: 15
Joined: Mon Oct 15, 2012 8:32 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: Yahoo [Bot] and 10 guests