Xbox not detected in PMS but can still stream from Xbox

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Xbox not detected in PMS but can still stream from Xbox

Postby tigersharkdog » Sat Jan 12, 2013 3:50 am

I have two weird problems. PMS can't detect my Xbox (it's stuck on "searching for renderers") but Xbox detects PMS and can stream from it fine. I forced the IP to direct to my Xbox and I have no idea I've set it to the correct network. I also had to change the port.

I am also unable to limit directories displayed on the Xbox. I've set them in PMS, but when I open the server from my Xbox, it shows everything.

Code: Select all
INFO  2013-01-12 13:32:09.105 [main] Starting PS3 Media Server 1.72.0
INFO  2013-01-12 13:32:09.114 [main] by shagrath / 2008-2012
INFO  2013-01-12 13:32:09.117 [main] http://ps3mediaserver.org
INFO  2013-01-12 13:32:09.117 [main] https://github.com/ps3mediaserver/ps3mediaserver
INFO  2013-01-12 13:32:09.118 [main]
INFO  2013-01-12 13:32:09.118 [main] Build: d9fd0a44c (2012-11-18)
INFO  2013-01-12 13:32:09.119 [main] Java: 1.7.0_09-Oracle Corporation
INFO  2013-01-12 13:32:09.120 [main] OS: Windows 7 x86 6.1
INFO  2013-01-12 13:32:09.122 [main] Encoding: UTF-8
INFO  2013-01-12 13:32:09.124 [main] Memory: 742 MB
INFO  2013-01-12 13:32:09.124 [main]
INFO  2013-01-12 13:32:09.124 [main] Working directory: C:\Program Files (x86)\PS3 Media Server
INFO  2013-01-12 13:32:09.134 [main] Temp directory: C:\Users\User\AppData\Local\Temp\ps3mediaserver
INFO  2013-01-12 13:32:09.135 [main] Logging config file: C:\Program Files (x86)\PS3 Media Server\logback.xml
INFO  2013-01-12 13:32:09.136 [main] debug.log: C:\Users\User\AppData\Local\Temp\\debug.log
INFO  2013-01-12 13:32:09.136 [main]
INFO  2013-01-12 13:32:09.136 [main] Profile directory: C:\ProgramData\PMS
INFO  2013-01-12 13:32:09.136 [main] Profile path: C:\ProgramData\PMS\PMS.conf
INFO  2013-01-12 13:32:09.137 [main] Profile permissions: rw
INFO  2013-01-12 13:32:09.137 [main] Profile name: Nymeria
INFO  2013-01-12 13:32:09.137 [main]
INFO  2013-01-12 13:32:09.139 [main] Loading MediaInfo library
INFO  2013-01-12 13:32:09.237 [main] Loaded MediaInfoLib - v0.7.60
INFO  2013-01-12 13:32:09.240 [main] Loading renderer configurations from C:\Program Files (x86)\PS3 Media Server\renderers
INFO  2013-01-12 13:32:09.240 [main] Loading configuration file: AirPlayer.conf
INFO  2013-01-12 13:32:09.243 [main] Loading configuration file: Android.conf
INFO  2013-01-12 13:32:09.244 [main] Loading configuration file: Bravia4500.conf
INFO  2013-01-12 13:32:09.246 [main] Loading configuration file: Bravia5500.conf
INFO  2013-01-12 13:32:09.247 [main] Loading configuration file: BraviaEX.conf
INFO  2013-01-12 13:32:09.250 [main] Loading configuration file: DirecTVHR.conf
INFO  2013-01-12 13:32:09.251 [main] Loading configuration file: DLinkDSM510.conf
INFO  2013-01-12 13:32:09.253 [main] Loading configuration file: FreeboxHD.conf
INFO  2013-01-12 13:32:09.254 [main] Loading configuration file: FreecomMusicPal.conf
INFO  2013-01-12 13:32:09.255 [main] Loading configuration file: iPad-iPhone.conf
INFO  2013-01-12 13:32:09.256 [main] Loading configuration file: Kuro.conf
INFO  2013-01-12 13:32:09.257 [main] Loading configuration file: LGST600.conf
INFO  2013-01-12 13:32:09.259 [main] Loading configuration file: N900.conf
INFO  2013-01-12 13:32:09.260 [main] Loading configuration file: OPPOBDP83.conf
INFO  2013-01-12 13:32:09.261 [main] Loading configuration file: OPPOBDP93.conf
INFO  2013-01-12 13:32:09.262 [main] Loading configuration file: Panasonic.conf
INFO  2013-01-12 13:32:09.264 [main] Loading configuration file: Philips.conf
INFO  2013-01-12 13:32:09.266 [main] Loading configuration file: PhilipsPFL.conf
INFO  2013-01-12 13:32:09.268 [main] Loading configuration file: PopcornHour.conf
INFO  2013-01-12 13:32:09.269 [main] Loading configuration file: PS3.conf
INFO  2013-01-12 13:32:09.272 [main] Loading configuration file: Realtek.conf
INFO  2013-01-12 13:32:09.273 [main] Loading configuration file: Samsung-SMT-G7400.conf
INFO  2013-01-12 13:32:09.275 [main] Loading configuration file: SamsungAllShare.conf
INFO  2013-01-12 13:32:09.276 [main] Loading configuration file: SamsungWiseLink.conf
INFO  2013-01-12 13:32:09.277 [main] Loading configuration file: Showtime3.conf
INFO  2013-01-12 13:32:09.278 [main] Loading configuration file: SMP-N100.conf
INFO  2013-01-12 13:32:09.279 [main] Loading configuration file: SonyBluray.conf
INFO  2013-01-12 13:32:09.280 [main] Loading configuration file: Streamium.conf
INFO  2013-01-12 13:32:09.281 [main] Loading configuration file: WDTVLive.conf
INFO  2013-01-12 13:32:09.282 [main] Loading configuration file: WMP.conf
INFO  2013-01-12 13:32:09.283 [main] Loading configuration file: XBMC.conf
INFO  2013-01-12 13:32:09.283 [main] Loading configuration file: XBOX360.conf
INFO  2013-01-12 13:32:09.284 [main] Loading configuration file: YamahaRXA1010.conf
INFO  2013-01-12 13:32:09.285 [main] Loading configuration file: YamahaRXV671.conf
INFO  2013-01-12 13:32:09.286 [main] Checking MPlayer font cache. It can take a minute or so.
INFO  2013-01-12 13:32:09.453 [main] Done!
INFO  2013-01-12 13:32:09.453 [main] Found AviSynth plugins dir: C:\Program Files (x86)\AviSynth 2.5\plugins
INFO  2013-01-12 13:32:09.454 [main] VSFilter.dll is not in the AviSynth plugins directory. This can cause problems when trying to play subtitled videos with AviSynth
INFO  2013-01-12 13:32:09.454 [main] Found VideoLAN version 2.0.4 at: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
INFO  2013-01-12 13:32:09.456 [main] Searching for plugins in C:\Program Files (x86)\PS3 Media Server\plugins
INFO  2013-01-12 13:32:09.456 [main] No plugins found
INFO  2013-01-12 13:32:09.463 [main] Registering transcoding engine: AviSynth/FFmpeg
INFO  2013-01-12 13:32:09.464 [main] Registering transcoding engine: FFmpeg Audio
INFO  2013-01-12 13:32:09.466 [main] Registering transcoding engine: MEncoder
INFO  2013-01-12 13:32:09.466 [main] Registering transcoding engine: AviSynth/MEncoder
INFO  2013-01-12 13:32:09.467 [main] Registering transcoding engine: FFmpeg
INFO  2013-01-12 13:32:09.467 [main] Registering transcoding engine: MPlayer Audio
INFO  2013-01-12 13:32:09.467 [main] Registering transcoding engine: FFmpeg Web Video
INFO  2013-01-12 13:32:09.467 [main] Registering transcoding engine: MEncoder Web
INFO  2013-01-12 13:32:09.468 [main] Registering transcoding engine: MPlayer Video Dump
INFO  2013-01-12 13:32:09.468 [main] Registering transcoding engine: MPlayer Web
INFO  2013-01-12 13:32:09.469 [main] Registering transcoding engine: tsMuxeR
INFO  2013-01-12 13:32:09.469 [main] Registering transcoding engine: Audio High Fidelity
INFO  2013-01-12 13:32:09.470 [main] Registering transcoding engine: VLC Audio Streaming
INFO  2013-01-12 13:32:09.470 [main] Registering transcoding engine: VLC Video Streaming
INFO  2013-01-12 13:32:09.470 [main] Registering transcoding engine: FFmpeg DVR-MS Remux
INFO  2013-01-12 13:32:09.471 [main] Registering transcoding engine: dcraw Thumbnailer
INFO  2013-01-12 13:32:09.506 [main] Using forced address 192.168.1.7
INFO  2013-01-12 13:32:09.506 [main] Created socket: /192.168.1.7:6001
ERROR 2013-01-12 13:32:09.538 [main] A serious error occurred during PMS init
org.jboss.netty.channel.ChannelException: Failed to bind to: /192.168.1.7:6001
   at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:303) ~[pms.jar:na]
   at net.pms.network.HTTPServer.start(HTTPServer.java:125) ~[pms.jar:na]
   at net.pms.PMS.init(PMS.java:459) [pms.jar:na]
   at net.pms.PMS.createInstance(PMS.java:814) [pms.jar:na]
   at net.pms.PMS.main(PMS.java:888) [pms.jar:na]
Caused by: java.net.BindException: Cannot assign requested address: bind
   at sun.nio.ch.Net.bind0(Native Method) ~[na:1.7.0_09]
   at sun.nio.ch.Net.bind(Unknown Source) ~[na:1.7.0_09]
   at sun.nio.ch.Net.bind(Unknown Source) ~[na:1.7.0_09]
   at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) ~[na:1.7.0_09]
   at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source) ~[na:1.7.0_09]
   at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.bind(NioServerSocketPipelineSink.java:148) ~[pms.jar:na]
   at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.handleServerSocket(NioServerSocketPipelineSink.java:100) ~[pms.jar:na]
   at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.eventSunk(NioServerSocketPipelineSink.java:74) ~[pms.jar:na]
   at org.jboss.netty.channel.Channels.bind(Channels.java:468) ~[pms.jar:na]
   at org.jboss.netty.channel.AbstractChannel.bind(AbstractChannel.java:192) ~[pms.jar:na]
   at org.jboss.netty.bootstrap.ServerBootstrap$Binder.channelOpen(ServerBootstrap.java:348) ~[pms.jar:na]
   at org.jboss.netty.channel.Channels.fireChannelOpen(Channels.java:176) ~[pms.jar:na]
   at org.jboss.netty.channel.socket.nio.NioServerSocketChannel.<init>(NioServerSocketChannel.java:85) ~[pms.jar:na]
   at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:142) ~[pms.jar:na]
   at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:90) ~[pms.jar:na]
   at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:282) ~[pms.jar:na]
   ... 4 common frames omitted
INFO  2013-01-12 13:50:20.083 [AWT-EventQueue-0] Configuration saved to: C:\ProgramData\PMS\PMS.conf
INFO  2013-01-12 13:50:21.069 [background-task-0-restart(0)] Sending BYEBYE...
INFO  2013-01-12 13:50:21.185 [background-task-0-restart(0)] Using the following UUID configured in PMS.conf: 5e3f4fe9-9ea8-39aa-8564-8d792f0bd62a
INFO  2013-01-12 13:50:24.769 [background-task-0-restart(0)] Stopping server on host 192.168.1.7 and port 6001...
INFO  2013-01-12 13:50:25.769 [background-task-0-restart(0)] Using forced address 192.168.1.7
INFO  2013-01-12 13:50:25.769 [background-task-0-restart(0)] Created socket: /192.168.1.7:6001
INFO  2013-01-12 13:50:25.811 [background-task-0] Exception in thread "background-task-0" org.jboss.netty.channel.ChannelException: Failed to bind to: /192.168.1.7:6001
INFO  2013-01-12 13:50:25.811 [background-task-0]    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:303)
INFO  2013-01-12 13:50:25.812 [background-task-0]    at net.pms.network.HTTPServer.start(HTTPServer.java:125)
INFO  2013-01-12 13:50:25.812 [background-task-0]    at net.pms.PMS$5.run(PMS.java:651)
INFO  2013-01-12 13:50:25.812 [background-task-0]    at net.pms.util.TaskRunner$2.run(TaskRunner.java:105)
INFO  2013-01-12 13:50:25.812 [background-task-0]    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
INFO  2013-01-12 13:50:25.812 [background-task-0]    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
INFO  2013-01-12 13:50:25.813 [background-task-0]    at java.lang.Thread.run(Unknown Source)
INFO  2013-01-12 13:50:25.813 [background-task-0] Caused by: java.net.BindException: Cannot assign requested address: bind
INFO  2013-01-12 13:50:25.813 [background-task-0]    at sun.nio.ch.Net.bind0(Native Method)
INFO  2013-01-12 13:50:25.813 [background-task-0]    at sun.nio.ch.Net.bind(Unknown Source)
INFO  2013-01-12 13:50:25.813 [background-task-0]    at sun.nio.ch.Net.bind(Unknown Source)
INFO  2013-01-12 13:50:25.813 [background-task-0]    at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
INFO  2013-01-12 13:50:25.813 [background-task-0]    at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
INFO  2013-01-12 13:50:25.813 [background-task-0]    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.bind(NioServerSocketPipelineSink.java:148)
INFO  2013-01-12 13:50:25.814 [background-task-0]    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.handleServerSocket(NioServerSocketPipelineSink.java:100)
INFO  2013-01-12 13:50:25.814 [background-task-0]    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.eventSunk(NioServerSocketPipelineSink.java:74)
INFO  2013-01-12 13:50:25.814 [background-task-0]    at org.jboss.netty.channel.Channels.bind(Channels.java:468)
INFO  2013-01-12 13:50:25.814 [background-task-0]    at org.jboss.netty.channel.AbstractChannel.bind(AbstractChannel.java:192)
INFO  2013-01-12 13:50:25.814 [background-task-0]    at org.jboss.netty.bootstrap.ServerBootstrap$Binder.channelOpen(ServerBootstrap.java:348)
INFO  2013-01-12 13:50:25.814 [background-task-0]    at org.jboss.netty.channel.Channels.fireChannelOpen(Channels.java:176)
INFO  2013-01-12 13:50:25.814 [background-task-0]    at org.jboss.netty.channel.socket.nio.NioServerSocketChannel.<init>(NioServerSocketChannel.java:85)
INFO  2013-01-12 13:50:25.815 [background-task-0]    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:142)
INFO  2013-01-12 13:50:25.815 [background-task-0]    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:90)
INFO  2013-01-12 13:50:25.815 [background-task-0]    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:282)
INFO  2013-01-12 13:50:25.815 [background-task-0]    ... 6 more


Thanks in advance for any help.
tigersharkdog
 
Posts: 2
Joined: Sat Jan 12, 2013 3:42 am

Re: Xbox not detected in PMS but can still stream from Xbox

Postby tigersharkdog » Mon Jan 14, 2013 11:29 am

Update, I restarted my computer and now the Xbox cannot detect PMS.
tigersharkdog
 
Posts: 2
Joined: Sat Jan 12, 2013 3:42 am


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 20 guests