OGM files refuse to play via mencoder.

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

OGM files refuse to play via mencoder.

Postby jizames » Thu Dec 06, 2012 8:24 am

Hi all, long time lurker (circa 2010-ish), first time poster. I never really had a problem getting PMS to run all these years and if I ever ran into a bump, I usually managed to find a solution on these boards. I now have an issue that I just can't seem to figure out no matter what I do.

I recently formatted my PC and did a fresh install of PMS. I believe that codec installation for Windows doesn't affect PMS but just for added measure, I also did a fresh install of Media Player Classic, madVR and LAV Filters and set the LAV filters as my preferred ones. Now for the issue at hand...

I have some ogm files which used to work flawlessly on PMS 1.72.0 before I formatted my pc, with the ability to select different audio streams and external subs. Now, attempting to play any via mencoder gives the "This content cannot be played (800288E1)" message. Settings are all the same as I had originally had them, so I can't figure out what the issue is. The videos will play through FFmpeg but external subs won't work and I'd rather have the convenience of using mencoder. mkv, avi, mp4, m2ts and other video formats all work without a hitch.

debug.log shows the following:

Code: Select all
DEBUG 2012-12-06 02:04:12.830 [New I/O server worker #1-12] Starting "C:\Program Files (x86)\PS3 Media Server\win32\ffmpeg.exe" -ss 1 -i "C:\Users\James\Videos\yuyu.ogm" -an -an -s 320x180 -vframes 1 -f image2 pipe:
DEBUG 2012-12-06 02:04:12.893 [New I/O server worker #1-12] Attaching thread: ffmpeg.exe-1
DEBUG 2012-12-06 02:04:15.529 [Buffered IO End Checker] Stopping process: ffmpeg.exe-1
INFO  2012-12-06 02:04:16.512 [New I/O server worker #1-2] Starting transcode/remux of yuyu.ogm
DEBUG 2012-12-06 02:04:16.559 [New I/O server worker #1-2] Creating pipe \\.\pipe\mencoder1354777456559
DEBUG 2012-12-06 02:04:16.606 [Thread-17] Waiting for pipe connection \\.\pipe\mencoder1354777456559
DEBUG 2012-12-06 02:04:16.668 [mencoder.exe-2] Starting "C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe" -ss 0 "C:\Users\James\Videos\yuyu.ogm" -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=8 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=8:keyint=5:vqscale=1:vqmin=2:vrc_maxrate=54000:vrc_buf_size=1835 -aid 0 -subdelay 20000 -ofps 24000/1001 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1354777456559
DEBUG 2012-12-06 02:04:16.668 [mencoder.exe-2] Reading pipe: \\.\pipe\mencoder1354777456559
DEBUG 2012-12-06 02:04:16.668 [mencoder.exe-2] Attaching thread: mencoder.exe-2
INFO  2012-12-06 02:04:16.777 [StartPlaying Event] renderer:, file: C:\Users\James\Videos\yuyu.ogm
DEBUG 2012-12-06 02:04:16.980 [Thread-21] MEncoder SB41 (C) 2000-2012 MPlayer Team
DEBUG 2012-12-06 02:04:16.980 [Thread-21] Custom build by SubJunk, http://www.spirton.com
DEBUG 2012-12-06 02:04:16.980 [Thread-21]
DEBUG 2012-12-06 02:04:16.980 [Thread-21] success: format: 0  data: 0x0 - 0xcde31fa
DEBUG 2012-12-06 02:04:16.980 [Thread-21] libavformat version 54.29.105 (internal)
DEBUG 2012-12-06 02:04:16.980 [Thread-21] libavformat file format detected.
INFO  2012-12-06 02:04:16.980 [mencoder.exe-2] Process C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe has a return code of -1073741819! Maybe an error occurred... check the log file
DEBUG 2012-12-06 02:04:19.289 [Buffered IO End Checker] Stopping process: mencoder.exe-2
INFO  2012-12-06 02:04:21.348 [StopPlaying Event] renderer:, file: C:\Users\James\Videos\yuyu.ogm

Any help would be greatly appreciated. Again, these ogm files all worked flawlessly on PMS before and still do on pc and via ffmpeg.
Posts: 2
Joined: Thu Dec 06, 2012 8:09 am

Re: OGM files refuse to play via mencoder.

Postby jizames » Thu Dec 06, 2012 9:47 am

I know that no one likes double posting but problem solved. I reverted back to 1.70.1 (which I guess was the one I had install prior to my HDD's format) and all OGM videos play again. I guess this should be taken as a bug report.
Posts: 2
Joined: Thu Dec 06, 2012 8:09 am

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot] and 6 guests