PMS and Spotify Problems

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PMS and Spotify Problems

Postby ashdump » Fri Nov 23, 2012 3:20 am

Hello,

I'm trying to connect my PS3 to my computer via PMS. More specifically I would like to stream Spotify using this method. I have followed a couple different tutorials found on the internet however I am having some problems.

http://ps3-spotify.blogspot.com/
http://www.2k3.org/?p=4598

PMS can be found on my PS3 but when I click on the server all I can see is my C:/(preload) - Then from there I basically have access to all my folders.

I was able to get the bridge to work - the blue dot shows up in my program manager when I run Spotify. (FYI - I'm using Win XP)

One part that I do not understand well is when people reference C:\ProgramData\PMS - I can not find that folder for the life of me however I did find C:\Documents and Settings\All Users\PMS - which might be the same or what I'm looking for?

I was able to change the WEB.conf file per the directions - that original file was found in C:\Program Files\PS3 Media Server (I think)

I then kept the original file in the folder and also made a copy and put that in C:\Documents and Settings\All Users\PMS too.

Maybe I have a problem with files being in the wrong folders or in the wrong users folders on my computer? Or maybe I need to change some settings on the PMS side of things?

Also, is it just me or do I think that WEB.conf files disappears sometimes? - I've moved files around so much I'm thinking of starting over from scratch or uninstalling PMS at least.

Can anyone help a fellow PMS user out? Thanks for reading.
ashdump
 
Posts: 5
Joined: Fri Nov 23, 2012 3:04 am

Re: PMS and Spotify Problems

Postby chocolateboy » Fri Nov 23, 2012 3:26 am

chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: PMS and Spotify Problems

Postby ashdump » Fri Nov 23, 2012 3:46 am

Thanks for the quick reply. I read all of that first but it doesn't really explain or help me out. I've laid out some specific details and I'm wondering if my assumptions are correct or wrong?

I think I've found all the correct folders and files however they are in slightly different places....?
ashdump
 
Posts: 5
Joined: Fri Nov 23, 2012 3:04 am

Re: PMS and Spotify Problems

Postby chocolateboy » Fri Nov 23, 2012 3:59 am

ashdump wrote:1. One part that I do not understand well is when people reference C:\ProgramData\PMS - I can not find that folder for the life of me however I did find C:\Documents and Settings\All Users\PMS - which might be the same or what I'm looking for?
2. Maybe I have a problem with files being in the wrong folders or in the wrong users folders on my computer?
3. I think I've found all the correct folders and files however they are in slightly different places....?


if you read the FAQ, it answers the question in the first line:

meskibob wrote:The actual locations are listed in the first lines of output on the Traces tab in the GUI and the debug.log.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: PMS and Spotify Problems

Postby ashdump » Fri Nov 23, 2012 4:00 am

BOOM!!!!! After hours and hours of trying and failing I finally got it to work!!!!

A quick recap on how I was able to make it work. I finally uninstalled PMS and deleted any and all folders left behind.

I re-downloaded PMS and followed the directions from the websites above.

My hiccup was the WEB.conf file. Drag this file to your desktop from C:\Program Files\PS3 Media Server - then edit it per the directions. Then put it in C:\Documents and Settings\All Users\PMS

This WEB.conf file should only be in one place when all said and done. It should be in the folder above along with another file called PMS.conf. That file is already there and you do not need to do anything to it.

Thank you to whomever developed this program. It is working perfectly! :D
ashdump
 
Posts: 5
Joined: Fri Nov 23, 2012 3:04 am

Re: PMS and Spotify Problems

Postby ashdump » Fri Nov 23, 2012 4:14 am

chocolateboy wrote:
ashdump wrote:1. One part that I do not understand well is when people reference C:\ProgramData\PMS - I can not find that folder for the life of me however I did find C:\Documents and Settings\All Users\PMS - which might be the same or what I'm looking for?
2. Maybe I have a problem with files being in the wrong folders or in the wrong users folders on my computer?
3. I think I've found all the correct folders and files however they are in slightly different places....?


if you read the FAQ, it answers the question in the first line:

meskibob wrote:The actual locations are listed in the first lines of output on the Traces tab in the GUI and the debug.log.

Thanks for your help. Keep up the good work!
ashdump
 
Posts: 5
Joined: Fri Nov 23, 2012 3:04 am

Re: PMS and Spotify Problems

Postby ashdump » Tue Nov 27, 2012 11:09 pm

Revisiting an intermittent issue when streaming Spotify. I get a pause every 40 to 90 seconds like its skipping. I thought immediately that it was Spotify and their servers or my ISP. It comes in waves and isn't always present but when it is - it makes listening to music hard.

When music pause is present, I'll disconnect from PMS and stream to my computer speakers but usually nothing happens. I feel like there might be a lag or an info drop between my laptop and PS3.

I have a Linksys N900v2 and set my QoS to put my laptop and PS3 in the front of the line but that doesn't seem to help. Are there any tweaks in the PMS module that I can make? I'm also not ruling out that the problem doesn't lie with Spotify. It still very well could.

debug report here http://pastebin.com/dVCf6Nu4

Thanks in advance!
ashdump
 
Posts: 5
Joined: Fri Nov 23, 2012 3:04 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 9 guests