Spotify streaming 10 seconds delay

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Spotify streaming 10 seconds delay

Postby Cybr » Thu Nov 01, 2012 1:23 am

Hi there!

I've been using PS3 Media Server the day I got my PS3 (in exchange for my PC in the living room).
This was about 3 weeks ago =D

Now the thing is, I love Spotify. Especially since I got a free premium subscription from my ISP :p

BUT, when I want to stream to PS3 (note: took me freaking 10 hours to set up), I suffer from a delay, circa ~10 seconds.
Before, I also suffered from the streaming server randomly crashing on the PS3, i.e. losing connection. This has been solved by removing the splitter between the router and the PS3.

So here's the setup:

1: router
I've been through 2 routers, one is the ZTE H220N (KPN Experia Box (100MB/s FULL DUPLEX)), and the other is Arcadyan VGV7519 (KPN Experia Box V8 (1000MB/s FULL DUPLEX). Both the routers have the same problem.
However, now I have a gigabit connection in-home, and Wi-Fi isn't instable anymore.
100MB/s fiber optics connection outbound.
I absolutely HATE Wi-Fi, since A: high ping, B: not maintaining speed. So I don't use Wi-Fi (except for phones :p)

2: computer
- 2500K CPU @ 4,5GHz, 16GB RAM @ 1600MHz, Crucial M4 SSD (where the offline files from Spotify are on, as is all software)
- Windows 7 Home Premium x64

2.1: Radio software
NCH BroadWave Audio Streaming Server (cracked full version)
This software creates an enormous echo when I'm streaming it on and from the same computer (so no lag here!)

2.2: Streaming software
PSM 1.70.1

2.3: Codecs
PCM through MPlayer WEB (that's what the PS3 says)

2.4 WEB.conf:
Code: Select all
# audio streams
audiostream.Web,Radios=Spotify BroadWave,http://192.168.2.32:88/broadwave.m3u?src=1&rate=1,http://hometheaterreview.com/images_news/spotify-logo.gif
#audiostream.Web,Radios=Spotify asx,http://192.168.2.32:88/broadwave.asx?src=1&rate=1,http://hometheaterreview.com/images_news/spotify-logo.gif
audiostream.Web,Radios=Spotify DSBridge,http://localhost:8124


So as you can see, all the hardware is fine. Maybe the problem lies with PSM's connection with BroadWave?

Unfortunately, I cannot seem to install or bind DSBridge to Spotify =[

Is anyone having the same problem? Or knows a(n alternative) solution?

---------------
;tldr?;

When I hit play on Spotify, using NCH BroadWave Audio Streaming Server and PSM, the sound is delivered to the PS3. But with 10 seconds delay.

EDIT::

Managed to get 2.5 seconds delay through TVersity and using my Xbox... On the PS3 it just plays back from start what has been buffered (up to 8024MB cache >.> = up to 7 hours delay)
But this still doesn't solve the problem PSM + BroadWave + PS3... and I need to switch from analogue to digital all the time I want to listen to music or play a game.. using Astro A40 headset for games and using my speakers for music...
Cybr
 
Posts: 1
Joined: Thu Nov 01, 2012 1:04 am

Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 22 guests