XVID (DIVX) PROBLEM: Videostream breaks, connection broken

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

XVID (DIVX) PROBLEM: Videostream breaks, connection broken

Postby Promaetheus » Sat Mar 28, 2009 10:52 am

Specifications:
My System: Win XP Pro
My CPU: Intel Core 2 Duo CPU E6750 @ 2,66GHz, 2GB RAM
PS3 Media Server Version: 1.10.51
Network: Linksys WRT-54G Router, PC connected to router with cable, PS3 connectet to router via WiFi.

Problem:
As i streamed mkv files after 3 minutes the video starts shuttering. then i limited the max bandwith to 14. Now the mkv file didn´t shutter anymore. perfect!
Now my son looked some 150MB avi (xvid) movie and after a while the video stopped and the connection to the media server was broken. after starting the video again the same error occured.
I went up to the PC and looked into the log file. No error occured there.

What could make this problem? The WiFi Connection can´t be the reason, cause the mkv file is ok now?! There is NO problem viewing mkv or dvd-files! The problem only occurs when you play XVID-files (EDIT: sometimes even at divx-files, but not with ALL divx files).
EDIT: i just added the debug.log.zip, maybe this is for use.

PS: I want to excuse for my bad english, but i come from austria and speek german normally.
PPS: Great thanks to the programmers of PS3 Media Server. It´s a GENIOUS work! Unbelievable how simple the installation and setup is. THANKS!
Attachments
debug.zip
(98.8 KiB) Downloaded 40 times
Last edited by Promaetheus on Mon Mar 30, 2009 9:09 am, edited 3 times in total.
Promaetheus
 
Posts: 3
Joined: Sat Mar 28, 2009 10:42 am

Re: Video stream stopps itself after some minutes

Postby d0000h » Sun Mar 29, 2009 5:29 pm

Same problem here. divx files start to stutter and cannot watch after 6-20minutes, and then cannot get it to work again unless I reboot router. HD movies play pretty good, but if I pause for 30secs and then play again it can start stuttering after that.

Looks like when this happens, the router is stuck in 1-2Mbps transfer mode for some reason. For divx I think this is why it happens more easily because the bit rate is generally very low so it says in 1-2Mbps mode, but it doesn't get knocked up to 5.5Mbps (or higher) when it needs to for some reason. I don't know why it happens for HD movies, other than perhaps it fills up a buffer of some sort in the PS3 so the bitrate drops, but then it cannot recover to higher bit rates when it needs to.

It seems quite obvious when this happens as the throughput out of the router just tanks and does not recover. I'm trying different router settings but no luck yet.

I will try older PMS version next as I watch many HD movies with no problems what so ever in the past with older versions. How can I disable the auto checking for newer version? (I cannot have the upgrade popup window appear every single time I run PMS.) Thx.

-Deuce-
d0000h
 
Posts: 10
Joined: Tue Feb 03, 2009 6:20 am

Re: Video stream stopps itself after some minutes

Postby d0000h » Mon Mar 30, 2009 6:34 am

Reverted to 1.04 and watched 2h HD movie with no problems. Will have to try divx movie later.
d0000h
 
Posts: 10
Joined: Tue Feb 03, 2009 6:20 am

Re: Video stream stopps itself after some minutes

Postby Promaetheus » Mon Mar 30, 2009 7:36 am

Today i tested again. mkv works fine, dvd-files work fine, but only xvid-files (sometimes divx, but not all) make problems. everytime i try to look a xvid movie, after a few seconds or minutes the error occurs: "connection to media server lost" then i am also logged out of the playstation network. when i logg in again and start the movie on my ps3 the same problem starts as described above.

The exact error message is:
Die Verbindung zwischen PS3-System und Medienserver wurde getrennt.

In english:
The connection between PS3-System and Mediaserver was closed/cut/disconnected.


Maybe the ps3 media server has a problem with divs/xvid movies? I postet my debug.log again. maybe it can help you figure out what´s wrong with ps3 media player.
Attachments
debug.zip
(47.1 KiB) Downloaded 38 times
Promaetheus
 
Posts: 3
Joined: Sat Mar 28, 2009 10:42 am

Re: XVID (DIVX) PROBLEM: Videostream breaks, connection broken

Postby d0000h » Mon Mar 30, 2009 4:58 pm

You talk about being disconnected from the PSN when you lose connection to the media server. Interestingly yesterday for the first time I noticed that the moment uTorrent (bittorrent client) was closed/shut down on my PC, I lost connection to PMS and had to rescan for media server to find it again. I found that strange.
d0000h
 
Posts: 10
Joined: Tue Feb 03, 2009 6:20 am

Re: XVID (DIVX) PROBLEM: Videostream breaks, connection broken

Postby Promaetheus » Mon Mar 30, 2009 7:14 pm

Yes. The disconnection from PSN is not everytime. Today i haven´t been disconnected, only the connection to the PS3MS was closed/lost.
Maybe PS3MS has really problems streaming divx/xvid movies?! The W-LAN cannot be the problem, caus as i wrote above i can view large mkv-titles and also dvd-files without problems.
Promaetheus
 
Posts: 3
Joined: Sat Mar 28, 2009 10:42 am

Re: XVID (DIVX) PROBLEM: Videostream breaks, connection broken

Postby epbiggs » Wed Apr 22, 2009 12:52 am

I have the exact same problem... anytime I stream a DIVX or XVID to my PS3, it works for a few minutes, then stops. I have to start the video over and try to find my place again. It happens 5 or 6 times during a movie. I love the program and use it for viewing all other formats, especially MKV's. If it weren't for this, I'd uninstall my Tversity, but it plays XVID/DIVX with no problems, so it stays for now. I"m assuming it is a PS3 Media Server program problem, since they stream fine using Tversity. Look forward to this being fixed.
epbiggs
 
Posts: 1
Joined: Wed Apr 22, 2009 12:44 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 17 guests