mencoder this content cannot be played

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

mencoder this content cannot be played

Postby ToWi1989 » Mon Jul 09, 2012 11:13 pm

Hi,

I've been trying to deal with this problem i've been having. Im not realy sure when this first started, but for some reason i can't play any video files using the mencoder when subs are enabled in the general transcoding settings (error code 800288E1 This content cannot be played). I only use mkv's.

I've been trying everything i could've think off, and narrowed it down to this:
Subs disabled:
- Tsmuxer file and general mencoder file plays (from transcode folder).
Subs enabled:
- Tsmuxer file plays, but none of the mencoder files work (from transcode folder).

Any idea how i can get the mencoder working properly again?


This is the part where it seems to go wrong:
Code: Select all
[win32/mencoder.exe] DEBUG 00:44:05.218 Starting "C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe" -ss 0 -quiet "D:\Downloads\Films\Mission.Impossible.Ghost.Protocol.2011.1080p.BluRay.x264-SECTOR7 [PublicHD.ORG]\Mission.Impossible.Ghost.Protocol.2011.1080p.BluRay.x264-SECTOR7 [PublicHD.ORG].mkv" -quiet -quiet -oac lavc -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=8 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=8:keyint=10:vqscale=12:vqmin10 -subfont C:\Windows\Fonts\Arial.ttf -quiet -quiet -sid 0 -quiet -quiet -ofps 24000/1001 -quiet -quiet -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1341873845121
[win32/mencoder.exe] DEBUG 00:44:05.220 Reading pipe: \\.\pipe\mencoder1341873845121
[win32/mencoder.exe] DEBUG 00:44:05.220 Attaching thread: win32/mencoder.exe
[Thread-466] DEBUG 00:44:05.234 MEncoder SB22 (C) 2000-2012 MPlayer Team
[Thread-466] DEBUG 00:44:05.234 Custom build by SubJunk, http://www.spirton.com
[Thread-466] DEBUG 00:44:05.234
            [Thread-465] DEBUG 00:44:05.235 Option lavcopts: Unknown suboption vqmin10
            [Thread-466] DEBUG 00:44:05.235
            [Thread-466] DEBUG 00:44:05.235 Exiting... (error parsing command line)
            [Thread-465] DEBUG 00:44:05.235 Error parsing option on the command line: -lavcopts
[win32/mencoder.exe] INFO  00:44:05.236 Process C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe has a return code of 1! Maybe an error occurred... check the log file
[Thread-453] DEBUG 00:44:05.628 Stopping process: win32/ffmpeg.exe
Last edited by ToWi1989 on Mon Jul 09, 2012 11:56 pm, edited 3 times in total.
ToWi1989
 
Posts: 3
Joined: Mon Jul 09, 2012 10:58 pm

Re: mencoder this content cannot be played

Postby ToWi1989 » Mon Jul 09, 2012 11:53 pm

Omg this actually turned out to be very lame. The parameters for the MPEG-2 settings were entered in the wrong order; it was:
keyint=XX:vqscale=XX:vqmin=XX
And it should be as followed:
vqmin=XX:vqscale=XX:keyint=XX
ToWi1989
 
Posts: 3
Joined: Mon Jul 09, 2012 10:58 pm

Re: mencoder this content cannot be played

Postby fizion » Mon Oct 29, 2012 9:09 am

Thanks for posting the fix, ToWi1989! Had the same issue and your solution works perfectly.
fizion
 
Posts: 1
Joined: Mon Oct 29, 2012 9:02 am

Re: mencoder this content cannot be played

Postby JonAntoine » Mon Nov 12, 2012 6:12 pm

I am seeing this issue even after changing the parameters for the MPEG-2 setting to "vqmin=XX:vqscale=XX:keyint=XX". I am attempting to digitize my media collection using MakeMKV for DVD's and Blu-ray's. My server is setup using Ubuntu 12.10. Any direction on resolving this issue is greatly appreciated.
JonAntoine
 
Posts: 1
Joined: Mon Nov 12, 2012 6:08 pm


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 11 guests