Freezing at end of MKV with 1.54.0

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Freezing at end of MKV with 1.54.0

Postby mistersmith » Tue Jul 03, 2012 7:08 am

Ever since the upgrade to 1.54.0, every single .mkv file (and only .mkvs) fails to play all the way through. Each one gets a few seconds to a minute from the end and just freezes -- the buffer empties, the video won't play, and it never cycles through to the next video. The program is also unresponsive to controls for a minute or two. I've tried several files that I know worked fine before the upgrade, every single .mkv has problems, and it's happening with all engines.

I've been using PS3MS for something like two years and never had a problem before. The PC that's doing the transcoding is 6-core, 12GB, Win7, etc., and is never close to fully taxed. And like I said, other files (mp4, m2ts) don't have this problem. I'm streaming to PS3, wired, through some boring old router.

Based on the text from the log of what's displayed when the freeze occurs I'm guessing this is a Java problem, but what do I know:

Code: Select all
INFO  2012-07-02 21:33:03.270 [Thread-589] Exception in thread "Thread-589" java.lang.NullPointerException

INFO  2012-07-02 21:33:03.274 [Thread-589]    at net.pms.io.BufferedOutputFileImpl.shiftVideo(BufferedOutputFileImpl.java:557)

INFO  2012-07-02 21:33:03.274 [Thread-589]    at net.pms.io.BufferedOutputFileImpl.write(BufferedOutputFileImpl.java:373)

INFO  2012-07-02 21:33:03.274 [Thread-589]    at net.pms.io.OutputBufferConsumer.run(OutputBufferConsumer.java:57)

Here's the full Trace report: http://pastebin.com/YUpC9UGh

Any ideas?

Edit: oh yeah, btw -- I effing LOVE this program. Thanks so much for all your work!
Last edited by Raptor399 on Tue Jul 03, 2012 7:25 am, edited 1 time in total.
Reason: Edited for code fragments
mistersmith
 
Posts: 3
Joined: Tue Jul 03, 2012 6:52 am

Re: Freezing at end of MKV with 1.54.0

Postby Raptor399 » Tue Jul 03, 2012 7:26 am

Interesting info, thanks for reporting.
I'll see what I can do.

Looks as if the buffer is null in shiftVideo(). That's a bit strange.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Freezing at end of MKV with 1.54.0

Postby mistersmith » Tue Jul 03, 2012 7:53 am

Thanks. Let me know if I can provide any more details.

For what it's worth, I uninstalled 1.54 and went back to 1.52.1 and everything's fine.
mistersmith
 
Posts: 3
Joined: Tue Jul 03, 2012 6:52 am

Re: Freezing at end of MKV with 1.54.0

Postby Raptor399 » Tue Jul 03, 2012 10:23 pm

The problem is I don't really see relevant changes to BufferedOutputFileImpl.java between 1.52.1 and 1.54.0 that would explain a sudden NullPointerException.
Does the bug happen consistently in 1.54.0?
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Freezing at end of MKV with 1.54.0

Postby mistersmith » Wed Jul 04, 2012 7:13 pm

Yeah, every single .mkv file, and only .mkvs, froze at the end, the buffer emptied, and PS3MS essentially stalled. This happened with files I'd previously had work perfectly, and "problem files" on .54 are playing fine in .52.1.

Other files, like stuff I'd converted to m2ts, played perfectly.

I can reinstall .54 and see if it happens again, but that'll take me a day or so.
mistersmith
 
Posts: 3
Joined: Tue Jul 03, 2012 6:52 am

Re: Freezing at end of MKV with 1.54.0

Postby justmatt » Wed Jul 04, 2012 8:03 pm

This is exactly the problem I reported in this thread just a couple days ago, although mine was much more long-winded. :lol:

I hadn't looked at my buffer before I read this, but I just watched it, and mine ticks down to zero as well. My freezes are a very consistent 15-20 sec from the EOF.

mistersmith, you say that your PC is never close to fully taxed. I'm seeing the exact same behavior as you, except my CPU cycles hit 100% at 4 minutes (+/- 5 sec) from the end of the file every single time, and stay there for a couple minutes after the file ends. The unresponsiveness you mentioned, on my PC, is directly related to that CPU load, and goes away as soon as the load falls.
justmatt
 
Posts: 9
Joined: Thu Jun 28, 2012 11:49 pm

Re: Freezing at end of MKV with 1.54.0

Postby taconaut » Wed Jul 04, 2012 8:19 pm

And another one with an interesting discussion viewtopic.php?f=6&t=14615
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1065
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland

Re: Freezing at end of MKV with 1.54.0

Postby justmatt » Sun Jul 08, 2012 7:03 pm

Any ideas on this, or more info we can provide? I've tested it extensively in both .53 and .54, and it behaves the same in both. I've reverted to .52.1 for now, as that was the last version without this issue.
justmatt
 
Posts: 9
Joined: Thu Jun 28, 2012 11:49 pm

Re: Freezing at end of MKV with 1.54.0

Postby S7eele » Wed Jul 18, 2012 4:10 am

Nothing to report that would be of any help in solving the problem but thought I would chime in and state I am having the same issue. Only thing I have noticed is that if you let it sit long enough it seems to jump back 10-15 seconds and start playing only to end in the same place again. I watched it do this at least three times in a row. I am also going to have to go back and look more closely though because I thought it was happening with other file types as well (.avi (mpeg2)). Not an expert by any means but if I find anything that might be helpful I will post it.

Not sure what I would have done over the past few years without this software, thanks to everyone that makes it possible.
S7eele
 
Posts: 13
Joined: Wed Apr 20, 2011 7:02 am

Re: Freezing at end of MKV with 1.54.0

Postby MyNameIsJeff » Sun Aug 05, 2012 2:18 am

Wanted to chime in and say that I've started to have the same problem. Oddly enough everything was fine when I left for a 2 week vacation, came home and started seeing this problem.
MyNameIsJeff
 
Posts: 1
Joined: Sun Aug 05, 2012 2:16 am

Next

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot] and 16 guests