Fast forward problem....

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Fast forward problem....

Postby kiptanoi » Sun Jun 03, 2012 8:28 pm

Hi!

I have a ViewSonic media player. That one cant stream out movies from rar folders...
So now I tryed Playstation media server... And all works great, I am happy with it...
But I cant fast forward, or go backwards in movies, the movie is hang up, and I need to see the movie from the beginning all time that is happend..

So my problem is that I cant go fast forward or backwards with PMS...
But I can do that without problem with my other media player...

My rig is:
Windows 7 64 bit
Intel Core i5-2500K
Ram: 8GB DDR III
LAN = 100Mb
I am running PMS on my SSD disk.
And I have movies on a intern SATA III disk (6GB/s)


Bonus Question: Can I get my ViewSonic to see and use PMS through network?
How to?

Thanks
Last edited by kiptanoi on Mon Jun 04, 2012 2:34 pm, edited 1 time in total.
kiptanoi
 
Posts: 10
Joined: Tue May 29, 2012 7:32 pm


Re: Fast forwanrd problem....

Postby ExSport » Mon Jun 04, 2012 1:35 pm

There are many different media renderers, one with timeseek support, other with byteseek support.
PS3 supports TimeSeek so FF/REW is working quite well (or you can use GOTO feature).
Renderers like Panasonic TV doesn't support TimeSeek or GOTO feature so only solution is using ByteSeek which is not documented well and it works little bit on trial and error 8-)
It uses instead of Variable bitrates Constant bitrates so PMS can predict byteseeking (byte2timeseek conversion)
Check Panasonic.conf renderer:
https://github.com/ps3mediaserver/ps3me ... c.conf#L10
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Fast forwanrd problem....

Postby kiptanoi » Mon Jun 04, 2012 2:34 pm

ExSport wrote:There are many different media renderers, one with timeseek support, other with byteseek support.
PS3 supports TimeSeek so FF/REW is working quite well (or you can use GOTO feature).
Renderers like Panasonic TV doesn't support TimeSeek or GOTO feature so only solution is using ByteSeek which is not documented well and it works little bit on trial and error 8-)
It uses instead of Variable bitrates Constant bitrates so PMS can predict byteseeking (byte2timeseek conversion)
Check Panasonic.conf renderer:
https://github.com/ps3mediaserver/ps3me ... c.conf#L10

´
Well, I am not a coder or I dont understand all of that, I am sorry.... :/
All I want is that fast forward and rewind is going to work better then it does now :P
kiptanoi
 
Posts: 10
Joined: Tue May 29, 2012 7:32 pm

Re: Fast forward problem....

Postby ExSport » Mon Jun 04, 2012 4:18 pm

You don't need to be coder.
What I linked is comments for modifing your renderer.conf file what is text file in your Renderer folder ;)
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Fast forward problem....

Postby anq4 » Sun Dec 16, 2012 12:53 am

I have the same exact problem with a Sony Bravia KDL-22EX320, fast forward/rewind is almost unusable.

But please don't direct me to the FAQ, cause it's not a network problem.
TV is on a wired dedicated fast ethernet network that has no problem at all, and I'm a professional network engineer.
Moreover the TV is correctly identified:
INFO 2012-12-15 22:49:56.324 [pool-5-thread-1] Renderer Sony Bravia EX found on this address: 192.168.33.66
INFO 2012-12-15 22:49:58.340 [pool-5-thread-1] Address /192.168.33.66 has an estimated network speed of: 85 Mb/s

A Panasonic Smart Viera Plasma TV on the same network has no problem:
INFO 2012-12-15 22:59:00.480 [pool-5-thread-3] Checking IP: 192.168.33.44 for Panasonic
INFO 2012-12-15 22:59:05.121 [pool-5-thread-3] Renderer Panasonic found on this address: 192.168.33.44

Moreover other two media servers I tried on the same PC worked like a charm, with the same files.

To be more precise with mpeg2-ps files recorded from DVB-T, when i fast forward the timer moves on, but when I press play the video starts from the beginning:
INFO 2012-12-16 00:37:57.293 [New I/O server worker #1-2] Checking shared folder: F:\PVR
INFO 2012-12-16 00:37:57.293 [New I/O server worker #1-2] Checking shared folder: D:\Programmi\eMule\Incoming
INFO 2012-12-16 00:38:05.152 [StartPlaying Event] renderer: 192.168.33.66, file: F:\PVR\LA7(121120_225105).mpg

With Xvid avi files instead (direct or remuxed) fast forward seems to work at the beginning, but after some seconds or a few stop and forward sequences, video doesn't resume, or stops, or goes out of sync, or jumps parts.
After that buffer bar on the home page starts to go crazy and from there on renders starts to have huge problem with every renderer, so that I have to restart the server.

The same files work well also directly on the Sony TV from a USB drive pen.

So the only thing that doesn't work is PMS+Sony, and it always happened during past 6 months, with many Sony firmware upgrades and PMS and Java upgrades, with config from scratch.
anq4
 
Posts: 2
Joined: Sun Dec 16, 2012 12:19 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Majestic-12 [Bot], Topken and 3 guests

cron