PS3 Media Server plays wrong file.

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PS3 Media Server plays wrong file.

Postby Digital God » Sat Jan 14, 2012 9:10 pm

Hi all.
The problem is that when i launch, for example first episode, ps3 media server plays another.

Logs:

Code: Select all
[New I/O server worker #1-2] INFO  22:58:55.076 Starting transcode/remux of Firefly.2002.Ep01-02.1080p.BluRay.DTS.x264.Rus.Eng.mkv
[New I/O server worker #1-2] DEBUG 22:58:55.076 Forcing short path name on P:\ServerFolders\Видео\Сериалы\Светлячок (Firefly)\Firefly.2002.Ep01-02.1080p.BluRay.DTS.x264.Rus.Eng.mkv
[New I/O server worker #1-2] DEBUG 22:58:55.091 Starting "C:\Program Files (x86)\PS3 Media Server\win32\ffmpeg.exe" -vframes 1 -i P:\SERVER~1\9734~1\DE9D~1\(FIREF~1\FIREFL~1.MKV -vcodec copy -f h264 -vbsf h264_mp4toannexb -an -y pipe:
[New I/O server worker #1-2] DEBUG 22:58:55.185 Attaching thread: win32/ffmpeg.exe
[Thread-24] DEBUG 22:58:55.840 ffmpeg version N-31564-g6c9e6a5-Sherpya, Copyright (c) 2000-2011 the FFmpeg developers
[Thread-24] DEBUG 22:58:55.840   built on Jul 19 2011 03:32:17 with gcc 4.2.5 20090330 (prerelease) [Sherpya]
[Thread-24] DEBUG 22:58:55.840   libavutil    51. 11. 0 / 51. 11. 0
[Thread-24] DEBUG 22:58:55.840   libavcodec   53.  8. 0 / 53.  8. 0
[Thread-24] DEBUG 22:58:55.840   libavformat  53.  6. 0 / 53.  6. 0
[Thread-24] DEBUG 22:58:55.840   libavdevice  53.  2. 0 / 53.  2. 0
[Thread-24] DEBUG 22:58:55.840   libavfilter   2. 27. 0 /  2. 27. 0
[Thread-24] DEBUG 22:58:55.840   libswscale    2.  0. 0 /  2.  0. 0
[Thread-24] DEBUG 22:58:55.840   libpostproc  51.  2. 0 / 51.  2. 0
[Thread-24] DEBUG 22:58:55.840 [matroska,webm @ 0002a160] Estimating duration from bitrate, this may be inaccurate
[Thread-24] DEBUG 22:58:55.840 Input #0, matroska,webm, from 'P:\SERVER~1\9734~1\DE9D~1\(FIREF~1\FIREFL~1.MKV':
[Thread-24] DEBUG 22:58:55.840   Metadata:
[Thread-24] DEBUG 22:58:55.840     title           : "Firefly" (2002)  - Episode 3: The Train Job
[Thread-24] DEBUG 22:58:55.840   Duration: 00:42:44.09, start: 0.000000, bitrate: 1728 kb/s
[Thread-24] DEBUG 22:58:55.840     Stream #0.0(eng): Video: h264 (High), yuv420p, 1920x1080, PAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       title           : ViDEO
[Thread-24] DEBUG 22:58:55.840     Stream #0.1(rus): Audio: ac3, 48000 Hz, stereo, s16, 192 kb/s (default)
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       title           : AC3 2.0 192 Kbps
[Thread-24] DEBUG 22:58:55.840     Stream #0.2(eng): Audio: dca (DTS), 48000 Hz, 5.1, s16, 1536 kb/s
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       title           : DTS 5.1 1536 Kbps
[Thread-24] DEBUG 22:58:55.840     Stream #0.3(eng): Audio: vorbis, 48000 Hz, stereo, s16
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       title           : Commentary track
[Thread-24] DEBUG 22:58:55.840     Stream #0.4(rus): Subtitle: [0][0][0][0] / 0x0000
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       title           : Tycoon
[Thread-24] DEBUG 22:58:55.840     Stream #0.5(rus): Subtitle: [0][0][0][0] / 0x0000
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       title           : Cinem
[Thread-24] DEBUG 22:58:55.840     Stream #0.6(eng): Subtitle: ass
[Thread-24] DEBUG 22:58:55.840     Stream #0.7: Attachment: [0][0][0][0] / 0x0000
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       filename        : CronosPro-SemiboldIt.ttf
[Thread-24] DEBUG 22:58:55.840     Stream #0.8: Attachment: [0][0][0][0] / 0x0000
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       filename        : CronosPro-Semibold.ttf
[Thread-24] DEBUG 22:58:55.840     Stream #0.9: Attachment: [0][0][0][0] / 0x0000
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       filename        : CronosPro-Bold.ttf
[Thread-24] DEBUG 22:58:55.840 Output #0, h264, to 'pipe:':
[Thread-24] DEBUG 22:58:55.840   Metadata:
[Thread-24] DEBUG 22:58:55.840     title           : "Firefly" (2002)  - Episode 3: The Train Job
[Thread-24] DEBUG 22:58:55.840     encoder         : Lavf53.6.0
[Thread-24] DEBUG 22:58:55.840     Stream #0.0(eng): Video: libx264, yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], q=2-31, 90k tbn, 23.98 tbc (default)
[Thread-24] DEBUG 22:58:55.840     Metadata:
[Thread-24] DEBUG 22:58:55.840       title           : ViDEO
[Thread-24] DEBUG 22:58:55.840 Stream mapping:
[Thread-24] DEBUG 22:58:55.840   Stream #0.0 -> #0.0
[Thread-24] DEBUG 22:58:55.840 Press [q] to stop, [?] for help
[Thread-24] DEBUG 22:58:55.840 frame=    1 fps=  0 q=-1.0 Lsize=       1kB time=00:00:00.00 bitrate=   0.0kbits/s   
[Thread-24] DEBUG 22:58:55.840
[Thread-24] DEBUG 22:58:55.840 video:1kB audio:0kB global headers:0kB muxing overhead 3.490566%


As you can see - instead of Firefly episode 1-2 i get episode 3.
What happend to pse media server? i get this error not only in tv series. (for example i start kill bill episode 1, but it starts episode 2)
Digital God
 
Posts: 8
Joined: Tue May 11, 2010 9:57 pm

Re: PS3 Media Server plays wrong file.

Postby meskibob » Sat Jan 14, 2012 9:19 pm

Looks like a mismatch between the filename and the metadata within the file, both of which are configurable and could have been specified incorrectly by whoever made the file.
This is an issue with the file, not an issue with PMS.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4768
Joined: Mon Jan 19, 2009 4:11 pm

Re: PS3 Media Server plays wrong file.

Postby Digital God » Sat Jan 14, 2012 9:27 pm

I think I found what the problem is.
I use StableBit DrivePool on my computer and PMS streams video from pool.
And problem with wrong file happens only when tv series are on different drives.

For example:
drive A contains episode 1-2, 4, 6
drive B contains episode 3,5,7,8,9

when i start episode 1-2 (first file in folder on drive A), it strarts episode 3 (first file in folder on drive B)..
if i put all episodes on one drive - it plays correct.

But i don't know if the problem is associated with PMS or with DrivePool.
Digital God
 
Posts: 8
Joined: Tue May 11, 2010 9:57 pm

Re: PS3 Media Server plays wrong file.

Postby Digital God » Sun Jan 15, 2012 8:31 am

The problem is with path.
Why PMS uses P:\SERVER~1\9734~1\DE9D~1\(FIREF~1\FIREFL~1.MKV instead of full path P:\ServerFolders\Видео\Сериалы\Светлячок (Firefly)\Firefly.2002.Ep01-02.1080p.BluRay.DTS.x264.Rus.Eng.mkv ?
Digital God
 
Posts: 8
Joined: Tue May 11, 2010 9:57 pm

Re: PS3 Media Server plays wrong file.

Postby meskibob » Sun Jan 15, 2012 3:41 pm

I apologize for the earlier statement. It looks like you have multiple files that resolve to the same shortname, which PMS should be able to handle.
Please create an issue on the issue tracker with the two file paths/names and that debug.log excerpt - https://code.google.com/p/ps3mediaserver/issues/list
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4768
Joined: Mon Jan 19, 2009 4:11 pm

Re: PS3 Media Server plays wrong file.

Postby Raptor399 » Sun Jan 15, 2012 5:17 pm

Digital God wrote:
Code: Select all
[New I/O server worker #1-2] INFO  22:58:55.076 Starting transcode/remux of Firefly.2002.Ep01-02.1080p.BluRay.DTS.x264.Rus.Eng.mkv
[New I/O server worker #1-2] DEBUG 22:58:55.076 Forcing short path name on P:\ServerFolders\Видео\Сериалы\Светлячок (Firefly)\Firefly.2002.Ep01-02.1080p.BluRay.DTS.x264.Rus.Eng.mkv
[New I/O server worker #1-2] DEBUG 22:58:55.091 Starting "C:\Program Files (x86)\PS3 Media Server\win32\ffmpeg.exe" -vframes 1 -i P:\SERVER~1\9734~1\DE9D~1\(FIREF~1\FIREFL~1.MKV -vcodec copy -f h264 -vbsf h264_mp4toannexb -an -y pipe:



Sounds like unwanted side effects of getShortPathNameW().

Someone with Windows should pick this one up, I can't replay this on OSX.
(Edit: created issue 1357)
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PS3 Media Server plays wrong file.

Postby Vizio_E422VLE » Tue Oct 16, 2012 7:30 am

[SOLVED - see end - the problem was either in the conf file or, more likely, having too broad a folder tree, i.e. too many subfolders within a single folder, which needed to be subdivided for faster and easier navigation.] I experience the same issue with movies on my Vizio TV, but not my Sony Bravia EX TV.

The Bravia uses the BraviaEX configuration file that came with the PS 3 Media Server download, but the Vizio uses a configuration file that I made trying to follow the instructions for alternative renderers. So, I suspect the issue may be in the renderer configuration file, not the PS 3 coding per se.

In particular, the BraviaEX.conf file has a line saying:
CreateDLNATreeFaster = true
That is a UPnP violation and the Vizio couldn't see any folders or files with it, so in the Vizio file I had to say:
CreateDLNATreeFaster = false
That enabled the Vizio to see the folders and files, but there was a mismatch in the sort order. The folders appeared in alphanumeric order per the Navigation tab settings in PS3 Media Server, but the files did not match. A window on the left side of the Vizio screen says Sort by Date, New to Old. I can't figure out how to change that, so I changed the Navigation tab setting to match it. That resolved the mismatch, although of course I would have preferred to keep everything in alphanumeric order.

I hope someone more knowledgeable might post a Vizio configuration file that works properly, meanwhile I will continue my fumbling attempts.

[SOLVED: I made a copy of the PS3.conf file in the renderers folder, changing only four things: filename=Vizio_E422VLE.conf, RendererName=Vizio E422VLE TV, RendererIcon=Vizio_E422VLE.png (which I found using Google images and downloaded to the renderers folder), UserAgentSearch = IPI/1.0 UPnP/1.0 DLNADOC/1.50 (and no other headers). Because the Vizio sends very little specific information, there may be a risk of misidentification if two similar TVs are used on the same network. As I have only a Bravia and a Vizio, this hasn't been a problem yet. Also, I had a "movies" folder where each movie title had its own subfolder; I suspected the subfolder list might be too long for PS3 Media Server to navigate, so I created an intermediate layer by letter, e.g. \movies\a\Abba; that reduced the number of folders at each level, and everything works fine now. The TV can navigate to the appropriate movie folder, then the #transcode# folder, then the first transcoded entry (title specifies a language, it would probably be ok to select a different transcoded entry, but attempting to play other files that aren't transcoded can cause an apparently endless loop).]
Vizio_E422VLE
 
Posts: 3
Joined: Tue Oct 02, 2012 4:49 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 10 guests