Memory Consumption

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Memory Consumption

Postby crakarjax » Mon Dec 12, 2011 4:08 am

Just upgraded to 1.50 and noticed that java.exe is taking up over 800Mb of memory. Is that normal? I'm on win 7 x64, 4Gb physical RAM, and running as a service.
crakarjax
 
Posts: 9
Joined: Wed Oct 12, 2011 12:27 am

Re: Memory Consumption

Postby Raptor399 » Mon Dec 12, 2011 8:26 am

crakarjax wrote:Just upgraded to 1.50 and noticed that java.exe is taking up over 800Mb of memory. Is that normal? I'm on win 7 x64, 4Gb physical RAM, and running as a service.

Yes, that is normal.

Rest assured, the memory may be allocated but it is freed just as easily if your other tasks need it.
It looks worse than it actually is.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Memory Consumption

Postby AdAstrum » Tue Dec 13, 2011 11:25 pm

Well, I am not so sure about this being normal. I did not upgrade PS3MS to version 1.50 until recently and was happy with the performance. I was able to stream with virtually no dropped packets even 1080p files (wired network). Now, after the upgrade I also see abnormal levels of resource utilization by jawaw.eve, mencoder.exe. Combined they seem to always use up 100% of CPU resources which slows down the PC that was working just fine before the upgrade. Even if I terminate the server, jawaw.exe and mencoder.exe seem to linger in the process tree (not killed automatically). Often I cannot even shut down the PC: an error about PS3MS pops-up, then Explorer fatal error occurs, so I have to manually terminate the system. I am strongly considering downgrading to the earlier version unless I figure out how to make things work soon.
AdAstrum
 
Posts: 14
Joined: Wed Sep 02, 2009 9:28 pm

Re: Memory Consumption

Postby AdAstrum » Tue Dec 13, 2011 11:30 pm

I forgot to mention that now I can only watch SD video files or 720p files that are natively supported by PS3. Any other HD contrainers that need to be transcoded, like mkv etc, cause a lot of dropped frames and freezing. This is actually why I came to the forum today to see if others are having similar issues or it is just my setup that is messed up.
AdAstrum
 
Posts: 14
Joined: Wed Sep 02, 2009 9:28 pm

Re: Memory Consumption

Postby Raptor399 » Tue Dec 13, 2011 11:47 pm

Sounds like the memory is the least of your problems.
Is there anything unusual in your debug.log?
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Memory Consumption

Postby AdAstrum » Wed Dec 14, 2011 3:52 am

checked logs. when playing mkv files, i see this line in the debug logs:

[New I/O server worker #1-2] INFO 20:41:52.250 Fatal error when retrieving AVC informations !

Is this a sign of configuration issue, or is it a bad video file? How can I check?
AdAstrum
 
Posts: 14
Joined: Wed Sep 02, 2009 9:28 pm

Re: Memory Consumption

Postby crakarjax » Sat Jan 12, 2013 4:00 pm

Just to follow up, memory consumption is unusually high on the latest (1.72?) version as well. I have resorted to setting up a windows task to restart PSM every night to avoid the memory issues that occur after long runtime. Has any effort been made to look into this issue? I am certain that the memory is not "phantom use" as one poster suggested, since if it were my system would not slow to a crawl when the memory is shown as being almost entirely used. Also I did a quick test with a VM by attempting to allocate slightly more memory than available to it, expecting to see greater than 100% memory use; this was not the case, and I am certain now that PSM is being a memory hog.
crakarjax
 
Posts: 9
Joined: Wed Oct 12, 2011 12:27 am


Return to General Help and Support

Who is online

Users browsing this forum: Yahoo [Bot] and 15 guests