Older Quicktime Files Problem

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Older Quicktime Files Problem

Postby DaScooby » Thu Mar 19, 2009 5:20 pm

Hi!

First of all: Great work! This software makes my life easier und I want to say thank you for all that unpaid work!

Ok, here is my problem:

I want to stream a trailer of a movie in Quicktime format. The new Quicktime trailers are streamed without a problem. But if I try to stream an older one like this: http://www.moviemaze.de/media/trailer/d ... en_480.mov

i get a windows error and the mediaserver restarts. I checked the Logfile:

[Thread-205] TRACE 17:14:47.194 Starting transcode/remux of ice_age_trailer1_m480.mov
[win32/mencoder.exe] TRACE 17:15:10.935 Process C:\Program Files\PS3 Media Server\win32\mencoder.exe has a return code of -1073741819! Maybe an error occured... check the log file

but I can't solve the Problem. Do you have an idea??

cya!
DaScooby
 
Posts: 3
Joined: Thu Mar 19, 2009 5:09 pm

Re: Older Quicktime Files Problem

Postby Burrito » Thu Mar 19, 2009 7:35 pm

Maybe older Trailers are still using the Sorenson Quicktime codec, which isn't H.264/AVC and therefore the PS3 can't play natively.

PMS tries to just remux .mov files because it assumes that the content is fully compatible with the PS3 - which works with newer .mov files.

Your solution is to go to the #Transcode# folder and play the file from there. FFmpeg can play back the Sorenson codec so it should work!
Burrito
 
Posts: 39
Joined: Mon Jan 19, 2009 12:41 am

Re: Older Quicktime Files Problem

Postby DaScooby » Fri Mar 20, 2009 9:02 am

thx for the help Burrito!

I changed the engine and it says:

"Direct Show Source: Could not open as Video or Audio" on my TV.

The log shows this:
Code: Select all
[win32/ffmpeg.exe] TRACE 08:59:23.774 Process C:\Program Files\PS3 Media Server\win32\ffmpeg.exe has a return code of 1! Maybe an error occured... check the log file
[Thread-250] TRACE 08:59:36.248 Starting transcode/remux of harold_and_kumar_trailer01_de_384.mov


maybe you have another idea? :)
DaScooby
 
Posts: 3
Joined: Thu Mar 19, 2009 5:09 pm

Re: Older Quicktime Files Problem

Postby Burrito » Sat Mar 21, 2009 1:25 am

Ok, like i said new files remux fine with MEncoder (just tested this).

But the following file also crashes MEncoder for me:
http://a772.g.akamai.net/5/772/51/8aae3 ... 3_m480.mov

[Thread-381] TRACE 01:19:46.989 Starting transcode/remux of ice_age-tlr3_m480.mov
[win32/mencoder.exe] TRACE 01:19:55.213 Process C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe has a return code of -1073741819! Maybe an error occured... check the log file

Even disabling the "Switch to TSmuxer when H.264 video is ps3 compatible..." option doesn't make MEncoder process the file. I can't play it also. Shagrath?
Burrito
 
Posts: 39
Joined: Mon Jan 19, 2009 12:41 am

Re: Older Quicktime Files Problem

Postby Burrito » Sat Mar 21, 2009 1:36 am

I'm posting the relevant part of the log but i think shagrath already has an answer:

Code: Select all
[Thread-151] TRACE 01:29:14.441 Starting transcode/remux of ice_age-tlr3_m480.mov
[Thread-151] DEBUG 01:29:14.441 Searching an audio track with lang: ger
[Thread-151] DEBUG 01:29:14.450 Searching an audio track with lang: eng
[Thread-151] DEBUG 01:29:14.450 Matched audio track: Audio: qdm2 / lang: eng / ID: 1
[Thread-151] DEBUG 01:29:14.452 Searching a subtitle track with lang: ger
[Thread-151] DEBUG 01:29:14.452 Searching a subtitle track with lang:  eng
[Thread-151] INFO  01:29:14.551 Creating pipe \\.\pipe\mencoder1237595354550
[Thread-150] INFO  01:29:14.621 HTTP: upnp/control/content_directory / 0-0
[Thread-150] DEBUG 01:29:14.621 Wrote on socket: HTTP/1.1 200 OK
[Thread-150] DEBUG 01:29:14.621 Wrote on socket: CONTENT-TYPE: text/xml; charset="utf-8"
[Thread-150] DEBUG 01:29:14.621 Wrote on socket: Server: Windows_Vista-x86-6.0, UPnP/1.0, PMS/1.10.51
[Thread-150] DEBUG 01:29:14.621 Wrote on socket: Content-Length: 335
[Thread-150] DEBUG 01:29:14.621 Wrote on socket:
[Thread-150] DEBUG 01:29:14.621 Close Connection
[Thread-154] DEBUG 01:29:14.627 Opened handler on socket Socket[addr=/192.168.2.2,port=61952,localport=5001]
[Thread-154] DEBUG 01:29:14.627 Received on socket: POST /upnp/control/content_directory HTTP/1.1
[Thread-154] DEBUG 01:29:14.627 Received on socket: X-AV-Client-Info: av=5.0; cn="Sony Computer Entertainment Inc."; mn="PLAYSTATION 3"; mv="1.0";
[Thread-153] INFO  01:29:14.636 Waiting for pipe connection \\.\pipe\mencoder1237595354550
[Timer-17] DEBUG 01:29:14.636 Buffered Space: 0 bytes / inputs: 0
[Thread-154] DEBUG 01:29:14.637 Received on socket: Host: 192.168.2.101:5001
[Thread-154] DEBUG 01:29:14.637 Received on socket: User-Agent: UPnP/1.0 DLNADOC/1.50
[Thread-154] DEBUG 01:29:14.637 Received on socket: Content-Length: 905
[Thread-154] DEBUG 01:29:14.637 Received on socket: Content-Type: text/xml; charset="utf-8"
[Thread-154] DEBUG 01:29:14.637 Received on socket: SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#Browse"
[win32/mencoder.exe] INFO  01:29:14.686 Starting C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe -ss 0 -quiet C:\Shared Media\Trailers\ice_age-tlr3_m480.mov -quiet -quiet -oac lavc -of mpeg -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=384:threads=4:keyint=1:vqscale=1:vqmin=2 -quiet -nofontconfig -subcp cp1252 -subfont C:\Windows\Fonts\Arial.ttf -ass-color ffffff00 -ass-border-color 00000000 -ass-font-scale 1.0 -ass-force-style FontName=Arial,Outline=1,Shadow=1,MarginV=10 -quiet -quiet -subdelay 20000 -quiet -quiet -ofps 24 -quiet -quiet -mc 0.1 -quiet -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1237595354550
[win32/mencoder.exe] INFO  01:29:14.692 Reading pipe: \\.\pipe\mencoder1237595354550
[win32/mencoder.exe] INFO  01:29:14.692 Attaching thread: win32/mencoder.exe
[Thread-157] DEBUG 01:29:14.707 MEncoder Sherpya-SVN-r28311-4.2.5 (C) 2000-2009 MPlayer Team
[Thread-157] DEBUG 01:29:14.707 CPU: Intel(R) Core(TM)2 Quad  CPU   Q9450  @ 2.66GHz (Family: 6, Model: 23, Stepping: 7)
[Thread-157] DEBUG 01:29:14.707 CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
[Thread-157] DEBUG 01:29:14.707 Compiled with runtime CPU detection.
[Thread-157] DEBUG 01:29:14.721 success: format: 0  data: 0x0 - 0x162df41
[Thread-157] DEBUG 01:29:14.722 libavformat file format detected.
[Thread-157] DEBUG 01:29:14.724 [lavf] Video stream found, -vid 0
[Thread-157] DEBUG 01:29:14.724 [lavf] Audio stream found, -aid 1
[Thread-157] DEBUG 01:29:14.724 VIDEO:  [SVQ3]  480x260  32bpp  24.000 fps    0.0 kbps ( 0.0 kbyte/s)
[Thread-157] DEBUG 01:29:14.724 [V] filefmt:44  fourcc:0x33515653  size:480x260  fps:24.000  ftime:=0.0417
[Thread-157] DEBUG 01:29:14.724 ==========================================================================
[Thread-157] DEBUG 01:29:14.725 Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[Thread-157] DEBUG 01:29:14.726 AUDIO: 44100 Hz, 2 ch, s16le, 112.0 kbit/7.94% (ratio: 14000->176400)
[Thread-157] DEBUG 01:29:14.726 Selected audio codec: [ffqdm2] afm: ffmpeg (FFmpeg QDM2 audio decoder)
[Thread-157] DEBUG 01:29:14.726 ==========================================================================
[Thread-157] DEBUG 01:29:14.726 PACKET SIZE: 2048 bytes, deltascr: 884
[Thread-153] INFO  01:29:14.726 Result of \\.\pipe\mencoder1237595354550 : true
[Thread-157] DEBUG 01:29:14.727 Opening video filter: [expand osd=1]
[Thread-157] DEBUG 01:29:14.727 Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
[Thread-157] DEBUG 01:29:14.727 ==========================================================================
[Thread-157] DEBUG 01:29:14.728 Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[Thread-157] DEBUG 01:29:14.730 Selected video codec: [ffsvq3] vfm: ffmpeg (FFmpeg Sorenson Video v3 (SVQ3))
[Thread-157] DEBUG 01:29:14.730 ==========================================================================
[Thread-156] DEBUG 01:29:14.765 Limiting audio preload to 0.4s.
[Thread-156] DEBUG 01:29:14.765 Increasing audio density to 4.
[Thread-157] DEBUG 01:29:14.776 VDec: vo config request - 480 x 260 (preferred colorspace: Planar YV12)
[Thread-157] DEBUG 01:29:14.776 VDec: using Planar YV12 as output csp (no 0)
[Thread-157] DEBUG 01:29:14.776 Movie-Aspect is undefined - no prescaling applied.
[Thread-157] DEBUG 01:29:14.776 videocodec: libavcodec (480x260 fourcc=3267706d [mpg2])
[Thread-157] DEBUG 01:29:14.776 [VE_LAVC] Using constant qscale = 1.000000 (VBR).
[Thread-154] INFO  01:29:14.821 HTTP: upnp/control/content_directory / 0-0
[Thread-154] DEBUG 01:29:14.821 Wrote on socket: HTTP/1.1 200 OK
[Thread-154] DEBUG 01:29:14.821 Wrote on socket: CONTENT-TYPE: text/xml; charset="utf-8"
[Thread-154] DEBUG 01:29:14.821 Searching for objectId: 0$0$2 with children option: false
[Thread-154] DEBUG 01:29:14.825 Wrote on socket: Server: Windows_Vista-x86-6.0, UPnP/1.0, PMS/1.10.51
[Thread-154] DEBUG 01:29:14.826 Wrote on socket: Content-Length: 851
[Thread-154] DEBUG 01:29:14.826 Wrote on socket:
[Thread-154] DEBUG 01:29:14.826 Close Connection
[Timer-17] DEBUG 01:29:16.636 Buffered Space: 0 bytes / inputs: 0
[Thread-158] DEBUG 01:29:17.166 Opened handler on socket Socket[addr=/192.168.2.2,port=61951,localport=5001]
[Thread-158] DEBUG 01:29:17.166 Received on socket: GET /get/0$0$2$13/ice_age-tlr3_m480.mov HTTP/1.0
[Thread-158] DEBUG 01:29:17.166 Received on socket: Host: 192.168.2.101:5001
[Thread-158] DEBUG 01:29:17.166 Received on socket: User-Agent: PLAYSTATION 3
[Thread-158] DEBUG 01:29:17.179 Received on socket: Connection: close
[Thread-158] DEBUG 01:29:17.179 Received on socket: Accept-Encoding: identity
[Thread-158] DEBUG 01:29:17.179 Received on socket: Cache-Control: no-cache
[Thread-158] INFO  01:29:17.179 HTTP: get/0$0$2$13/ice_age-tlr3_m480.mov / 0-0
[Thread-158] DEBUG 01:29:17.180 Wrote on socket: HTTP/1.0 200 OK
[Thread-158] DEBUG 01:29:17.180 Searching for objectId: 0$0$2$13 with children option: false
[Thread-158] DEBUG 01:29:17.180 Asked stream chunk [0-0] timeseek: 0.0 of ice_age-tlr3_m480.mov and player MEncoder
[Thread-158] DEBUG 01:29:17.180 Wrote on socket: Content-Type: video/mpeg
[Thread-158] DEBUG 01:29:17.180 Wrote on socket: Connection: keep-alive
[Thread-158] DEBUG 01:29:17.180 Wrote on socket: Server: Windows_Vista-x86-6.0, UPnP/1.0, PMS/1.10.51
[Thread-158] DEBUG 01:29:17.180 Wrote on socket:
[Thread-158] DEBUG 01:29:17.180 Suspend Read: readCount=0 / writeCount=0
[Thread-159] DEBUG 01:29:17.434 Opened handler on socket Socket[addr=/192.168.2.2,port=61950,localport=5001]
[Thread-159] DEBUG 01:29:17.434 Received on socket: HEAD /get/0$0$2$13/thumbnail0000ice_age-tlr3_m480.mov HTTP/1.0
[Thread-159] DEBUG 01:29:17.434 Received on socket: Host: 192.168.2.101:5001
[Thread-159] DEBUG 01:29:17.434 Received on socket: User-Agent: PLAYSTATION 3
[Thread-159] DEBUG 01:29:17.444 Received on socket: Connection: close
[Thread-159] DEBUG 01:29:17.444 Received on socket: Accept-Encoding: identity
[Thread-159] DEBUG 01:29:17.444 Received on socket: Cache-Control: no-cache
[Thread-159] INFO  01:29:17.444 HTTP: get/0$0$2$13/thumbnail0000ice_age-tlr3_m480.mov / 0-0
[Thread-159] DEBUG 01:29:17.445 Wrote on socket: HTTP/1.0 200 OK
[Thread-159] DEBUG 01:29:17.445 Searching for objectId: 0$0$2$13 with children option: false
[Thread-159] DEBUG 01:29:17.445 Wrote on socket: Content-Type: image/png
[Thread-159] DEBUG 01:29:17.445 Wrote on socket: Accept-Ranges: bytes
[Thread-159] DEBUG 01:29:17.445 Wrote on socket: Expires: Tue, 14 Jul 2009 18:15:57 GMT
[Thread-159] DEBUG 01:29:17.445 Wrote on socket: Connection: keep-alive
[Thread-159] DEBUG 01:29:17.446 Wrote on socket: Server: Windows_Vista-x86-6.0, UPnP/1.0, PMS/1.10.51
[Thread-159] DEBUG 01:29:17.446 Available Content-Length: 10275
[Thread-159] DEBUG 01:29:17.446 Wrote on socket: Content-Length: 10275
[Thread-159] DEBUG 01:29:17.446 Wrote on socket:
[Thread-159] DEBUG 01:29:17.446 Sending stream: 0 bytes of get/0$0$2$13/thumbnail0000ice_age-tlr3_m480.mov
[Thread-159] DEBUG 01:29:17.446 Close Connection
[Thread-160] DEBUG 01:29:17.454 Opened handler on socket Socket[addr=/192.168.2.2,port=61949,localport=5001]
[Thread-160] DEBUG 01:29:17.454 Received on socket: GET /get/0$0$2$13/thumbnail0000ice_age-tlr3_m480.mov HTTP/1.1
[Thread-160] DEBUG 01:29:17.454 Received on socket: Host: 192.168.2.101:5001
[Thread-160] DEBUG 01:29:17.454 Received on socket: User-Agent: PLAYSTATION 3
[Thread-160] DEBUG 01:29:17.466 Received on socket: Connection: Keep-Alive
[Thread-160] DEBUG 01:29:17.466 Received on socket: Accept-Encoding: identity
[Thread-160] DEBUG 01:29:17.466 Received on socket: transferMode.dlna.org: Interactive
[Thread-160] INFO  01:29:17.466 HTTP: get/0$0$2$13/thumbnail0000ice_age-tlr3_m480.mov / 0-0
[Thread-160] DEBUG 01:29:17.466 Wrote on socket: HTTP/1.1 200 OK
[Thread-160] DEBUG 01:29:17.466 Searching for objectId: 0$0$2$13 with children option: false
[Thread-160] DEBUG 01:29:17.466 Wrote on socket: Content-Type: image/png
[Thread-160] DEBUG 01:29:17.466 Wrote on socket: Accept-Ranges: bytes
[Thread-160] DEBUG 01:29:17.466 Wrote on socket: Expires: Tue, 14 Jul 2009 18:15:57 GMT
[Thread-160] DEBUG 01:29:17.466 Wrote on socket: Connection: keep-alive
[Thread-160] DEBUG 01:29:17.467 Wrote on socket: Server: Windows_Vista-x86-6.0, UPnP/1.0, PMS/1.10.51
[Thread-160] DEBUG 01:29:17.467 Available Content-Length: 10275
[Thread-160] DEBUG 01:29:17.467 Wrote on socket: Content-Length: 10275
[Thread-160] DEBUG 01:29:17.467 Wrote on socket:
[Thread-160] DEBUG 01:29:17.467 Sending stream: 10275 bytes of get/0$0$2$13/thumbnail0000ice_age-tlr3_m480.mov
[Thread-160] DEBUG 01:29:17.467 Close Connection
[Timer-17] DEBUG 01:29:18.636 Buffered Space: 0 bytes / inputs: 1
[Timer-17] DEBUG 01:29:20.636 Buffered Space: 0 bytes / inputs: 1
[Thread-153] DEBUG 01:29:20.672 EOF
[win32/mencoder.exe] DEBUG 01:29:20.674 EOF
[win32/mencoder.exe] TRACE 01:29:20.674 Process C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe has a return code of -1073741819! Maybe an error occured... check the log file
[Thread-158] DEBUG 01:29:20.680 Resume Read: readCount=0 / writeCount=0
[Thread-158] DEBUG 01:29:20.680 Ready to Stop: true
[Thread-158] DEBUG 01:29:20.680 Sending stream: 32768 bytes of get/0$0$2$13/ice_age-tlr3_m480.mov
[Thread-158] DEBUG 01:29:20.681 Close Connection
Burrito
 
Posts: 39
Joined: Mon Jan 19, 2009 12:41 am

Re: Older Quicktime Files Problem

Postby DaScooby » Sun Mar 22, 2009 5:45 pm

thx for your work again burrito!

maybe it helps to post my specs etc.:

1. Computer Specs:
Intel Core Duo 6600 2x2,4 Ghz
4 GB RAM
Geforce 8800 GT
100 MBit lan
Windows Vista SP1

2. Network Connection:
ethernet 100Mbits
Router: D-Link DIR-635

3. Problem:
Older Quicktime Files don't play on the PS3. (e.g.: http://www.moviemaze.de/media/trailer/d ... en_480.mov).
All new Quicktime Trailers (HD trailer) are working.

4.Decoder:
First I try MEncoder. -> Windows Error, Server restarts
FFMpeg: Error Message on TV. No Vid is playing.

5. Media Server Version:
1.10.51

6. Debug Log:
DaScooby
 
Posts: 3
Joined: Thu Mar 19, 2009 5:09 pm


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 11 guests