dvd iso audio out of sync

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

dvd iso audio out of sync

Postby fssilva » Wed Oct 26, 2011 11:21 pm

Hello all,

I'm new using this wonderful program and i have a audio sync issue when playing DVD ISO ...

I'm watching on PS3 and just DVD iso are with this issue... mkv files works perfect....

I tried version 1.40 and now 1.50.b1

Any idea how to solve it?

Running on windows and ubuntu linux I have the same issue.


Thank you!
fssilva
 
Posts: 4
Joined: Tue Oct 25, 2011 11:05 pm

Re: dvd iso audio out of sync

Postby doc9463 » Tue Oct 16, 2012 2:26 am

I am having the same issue with any version prior to 1.54.0 and after (to include the latest 1.70.1) The only version that works for me is 1.54.0. :(
All other formats seem to work appropriately (m2ts, mkv, mp4, vob) :D except GoPro videos. :(

Using Windows 7 64 bit Service Pack 1
i5 650@3.20Ghz
8 GB ram

full gigabit wired network
doc9463
 
Posts: 4
Joined: Sat Nov 06, 2010 2:45 pm

Re: dvd iso audio out of sync

Postby olograph » Tue Oct 16, 2012 6:06 am

To the rescue, there seems to be almost no data on the subject though one day I found a thread..by mistake in an unrelated section where a guy tells randomly about the issue and his resolution.

It worked for me so here it is:

You have to change mencoder custom settings, which are conditional to the container (e.g. iso, vob...)
Basically, tell mencoder what to do for particular file formats.

Here's my pms.conf, check the last item which is a list of parameters in itself.

Code: Select all
thumbnails = true
chapter_support = true
thumbnail_seek_pos = 300
mencoder_ass = true
folders = /secgen/Videos,/secgen/Pictures,/secgen/Music
uuid = 464c14ba-f252-49b8-b8f5-04647ba6a2a6
maximumbitrate = 0
dvd_isos_thumbnails = true
audio_thumbnails_method = 1
enable_archive_browsing = true
hidevideosettings = false
mencoder_audiosublangs = jpn,eng;eng,eng;fre,off;*,eng;*,*
mencoder_disablesubs = false
mencoder_audiolangs = jpn,eng,fre
mencoder_sublangs = eng,fre,und
mencoder_intelligent_sync = true
mencoder_nooutofsync = false
mencoder_forcefps = false
embed_dts_in_pcm = true
mencoder_remux_mpeg2 = true
fix_25fps_av_mismatch = false
engines = mencoder,tsmuxer,ffmpegvideo,avsffmpeg,avsmencoder,ffmpegaudio,mplayeraudio,tsmuxeraudio,ffmpegwebvideo,vlcvideo,mencoderwebvideo,mplayervideodump,mplayerwebaudio,vlcaudio,ffmpegdvrmsremux,rawthumbs
codec_spec_script = \ncontainer == vob :: -ofps 23.976 -noass\ncontainer == iso :: -ofps 23.976 -noass\nframerate == 23.976 && container == iso :: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25\nframerate == 29.97 && container == iso :: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25\nframerate == 25 && container == iso :: -mpegopts tele_src=25:tele_dest=25 -ofps 25\nframerate == 23.976 && container == vob :: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25\nframerate == 29.97 && container ==vob :: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25\nframerate == 25 && container == vob :: -mpegopts tele_src=25:tele_dest=25 -ofps 25\ncontainer == flv :: -mc 0.1\ncontainer == mov :: -mc 0.1 -noass\ncontainer == rm :: -mc 0.1\ncontainer == mov :: -mc 0.1\ncontainer == rm  :: -mc 0.1\ncontainer == matroska && framerate == 29.97  :: -nomux -mc 0\ncontainer == matroska :: -mc 0 -noskip\ncontainer == mp4 && vcodec == h264 :: -mc 0.1\n


Additions such as
Code: Select all
container == vob :: -ofps 23.976 -noass
fixed the issue on 1.70.0
olograph
 
Posts: 6
Joined: Tue Oct 16, 2012 12:08 am

Re: dvd iso audio out of sync

Postby navinag » Fri Oct 19, 2012 10:38 pm

Finally! A Solution that works...........I was about ready to give up on the PS3 and get an XBOX.
navinag
 
Posts: 1
Joined: Thu Jul 21, 2011 7:22 pm

Re: dvd iso audio out of sync

Postby LSU TIger » Sun Oct 28, 2012 3:49 pm

Can you tell me where you entered this code? I attempted to enter it into the "Expert Settings: Codec-specific parameters" section under MEncoder in the Transcode settings but only received an error when trying to save it.

Thanks
LSU TIger
 
Posts: 1
Joined: Sun Oct 28, 2012 3:46 pm

Re: dvd iso audio out of sync

Postby jlabarr » Sat Nov 17, 2012 3:51 pm

I can confirm this method works. The PMS.conf file is located in c:\ProgramData\PMS. This will fix your iso out of sync problems.
jlabarr
 
Posts: 1
Joined: Sat Nov 17, 2012 3:48 pm

Re: dvd iso audio out of sync

Postby Davdomlan » Tue Aug 26, 2014 3:06 am

Hello there, I have just found the PS3 Media server, I founded it cause I wanted to play some dvds on my ps3 that were another region and I was not able to do it. Well It worked great to me. ActuallyI got the A/V Synth problem however I fixed with the code olograph posted in here:

container == vob :: -ofps 23.976
container == iso :: -ofps 23.976
framerate == 23.976 && container == iso :: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25
framerate == 29.97 && container == iso :: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25
framerate == 25 && container == iso :: -mpegopts tele_src=25:tele_dest=25 -ofps 25
framerate == 23.976 && container == vob :: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25
framerate == 29.97 && container ==vob :: -mpegopts tele_src=24000/1001:tele_dest=25 -ofps 25
framerate == 25 && container == vob :: -mpegopts tele_src=25:tele_dest=25 -ofps 25

However as far as I can understand, this is converting the video to 25 fps, what about if I want it to be 29 fps NTSC, can any one help me? Sorry to ask but I dont know nothing about mencoder.

thank you.
Davdomlan
 
Posts: 1
Joined: Tue Aug 26, 2014 2:55 am


Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 23 guests