ProcessInputError

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

ProcessInputError

Postby tmlt » Thu Mar 05, 2009 8:14 pm

If mencoder tries to use the wmvvc1dmo codec to transcode VC-1, then the debug log fills up with numerous messages such as:
(this is from ps3mediaserver 1.04, but same thing happens with 1.10.1)

Code: Select all
[Thread-102] DEBUG 10:56:42.057 Asked stream chunk [0-0] timeseek: 0.0 of Dark Knight, The.m2ts and player MEn
coder
[Thread-102] TRACE 10:56:42.057 Starting transcode/remux of Dark Knight, The.m2ts
[mkfifo] INFO  10:56:42.227 Starting mkfifo --mode=777 /tmp/javaps3media/mencoder1236279402226
[mencoder] INFO  10:56:42.280 Starting mencoder -ss 0 -quiet /mnt/user/Video/Blu-ray/Dark Knight, The.m2ts -qu
iet -quiet -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -cha
nnels 6 -lavdopts debug=0:threads=1 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=1
:keyint=3:vqscale=2:vqmin=3 -quiet -nofontconfig -subcp cp1252 -alang eng,fre,jpn,ger -ass-color ffffff00 -ass
-border-color 00000000 -ass-font-scale 1.0 -ass-force-style FontName=Arial,Outline=1,Shadow=1,MarginV=10 -slan
g eng,fre,jpn,ger -quiet -quiet -quiet -quiet -ofps 24000/1001 -quiet -quiet -mc 0 -noskip -af lavcresample=48
000 -srate 48000 -o /tmp/javaps3media/mencoder1236279402226
[mencoder] INFO  10:56:42.310 Reading pipe: /tmp/javaps3media/mencoder1236279402226
[mencoder] DEBUG 10:56:42.310 Opening file /tmp/javaps3media/mencoder1236279402226 for reading...
[Timer-3] DEBUG 10:56:42.570 Buffered Space: 0 bytes
[mencoder] INFO  10:56:42.570 Attaching thread: mencoder
[Thread-108] DEBUG 10:56:42.590 MEncoder dev-SVN-r28058-4.2.3 (C) 2000-2008 MPlayer Team
[Thread-108] DEBUG 10:56:42.590 CPU: Intel(R) Celeron(R) CPU 2.80GHz (Family: 15, Model: 4, Stepping: 9)
[Thread-108] DEBUG 10:56:42.590 CPUflags: Type: 15 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
[Thread-108] DEBUG 10:56:42.590 Compiled with runtime CPU detection.
[Thread-108] DEBUG 10:56:42.590 success: format: 0  data: 0x0 - 0xdf7aa800
[Thread-108] DEBUG 10:56:42.590 TS file format detected.
[Thread-108] DEBUG 10:56:42.590 VIDEO VC1(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)!  PROGRAM N. 1
[Thread-108] DEBUG 10:56:42.590 Searching for VC1 sequence header... found
[Thread-108] DEBUG 10:56:42.590 VIDEO:  VC-1  1920x1080, 23.976 fps, header len: 33
[Thread-108] DEBUG 10:56:42.590 [V] filefmt:29  fourcc:0x31435657  size:1920x1080  fps:23.976  ftime:=0.0417
[Thread-108] DEBUG 10:56:42.590 ==========================================================================
[Thread-108] DEBUG 10:56:42.590 Opening audio decoder: [liba52] AC3 decoding with liba52
[Thread-108] DEBUG 10:56:42.590 AUDIO: 48000 Hz, 6 ch, s16le, 640.0 kbit/13.89% (ratio: 80000->576000)
[Thread-108] DEBUG 10:56:42.590 Selected audio codec: [a52] afm: liba52 (AC3-liba52)
[Thread-108] DEBUG 10:56:42.590 ==========================================================================
[Thread-108] DEBUG 10:56:42.590 PACKET SIZE: 2048 bytes, deltascr: 884
[Thread-108] DEBUG 10:56:42.590 Opening video filter: [expand osd=1]
[Thread-108] DEBUG 10:56:42.591 Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
[Thread-108] DEBUG 10:56:42.591 ==========================================================================
[Thread-108] DEBUG 10:56:42.591 Opening video decoder: [dmo] DMO video codecs
[Thread-108] DEBUG 10:56:42.591 Creating new registry
[Thread-108] DEBUG 10:56:42.591 DMO dll supports VO Optimizations 0 1
[Thread-108] DEBUG 10:56:42.591 DMO dll might use previous sample when requested
[Thread-105] DEBUG 10:56:42.609 SUB: error opening iconv descriptor.
[Thread-105] DEBUG 10:56:42.610 Using SSE optimized IMDCT transform
[Thread-105] DEBUG 10:56:42.610 Using MMX optimized resampler
[Thread-108] DEBUG 10:56:42.738 GetOutput r=0x0   size:6220800  align:1
[Thread-108] DEBUG 10:56:42.738 StreamCount r=0x0  1  1
[Thread-108] DEBUG 10:56:42.739 Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565
 RGB24 RGB32
[Thread-108] DEBUG 10:56:42.739 Decoder is capable of YUV output (flags 0x1b)
[Thread-108] DEBUG 10:56:42.739 VDec: vo config request - 1920 x 1080 (preferred colorspace: Packed YUY2)
[Thread-108] DEBUG 10:56:42.739 VDec: using Planar YV12 as output csp (no 0)
[Thread-108] DEBUG 10:56:42.739 Movie-Aspect is undefined - no prescaling applied.
[Thread-108] DEBUG 10:56:42.739 videocodec: libavcodec (1920x1080 fourcc=3267706d [mpg2])
[Thread-108] DEBUG 10:56:42.740 [VE_LAVC] Using constant qscale = 2.000000 (VBR).
[Thread-108] DEBUG 10:56:42.742 Selected video codec: [wmvvc1dmo] vfm: dmo (Windows Media Video (VC-1) Advance
d Profile Decoder)
[Thread-108] DEBUG 10:56:42.742 ==========================================================================
[Thread-105] DEBUG 10:56:42.743 Limiting audio preload to 0.4s.
[Thread-105] DEBUG 10:56:42.743 Increasing audio density to 4.
[Thread-105] DEBUG 10:56:43.020 New_Face failed. Maybe the font path is wrong.
[Thread-105] DEBUG 10:56:43.020 Please supply the text font file (~/.mplayer/subfont.ttf).
[Thread-105] DEBUG 10:56:43.020 subtitle font: load_sub_face failed.
[Thread-108] DEBUG 10:56:43.057 ProcessInputError  r:0xffffff9c=-100 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.057 Writing header...
[Thread-108] DEBUG 10:56:43.087 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.114 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.148 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.172 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.195 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.228 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.252 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.274 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.308 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.333 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.354 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.388 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.416 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.437 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.474 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.498 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.520 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Thread-108] DEBUG 10:56:43.554 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)
[Timer-3] DEBUG 10:56:43.579 Buffered Space: 309248 bytes
[Thread-108] DEBUG 10:56:43.581 ProcessInputError  r:0x80004005=-2147467259 (keyframe: 1)


These messages repeat & no video is output.

If the file /usr/lib/codecs/wvc1dmod.dll is deleted, then mencoder complains about it but uses ffvc1 instead which does work, but is this the desired behavior?
tmlt
 
Posts: 1
Joined: Thu Mar 05, 2009 8:05 pm

Re: ProcessInputError

Postby az1979 » Fri Mar 06, 2009 2:03 am

mplayer/mencoder is not exactly _the_ player/encoder for windows media crap. You shouldn't use that format anyways. But if a fallback to ffmpeg works, this should be exactly what you need?

My suggestion: Stick to open and well-defined formats. Don't use any windows media crap. I guess it's not exactly the answer you hoped for, but it's the most reasonable. Microsoft switches their library bullshit around all of the time and there's no way for the open software community to work with that kind of behavior, so the best thing to do is to avoid everything that ends with ".dll" ;)

Andreas
az1979
 
Posts: 12
Joined: Tue Mar 03, 2009 8:53 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 7 guests