.DEB package available for Debian/Ubuntu

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: .DEB package available for Debian/Ubuntu

Postby paissad » Tue Nov 16, 2010 2:22 am

try these commands
Code: Select all
sudo aptitude purge pms-linux

or
Code: Select all
sudo aptitude reinstall pms-linux
User avatar
paissad
 
Posts: 189
Joined: Wed Feb 10, 2010 11:52 pm

Re: .DEB package available for Debian/Ubuntu

Postby coolit » Tue Nov 16, 2010 2:39 am

Hi Paissad,

Thx for the fast response ;)
I would love the new package and will report back my findings.
Im on Ubuntu 9.10

Thx in advance!
coolit
 
Posts: 13
Joined: Sat Jun 26, 2010 2:59 am

Re: .DEB package available for Debian/Ubuntu

Postby speedmax » Tue Nov 16, 2010 2:47 am

@Paissad,

Not working... still have the same error code.

Other idea?

Code: Select all
maxime@maxime-desktop:~$ sudo aptitude purge pms-linux
[sudo] password for maxime:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu       
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Les paquets suivants seront ENLEVÉS :
  aften{u} dvdauthor{u} dvdrip-doc{u} dvdrip-utils{u} faac{u} ffmpeg{u}
  ffmpegthumbnailer{u} fping{u} gocr{u} gpac{u} libanyevent-perl{u}
  libasync-interrupt-perl{u} libcommon-sense-perl{u} libdirac-decoder0{u}
  libevent-execflow-perl{u} libevent-perl{u} libevent-rpc-perl{u}
  libffmpegthumbnailer4{u} libgpac0.4.5{u} libgtk2-ex-formfactory-perl{u}
  libintl-perl{u} libio-socket-ssl-perl{u} libnet-libidn-perl{u}
  libnet-ssleay-perl{u} libnetpbm10{u} liboggz2{u} libogmrip1{u}
  libsox-fmt-alsa{u} libsox-fmt-base{u} libsox1a{u} libxine1-ffmpeg{u}
  lsdvd{u} netpbm{u} oggz-tools{u} ogmrip-dirac{u} ogmrip-oggz{u}
  ogmtools{u} pms-linux{p} sox{u} subtitleripper{u} transcode{u}
  transcode-doc{u} transcode-utils{u} transfig{u} vcdimager{u} xine-ui{u}
0 paquets mis à jour, 0 nouvellement installés, 46 à enlever et 1 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 167Mo seront libérés.
Voulez-vous continuer ? [Y/n/?] Y
Écriture de l'information d'état étendu... Fait
(Lecture de la base de données... 377858 fichiers et répertoires déjà installés.)
Suppression de pms-linux ...
/etc/init.d/pms-linux: ligne 47 : [: = : opérateur unaire attendu
invoke-rc.d: initscript pms-linux, action "stop" failed.
dpkg : erreur de traitement de pms-linux (--purge) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
action: abort-remove not supported
Des erreurs ont été rencontrées pendant l'exécution :
 pms-linux
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
Lecture des listes de paquets... Fait             
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu       
Initialisation de l'état des paquets... Fait
speedmax
 
Posts: 20
Joined: Wed Jan 06, 2010 12:05 pm


Re: .DEB package available for Debian/Ubuntu

Postby speedmax » Tue Nov 16, 2010 3:32 am

Same thing...

Code: Select all
maxime@maxime-desktop:~$ sudo aptitude reinstall pms-linux
[sudo] password for maxime:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu     
Initialisation de l'état des paquets... Fait
Les paquets suivants seront RÉINSTALLÉS :
  pms-linux
0 paquets mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 0o seront utilisés.
Écriture de l'information d'état étendu... Fait
Paramétrage de pms-linux (1.20.409+svn412-3) ...
/etc/init.d/pms-linux: ligne 47 : [: = : opérateur unaire attendu
invoke-rc.d: initscript pms-linux, action "start" failed.
dpkg : erreur de traitement de pms-linux (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 pms-linux
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
Lecture des listes de paquets... Fait             
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu     
Initialisation de l'état des paquets... Fait
speedmax
 
Posts: 20
Joined: Wed Jan 06, 2010 12:05 pm

Re: .DEB package available for Debian/Ubuntu

Postby paissad » Tue Nov 16, 2010 3:14 pm

@ speedmax
i have an idea about the problem
let me do a check and upgrade the package.
You tell me after !
Don't give up, ok ;)
User avatar
paissad
 
Posts: 189
Joined: Wed Feb 10, 2010 11:52 pm

Re: .DEB package available for Debian/Ubuntu

Postby paissad » Tue Nov 16, 2010 4:12 pm

@ speedmax
1st of all, i have to tell you that the problem you currently have is entirely your fault ...
you should have /etc/default/pms-linux file ;)
Btw, that gave my an idea ( i modified the init.d script so that if ever some loose his /etc/default/pms-linux file ...that would not crash the start of pms-linux :))
Follow carefully and excactly the following instructions, that should solve your matter.
Code: Select all
sudo sed -i".bak". "/^DAEMON=/aPMS_START=1" /etc/init.d/pms-linux

Code: Select all
sudo apt-get purge pms-linux


Now, pms-linux should be removed (purged) successfully ;)
If not, you must not continue to the following instructions

I have built a new and safer version of pms-linux package ...
update and then install it
Code: Select all
sudo apt-get udpate
sudo apt-get install pms-linux


Finished mate,
Tell me if you have troubles,
and don't mess up this time :)
User avatar
paissad
 
Posts: 189
Joined: Wed Feb 10, 2010 11:52 pm

Re: .DEB package available for Debian/Ubuntu

Postby speedmax » Tue Nov 16, 2010 6:08 pm

Thanks! It work's to remove it.

Trying to install...

I know I probably did something wrong, but I dont know what!
Now I have to test it if it work with renderer. (PS3 & XMBC)

Thanks again...

Max
speedmax
 
Posts: 20
Joined: Wed Jan 06, 2010 12:05 pm

Re: .DEB package available for Debian/Ubuntu

Postby speedmax » Tue Nov 16, 2010 7:52 pm

Finally, It work now.

Other question, why it's not loading the renderer? I see on a other post that is suppose to load the renderer.
The post i taking about, http://ps3mediaserver.org/forum/viewtopic.php?f=3&t=8378

Thanks again for your help,

Max

Code: Select all
maxime@maxime-desktop:~$ pms-linux
[main] TRACE 13:45:02.688 Starting Java PS3 Media Server v1.20.409
[main] TRACE 13:45:02.689 by shagrath / 2008-2010
[main] TRACE 13:45:02.690 http://ps3mediaserver.blogspot.com
[main] TRACE 13:45:02.690 http://code.google.com/p/ps3mediaserver
[main] TRACE 13:45:02.690
[main] TRACE 13:45:02.690 Java 1.6.0_18-Sun Microsystems Inc.
[main] TRACE 13:45:02.701 OS Linux amd64 2.6.32-26-generic
[main] TRACE 13:45:02.701 Encoding: UTF-8
[main] TRACE 13:45:02.705 Temp folder: /tmp/javaps3media-maxime
[main] TRACE 13:45:02.827 Checking font cache... launching simple instance of MPlayer... You may have to wait 60 seconds !
[main] TRACE 13:45:02.859 Done!
[main] TRACE 13:45:02.867 Registering transcoding engine FFmpeg Audio
[main] TRACE 13:45:02.871 Registering transcoding engine MEncoder
[main] TRACE 13:45:02.872 Registering transcoding engine MPlayer Audio
[main] TRACE 13:45:02.872 Registering transcoding engine MEncoder Web
[main] TRACE 13:45:02.873 Registering transcoding engine MPlayer Video Dump
[main] TRACE 13:45:02.873 Registering transcoding engine MPlayer Web
[main] TRACE 13:45:02.875 Registering transcoding engine TsMuxer
[main] TRACE 13:45:02.875 Registering transcoding engine Audio High Fidelity
[main] TRACE 13:45:02.876 Registering transcoding engine VideoLan Audio Streaming
[main] TRACE 13:45:02.876 Registering transcoding engine VideoLan Video Streaming
[main] TRACE 13:45:02.876 Registering transcoding engine Raws Thumbnailer
[main] TRACE 13:45:03.024 Scanning network interface eth0 / eth0
[main] TRACE 13:45:03.024 Using address /192.168.1.121 found on network interface: name:eth0 (eth0) index: 2 addresses: /192.168.1.121;
[main] TRACE 13:45:03.025 Created socket: /192.168.1.121:5001
[main] TRACE 13:45:03.088 org.jboss.netty.channel.ChannelException: Failed to bind to: /192.168.1.121:5001
[main] TRACE 13:45:03.089    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:296)
[main] TRACE 13:45:03.089    at net.pms.network.HTTPServer.start(HTTPServer.java:152)
[main] TRACE 13:45:03.089    at net.pms.PMS.init(PMS.java:398)
[main] TRACE 13:45:03.089    at net.pms.PMS.get(PMS.java:1113)
[main] TRACE 13:45:03.089    at net.pms.PMS.main(PMS.java:1177)
[main] TRACE 13:45:03.090 Caused by: java.net.BindException: Adresse déjà utilisée
[main] TRACE 13:45:03.090    at sun.nio.ch.Net.bind(Native Method)
[main] TRACE 13:45:03.090    at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:137)
[main] TRACE 13:45:03.090    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:77)
[main] TRACE 13:45:03.091    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.bind(NioServerSocketPipelineSink.java:148)
[main] TRACE 13:45:03.091    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.handleServerSocket(NioServerSocketPipelineSink.java:100)
[main] TRACE 13:45:03.091    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.eventSunk(NioServerSocketPipelineSink.java:74)
[main] TRACE 13:45:03.091    at org.jboss.netty.channel.Channels.bind(Channels.java:671)
[main] TRACE 13:45:03.092    at org.jboss.netty.channel.AbstractChannel.bind(AbstractChannel.java:170)
[main] TRACE 13:45:03.092    at org.jboss.netty.bootstrap.ServerBootstrap$Binder.channelOpen(ServerBootstrap.java:342)
[main] TRACE 13:45:03.092    at org.jboss.netty.channel.Channels.fireChannelOpen(Channels.java:190)
[main] TRACE 13:45:03.093    at org.jboss.netty.channel.socket.nio.NioServerSocketChannel.<init>(NioServerSocketChannel.java:80)
[main] TRACE 13:45:03.093    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:142)
[main] TRACE 13:45:03.093    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:90)
[main] TRACE 13:45:03.094    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:275)
[main] TRACE 13:45:03.094    ... 4 more
speedmax
 
Posts: 20
Joined: Wed Jan 06, 2010 12:05 pm

Re: .DEB package available for Debian/Ubuntu

Postby coolit » Tue Nov 16, 2010 8:16 pm

Hi Paissad,

Downloading the new package right now.
Will keep you posted if everything works or not ;)

Greetzzz
coolit
 
Posts: 13
Joined: Sat Jun 26, 2010 2:59 am

PreviousNext

Return to Linux/Unix Support

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests