Fails to connect PS3 & Ubuntu, works find for XP. [Solved]

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Fails to connect PS3 & Ubuntu, works find for XP. [Solved]

Postby Mr_Temp » Sat Oct 03, 2009 8:04 am

Hi

I have recently set up a Ubuntu 9.04 system of a portable USB to utilize a XP lenovo laptop (work laptop). I have successfully installed PS3 Media Server on the system, having been my favorite streaming software on xp. Problem is it does not see the ps3, and vice verser . I can ping the PS3 (172.16.1.101) fine, and the logs for PMS look fine (see below). When I boot up the xp image and test it connect fine, so I don't believe it is an issue with my hardware setup, more likely with a setting i need to change in ubuntu itself. it has been 10 years since i last used a unix environment, so I most likely missing something basic

Setup
Lenovo Laptop connected (172.16.1.100) via wireless (wpa2) to a Linksys wrt54g router. I have the PS3 directly wired to the same router.
Ubuntu 9.04
PS3 media server 1.10.5
java 1.6

As you can see below , it can see the router fine. I have tried setting to a different port, and hard setting it to wlan0 as suggested in otmanix thread, but still no luck. I also installed firestarter to force port 5001 to be open to all , zero. I can connect fine with xp, but prefer not to due to having to stuff around with the firewall each time i wish to use it. looking at the log file , i see no issues.

Anyone have a clue what i am missing? the only thing I have not done is http://ps3mediaserver.org/forum/viewtopic.php?f=6&t=3507&start=20 as I have no idea if it applies, or how to do it (still giving myself a crash course in the terminal, it is slowly coming back)

Code: Select all
[main] TRACE 16:19:45.420 Starting Java PS3 Media Server v1.10.5
[main] TRACE 16:19:45.422 by shagrath / 2008-2009
[main] TRACE 16:19:45.422 http://ps3mediaserver.blogspot.com
[main] TRACE 16:19:45.422 http://code.google.com/p/ps3mediaserver
[main] TRACE 16:19:45.422
[main] TRACE 16:19:45.422 Java 1.6.0_16-Sun Microsystems Inc.
[main] TRACE 16:19:45.423 OS Linux i386 2.6.28-15-generic
[main] TRACE 16:19:45.423 Encoding: UTF-8
[main] TRACE 16:19:45.428 Temp folder: /tmp/javaps3media
[main] TRACE 16:19:45.472 Registering transcoding engine FFmpeg Audio
[main] TRACE 16:19:45.479 Registering transcoding engine MEncoder
[main] TRACE 16:19:45.480 Registering transcoding engine MPlayer Audio
[main] TRACE 16:19:45.480 Registering transcoding engine MEncoder Web
[main] TRACE 16:19:45.481 Registering transcoding engine MPlayer Video Dump
[main] TRACE 16:19:45.481 Registering transcoding engine MPlayer Web
[main] TRACE 16:19:45.484 Registering transcoding engine TsMuxer
[main] TRACE 16:19:45.484 Registering transcoding engine Audio High Fidelity
[main] TRACE 16:19:45.485 Registering transcoding engine VideoLan Audio Streaming
[main] TRACE 16:19:45.485 Registering transcoding engine VideoLan Video Streaming
[main] TRACE 16:19:45.485 Registering transcoding engine Raws Thumbnailer
[main] TRACE 16:19:45.703 Scanning network interface wlan0 / wlan0
[main] TRACE 16:19:45.703 Using address /172.16.1.100 found on network interface: name:wlan0 (wlan0) index: 4 addresses: /172.16.1.100;
[main] TRACE 16:19:45.704 Created socket: /172.16.1.100:5001
[Thread-4] TRACE 16:19:45.709 Starting DLNA Server on host 172.16.1.100 and port 5001...
[main] TRACE 16:19:45.712 Sending ALIVE...
[main] TRACE 16:19:45.715 Using following UUID: 068d4795-9fb0-3dc5-bd98-0ec54d44a844
[main] TRACE 16:19:51.947 It's ready! You should see the server appears on XMB
[Thread-7] TRACE 16:20:01.946 Sending ALIVE...
Last edited by Mr_Temp on Sun Oct 11, 2009 11:21 am, edited 1 time in total.
Mr_Temp
 
Posts: 4
Joined: Sat Oct 03, 2009 7:27 am

Re: Fails to connect to PS3 under Ubuntu, works find for XP

Postby meskibob » Sat Oct 03, 2009 3:57 pm

I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4788
Joined: Mon Jan 19, 2009 4:11 pm

Re: Fails to connect to PS3 under Ubuntu, works find for XP

Postby Mr_Temp » Mon Oct 05, 2009 9:05 am

Thank you for that , it is slowly coming back to me, unfortunately it is still failing to connect to the PS3

Guessing I have made a mistake somewhere, current host file is

Code: Select all
127.0.0.1   localhost.localdomain localhost
127.0.1.1   Mr-HD.localdomain Mr-HD

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


Only 2 machines on the router,
Ubuntu box - Mr-HD ip 172.16.1.100
PS3 - Mr_PS3 ip 172.16.1.101

I tried placing both in the host file with there allocated ip ranges, but this also failed
(tested with mediatomb - same result)

Searching Google I could not see any examples of what a host file should look like when streaming to a PS3
Mr_Temp
 
Posts: 4
Joined: Sat Oct 03, 2009 7:27 am

Re: Fails to connect to PS3 under Ubuntu, works find for XP

Postby Mr_Temp » Wed Oct 07, 2009 12:10 pm

Update

A second thing I have noticed is I can no longer access the routers setup/admin page at 172.16.1.1 . Does not even prompt for a password, (When I first set up Ubuntu I was able to log on). It is if my Ubuntu machine can not see the local network correctly, even thou I have full net access, and can ping the devices on my network. Switching back to XP, I can access the config page fine (As well as have ps3mediaserver serve fine). It looks like something has changed with the basic Ubuntu network settings since I first set it up, hence why I can not connect to anything on the local network (PS3 or router)

I would rather not wipe the drive and start from scratch, any Ideas what may of changed to block local network access , but not disable www access?

Searching the web, I can see a few people with the same issues, but no answers
Mr_Temp
 
Posts: 4
Joined: Sat Oct 03, 2009 7:27 am

Re: Fails to connect to PS3 under Ubuntu, works find for XP

Postby Mr_Temp » Sun Oct 11, 2009 11:20 am

Ok, update for others that may experience the same problem. issue was with my network and ubuntu

I am running a bridged modem (192.168.0.1) and the controlling router was on a completely different subnet (172.16.1.1). this has never been a problem with windows, but Ubuntu did not like it on bit. So I hard coded the ps3 to a static ip (192.168.2.99), and changed the ip of the router to 192.168.2.1, bam I can now stream again.

Why Ubuntu disliked my router settings yet windows worked fine I don't know. But hey. It's working now
Mr_Temp
 
Posts: 4
Joined: Sat Oct 03, 2009 7:27 am


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 2 guests