Problem with PS3MS not being detected with specific hostname

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Problem with PS3MS not being detected with specific hostname

Postby aaroe » Tue Aug 18, 2009 7:56 pm

Hi there,

I've been using PS3 for a while now and recently changed to a new server at home to decently support transcoding of full HD movies. My old server was based around a 2,6GHz Pentium4 with 2 Gigabytes of RAM and was, besides full HD movies, working like a charm. The new one is based around a 3GHz Core2Duo with 4 Gigabytes of RAM. Both servers are/were running Gentoo Linux since - the only difference is that the new one is an AMD64 where the old one was an x86.

Anyhow, PS3 is mainly working although I've identified a small issue which I can't seem to identify the cause of.
Per default, the hostname of the server is set to localhost and when this is the case, PS3MS detects the PS3 just fine and also the other way around. When changing the hostname - the new one has been baptized 'RickJames' - then only the server detects the PS3, not the other way around. I've been a bit puzzled about this for quite a while. It worked just fine on the old server which was named 'FreakTux'. Both about the same length, both mixed uppercase/lowercase. If changing the new server's hostname to 'FreakTux' (which worked earlier) it still doesn't work. My PS3 only seems to be able to identify the server when its hostname is set to 'localhost' as it is per default.

Any suggestions? Any help is much appreciated.

Kind regards
Christian Rasmussen
aaroe
 
Posts: 8
Joined: Mon Apr 20, 2009 9:30 pm

Re: Problem with PS3MS not being detected with specific hostname

Postby WorldOfHurt » Wed Aug 19, 2009 9:22 am

Presumably, you are not using a local DNS to resolve the new hostname.

This is just an educated guess, but I assume the PMS is sending urls to the PS3 saying something like "http://RickJames.yourdomain:xxxx/blah" and without a local DNS the PS3 can't resolve the name.

Maybe if you use localhost the PMS translates it into an IP address? Just a guess, but possibly worth investigating?
User avatar
WorldOfHurt
 
Posts: 252
Joined: Thu Mar 19, 2009 10:49 pm
Location: Winchester, UK

Re: Problem with PS3MS not being detected with specific hostname

Postby randaple4 » Sun Aug 23, 2009 4:00 am

Hi,
I tried this and got the same problem. I am using openSuse 11.1
I found that if the entry in /etc/HOSTNAME doesn't have a matching entry in /etc/hosts the PS3 can't find it.

Code: Select all
#cat /etc/HOSTNAME
linux-lounge.site



Code: Select all
 # cat /etc/hosts
#
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
#   
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#

127.0.0.1       localhost
192.168.1.2   linux-lounge

regards
Rob
randaple4
 
Posts: 6
Joined: Sun Aug 23, 2009 3:43 am
Location: Queensland Australia


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 6 guests