Ogg vorbis transcoding skipping [SOLVED]

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Ogg vorbis transcoding skipping [SOLVED]

Postby El Tonerino » Mon Aug 10, 2009 5:26 pm

I'm trying to set up PMS, but transcoding Ogg Vorbis always stutters on playback.

Plain old mp3's work fine, but most of music is in vorbis or flac. When playing back, it skips 4 or 5 times per song.
Pretty sure it's not the network (can get over 13mb on http://speedtest.net/ from the PS3, same on the server, which should be enough for audio right?)

Any ideas why?

Software:
Ubuntu 9.04, PMS 1.10.5
Hardware:
Quad core (I guess it's not that ;))
Last edited by El Tonerino on Mon Sep 28, 2009 8:35 pm, edited 2 times in total.
El Tonerino
 
Posts: 6
Joined: Mon Aug 10, 2009 5:16 pm

Re: Ogg vorbis transcoding

Postby Topguy » Thu Aug 20, 2009 3:10 pm

El Tonerino wrote:Plain old mp3's work fine, but most of music is in vorbis or flac. When playing back, it skips 4 or 5 times per song.
Pretty sure it's not the network (can get over 13mb on http://speedtest.net/ from the PS3, same on the server, which should be enough for audio right?)

Any ideas why?

Software:
Ubuntu 9.04, PMS 1.10.5
Hardware:
Quad code (I guess it's not that ;))


Wireless ??
Anyway, speedtest.net tests your internet-speed, it has nothing to do with traffic between PC and PS3. If you want to calculate real speed, us PMS to copy a .avi (divx/xvid) file to PS3 and take the time and do some math.
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: Ogg vorbis transcoding

Postby El Tonerino » Sun Sep 13, 2009 8:10 pm

Topguy wrote:Wireless ??


Oops, I thought I mentioned that :oops: . Yes.

Topguy wrote:Anyway, speedtest.net tests your internet-speed, it has nothing to do with traffic between PC and PS3.

True, but it does show that my PS3 has 13Mb/s wireless connection to the wireless router (as does the computer running PMS). I am running the PS3 through a wireless bridge, as it was only getting 3-4Mb/s over wireless and I thought that might've been the problem. (as a side note, I now no longer suck at WipEout online ;))

Topguy wrote:If you want to calculate real speed, us PMS to copy a .avi (divx/xvid) file to PS3 and take the time and do some math.

Although, that won't necessarily measure the true speed either. For example, my disk can spit out data at 88MB/s or 704Mb/s. If I was connected over gigabit lan, my disk should not saturate the network. Although it should saturate my wireless.
I have Linux installed on the PS3 too, so I suppose I could use iperf to test the actual bandwidth, but I'm not convinced the network is the problem.

I forgot to mention, that watching video is fine. I've not pushed any HD content over the network, but standard def video works without issue, as does MP3 music, and the one album I have encoded at ridiculously high bit rate wav files - The Slip - NIN.

Since the original post, I've also pulled down the SVN version of PMS, and tried that, it also skips on transcoded audio.
Which makes me think the issue is to do with transcoding from flac/vorbis. I have noticed that sometimes the Transcoding Buffer hits 0, and then a second or two later the skip happens.

I also get a 2104 error when browsing the contents of the media server from the PS3, although everything else still works. Having trouble finding out what a 2104 is, any idea?

In my effort to try and resolve the issue, I dug through the source code a little (although haven't touched Java for ~7 years, and have forgotten most of what I knew) and found a setting for maxaudiobuffer. I have set it to 599 in PMS.conf, but it doesn't seem to have made a difference.
I also added a tiny bit more logging in net/pms/dlna/DLNAResource.java. On line 852, I added
Code: Select all
PMS.minimal("..." + getSystemName() + "~" + media + "~" + params);

From that I get this when playing a song:
Code: Select all
[New I/O server worker #2-3] TRACE 19:15:10.873 Starting transcode/remux of Highschool Lover (Theme from The Virgin Suicides).ogg
[New I/O server worker #2-3] TRACE 19:15:10.873 .../home/anthony/Music/Air/The Virgin Suicides/Highschool Lover (Theme from The Virgin Suicides).ogg~container: null / bitrate: 160 / size: 3151211 / codecV: null / duration: 00:02:42.00 / width: 0 / height: 0 / frameRate: null / thumb size : 0 audio: id=0 / lang: null / codec: ogg vorbis v1 / sf:44100~net.pms.io.OutputParams@783b110a

and if it helps, for Video (which works),
Code: Select all
[New I/O server worker #2-1] TRACE 19:30:30.100 Starting transcode/remux of Old Boy.mkv
[New I/O server worker #2-1] TRACE 19:30:30.100 .../home/anthony/Videos/Films/Horror/Old Boy.mkv~container: matroska / bitrate: 0 / size: 1723823381 / codecV: h264 / duration: 01:55:03.920 / width: 718 / height: 436 / frameRate: 25.00 / thumb size : 4639 audio: id=0 / lang: kor / codec: ac3 / sf:48000~net.pms.io.OutputParams@6df14b06


Are there any recommended options for transcoding audio? Which engine? Any hidden settings to try?

Thanks in advance,
Tony
El Tonerino
 
Posts: 6
Joined: Mon Aug 10, 2009 5:16 pm

Re: Ogg vorbis transcoding

Postby shagrath » Sun Sep 13, 2009 10:21 pm

I actually experienced the same thing on my own setup, with basic mp3 streaming (short freeze of 2 seconds every 10, 15 minutes) maybe it's the same origin ?
I think i've fixed those in the latest revisions with a whole replacement of the HTTP engine... what version do you use ?
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: Ogg vorbis transcoding

Postby El Tonerino » Mon Sep 14, 2009 8:19 pm

Maybe, although MP3 is fine for me, just flac and vorbis that skip. It is usually 2 to 5 times per song.

I last tried with rev 359.
El Tonerino
 
Posts: 6
Joined: Mon Aug 10, 2009 5:16 pm

Re: Ogg vorbis transcoding

Postby El Tonerino » Mon Sep 28, 2009 8:30 pm

I have managed to sort out the issue :)

Unfortunately, I changed two things at once...

  • Thing the first: When I said
    [I] found a setting for maxaudiobuffer. I have set it to 599 in PMS.conf, but it doesn't seem to have made a difference.
    What I actually means was, I mis-typed maxaudiobuffer as maxauidobuffer, so it took no effect. Correcting the mistake led to out of memory errors, so I dropped it down to 100, and it stopped complaining.
  • Thing the second: I re-arranged my flat quite a bit. Moved the media server to a different room than the PS3, but now the router is in the same room as the media server (before the PS3 and mediaserver were in the same room, but the router in a different one.

So, if your transcoded music is skipping, try either setting maxaudiobuffer = 100 or rearrange your house ;)
El Tonerino
 
Posts: 6
Joined: Mon Aug 10, 2009 5:16 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 5 guests