Problems with system freezing.

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Problems with system freezing.

Postby Dauntes » Thu Jun 25, 2009 8:07 am

As per Shagraths info request, here's the breakdown:

1.) AMD XP 2600+(2.13ghz) with 1gig of RAM on PMS 1.10.51
2.) The network connection I'm using is wired 100mbits
3.)Everything works perfectly up until the system completely locks up.
4.)Transcoding doesn't seem to make a difference, the system locks up both transcoding and not.
5.) I would have attached the whole debuglog but it was too large even zipped so here's an excerpt I hope will prove helpful.

Any help would be greatly appreciated!
Attachments
DebugExcerpt.zip
Debug
(29.09 KiB) Downloaded 59 times
Dauntes
 
Posts: 4
Joined: Thu Jun 18, 2009 8:39 pm

Re: Problems with system freezing.

Postby Dauntes » Thu Jul 02, 2009 1:20 pm

Hey all, I'm still hoping someone can point me in the right direction to see if I can figure out what's wrong.

Essentially I'm pretty sure some aspect of streaming media to my PS3 is causing my system to lockup, but I'm not sure where the problem lies. It's inconsistent, the only common factor is that it occurs while streaming. I may be able to watch as many as 10 .avi's before the problem arises, or as few as part of one. It doesn't seem to matter if the media is transcoded or not. If I simply play the media on the server, there's no problems whatsoever.

I am running an ubuntu based distro called CrunchBang which is based on Intrepid I believe.

I'm pretty sure at this point that the problem is not directly PMS related as I did test using MediaTomb and ran into the same problems.

I thought maybe somehow it was a SWAP error so I used swapoff -a to test and the issue still occurs. It does seem to perform longer with SWAP off, but it may just be my imagination.

I'm at pretty much a standstill being very much the ubuntu neophyte and complete linux newbie in general.

Is it possible I have a bad ffmpeg install or something? Although, if I did, wouldn't the system lockup when I was playing something on the server itself?

Thanks for any help you may be able to provide.
Dauntes
 
Posts: 4
Joined: Thu Jun 18, 2009 8:39 pm

Re: Problems with system freezing.

Postby Topguy » Fri Jul 03, 2009 1:11 pm

Dauntes wrote:Thanks for any help you may be able to provide.


It is normally pretty hard to freeze any Linux system, the only similar things that happens to me sometimes is the X-server freezes due to some graphics-card bug.
But even then I can still either switch out to the virtual consoles (ctrl-alt-f1) or at least go to another machine and log in via ssh.

Are you running PMS with a gui ? you could try to run it without to see if that makes a difference. (see other threads here for how-to)
Since you had similar problems with mediatomb it may be some instability with your network card/drivers.
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: Problems with system freezing.

Postby iBurger » Fri Jul 03, 2009 3:46 pm

your kernel: 2.6.27-9

is non-stable, if I am not mistaken.
iBurger
 
Posts: 13
Joined: Wed Jun 10, 2009 3:45 pm

Re: Problems with system freezing.

Postby Dauntes » Sat Jul 04, 2009 12:39 pm

Thanks for the replies guys.

TopGuy: I have tried running it with no GUI but I appreciate the suggestion. I'm going to look into my drivers to see if one of them may be the problem.

iBurger: If that' the problem I'll be very happy. I'm going to look into it. Wouldn't Kernel instability make the system freeze outside of just streaming though? Truthfully I don't know much about kernels.

Thank you both for at least giving me ideas on where to look next.
Dauntes
 
Posts: 4
Joined: Thu Jun 18, 2009 8:39 pm

Re: Problems with system freezing.

Postby Pralix » Wed Jul 22, 2009 9:26 pm

I am having the system freeze problem as well. I also use MythTV as a Upnp server and have no problems.

My system is quite beefy:

AMD Phenom II X4 955
8 gigs of DDR3 memory
6TB of disk space.

I am running Gentoo so everyting is up to date.
2.6.30 kernel.
Pralix
 
Posts: 2
Joined: Wed Jul 22, 2009 9:20 pm

Re: Problems with system freezing.

Postby Pralix » Thu Jul 23, 2009 4:03 pm

I tried PMS again. This time I had multiple log windows open as well as atop running in a window. The app seemed to lockup after it finished scanning the media directories. The last entry in debug.log did no show anything relevant. atop showed java pegged at 100%. PMS was unresponsive but I was still able to use my system until I tried to close PMS. PMS would not close and then the system locked up completely.

FWIW: I am running a 64bit system.
Pralix
 
Posts: 2
Joined: Wed Jul 22, 2009 9:20 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests