PMS not showing any media on any renderer

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PMS not showing any media on any renderer

Postby tabmow » Sun Aug 25, 2013 11:23 am

Hi All,

I have used PMS on Windows without a problem and I am now switching it over to running on my NAS which is running FreeBSD.
I have installed all the pre-requisites and the application starts up find, however it doesn't show any of my media.
I am using the latest build, here is my PMS.conf:

Code: Select all
uuid = 2d1b9959-104c-4476-b85d-9207f26dc616
folders = /mnt/media,\/mnt\/media
minimized = true
renderer_force_default = false
hide_media_library_folder = true
renderer_default = PlayStation 3
thumbnails = true
image_thumbnails = true


Here is the debug.log:
Code: Select all
INFO  2013-08-25 20:09:14.171 [main] Starting PS3 Media Server 1.90.1
INFO  2013-08-25 20:09:14.171 [main] by shagrath / 2008-2013
INFO  2013-08-25 20:09:14.172 [main] http://ps3mediaserver.org
INFO  2013-08-25 20:09:14.172 [main] https://github.com/ps3mediaserver/ps3mediaserver
INFO  2013-08-25 20:09:14.172 [main]
INFO  2013-08-25 20:09:14.172 [main] Build: 3a4304c72 (2013-08-17)
INFO  2013-08-25 20:09:14.172 [main] Java: OpenJDK 64-Bit Server VM 1.7.0_25 by Oracle Corporation
INFO  2013-08-25 20:09:14.172 [main] OS: FreeBSD amd64 9.1-STABLE
INFO  2013-08-25 20:09:14.172 [main] Encoding: UTF-8
INFO  2013-08-25 20:09:14.179 [main] Memory: 682 MB
INFO  2013-08-25 20:09:14.180 [main]
INFO  2013-08-25 20:09:14.180 [main] Working directory: /root/pms-1.90.1
INFO  2013-08-25 20:09:14.186 [main] Temp directory: /tmp/ps3mediaserver
INFO  2013-08-25 20:09:14.187 [main] Logging config file: /root/pms-1.90.1/logback.headless.xml
INFO  2013-08-25 20:09:14.187 [main] debug.log: /root/.config/PMS/debug.log
INFO  2013-08-25 20:09:14.187 [main]
INFO  2013-08-25 20:09:14.187 [main] Profile directory: /root/.config/PMS
INFO  2013-08-25 20:09:14.188 [main] Profile directory permissions: rw
INFO  2013-08-25 20:09:14.188 [main] Profile path: /root/.config/PMS/PMS.conf
INFO  2013-08-25 20:09:14.188 [main] Profile permissions: rw
INFO  2013-08-25 20:09:14.188 [main] Profile name: sickbeard
INFO  2013-08-25 20:09:14.188 [main]
INFO  2013-08-25 20:09:14.189 [main] Web conf path: /root/.config/PMS/WEB.conf
INFO  2013-08-25 20:09:14.189 [main] Web conf permissions: file not found
INFO  2013-08-25 20:09:14.189 [main]
INFO  2013-08-25 20:09:14.190 [main] GUI environment not available
INFO  2013-08-25 20:09:14.190 [main] Switching to console mode
INFO  2013-08-25 20:09:14.241 [main] Loading MediaInfo library
INFO  2013-08-25 20:09:14.260 [main] Loaded MediaInfoLib - v0.7.52
INFO  2013-08-25 20:09:14.269 [main] Loading renderer configurations from /root/pms-1.90.1/renderers
INFO  2013-08-25 20:09:14.278 [main] Loading configuration file: AirPlayer.conf
INFO  2013-08-25 20:09:14.283 [main] Loading configuration file: Android.conf
INFO  2013-08-25 20:09:14.294 [main] Loading configuration file: BlackBerryPlayBook-KalemSoftMP.conf
INFO  2013-08-25 20:09:14.299 [main] Loading configuration file: Bravia4500.conf
INFO  2013-08-25 20:09:14.303 [main] Loading configuration file: Bravia5500.conf
INFO  2013-08-25 20:09:14.307 [main] Loading configuration file: BraviaEX.conf
INFO  2013-08-25 20:09:14.312 [main] Loading configuration file: BraviaEX620.conf
INFO  2013-08-25 20:09:14.316 [main] Loading configuration file: BraviaHX.conf
INFO  2013-08-25 20:09:14.322 [main] Loading configuration file: BraviaW.conf
INFO  2013-08-25 20:09:14.327 [main] Loading configuration file: DLinkDSM510.conf
INFO  2013-08-25 20:09:14.329 [main] Loading configuration file: DirecTVHR.conf
INFO  2013-08-25 20:09:14.333 [main] Loading configuration file: FreeboxHD.conf
INFO  2013-08-25 20:09:14.335 [main] Loading configuration file: FreecomMusicPal.conf
INFO  2013-08-25 20:09:14.337 [main] Loading configuration file: Kuro.conf
INFO  2013-08-25 20:09:14.340 [main] Loading configuration file: LGST600.conf
INFO  2013-08-25 20:09:14.344 [main] Loading configuration file: N900.conf
INFO  2013-08-25 20:09:14.346 [main] Loading configuration file: NetgearNeoTV.conf
INFO  2013-08-25 20:09:14.348 [main] Loading configuration file: OPPOBDP83.conf
INFO  2013-08-25 20:09:14.350 [main] Loading configuration file: OPPOBDP93.conf
INFO  2013-08-25 20:09:14.352 [main] Loading configuration file: OnkyoTX-NR717.conf
INFO  2013-08-25 20:09:14.354 [main] Loading configuration file: PS3.conf
INFO  2013-08-25 20:09:14.361 [main] Loading configuration file: Panasonic.conf
INFO  2013-08-25 20:09:14.367 [main] Loading configuration file: Philips.conf
INFO  2013-08-25 20:09:14.370 [main] Loading configuration file: PhilipsPFL.conf
INFO  2013-08-25 20:09:14.379 [main] Loading configuration file: PopcornHour.conf
INFO  2013-08-25 20:09:14.382 [main] Loading configuration file: Realtek.conf
INFO  2013-08-25 20:09:14.384 [main] Loading configuration file: SMP-N100.conf
INFO  2013-08-25 20:09:14.388 [main] Loading configuration file: Samsung-SMT-G7400.conf
INFO  2013-08-25 20:09:14.393 [main] Loading configuration file: SamsungAllShare.conf
INFO  2013-08-25 20:09:14.395 [main] Loading configuration file: SamsungWiseLink.conf
INFO  2013-08-25 20:09:14.397 [main] Loading configuration file: SharpAquos.conf
INFO  2013-08-25 20:09:14.400 [main] Loading configuration file: Showtime3.conf
INFO  2013-08-25 20:09:14.404 [main] Loading configuration file: Showtime4.conf
INFO  2013-08-25 20:09:14.409 [main] Loading configuration file: SonyBluray.conf
INFO  2013-08-25 20:09:14.429 [main] Loading configuration file: SonyHomeTheatreSystem.conf
INFO  2013-08-25 20:09:14.433 [main] Loading configuration file: Streamium.conf
INFO  2013-08-25 20:09:14.435 [main] Loading configuration file: TelstraTbox.conf
INFO  2013-08-25 20:09:14.436 [main] Loading configuration file: VideoWebTV.conf
INFO  2013-08-25 20:09:14.438 [main] Loading configuration file: VizioSmartTV.conf
INFO  2013-08-25 20:09:14.441 [main] Loading configuration file: WDTVLive.conf
INFO  2013-08-25 20:09:14.443 [main] Loading configuration file: WMP.conf
INFO  2013-08-25 20:09:14.445 [main] Loading configuration file: XBMC.conf
INFO  2013-08-25 20:09:14.446 [main] Loading configuration file: XBOX360.conf
INFO  2013-08-25 20:09:14.447 [main] Loading configuration file: YamahaRXA1010.conf
INFO  2013-08-25 20:09:14.448 [main] Loading configuration file: YamahaRXV3900.conf
INFO  2013-08-25 20:09:14.449 [main] Loading configuration file: YamahaRXV671.conf
INFO  2013-08-25 20:09:14.450 [main] Loading configuration file: iPad-iPhone.conf
DEBUG 2013-08-25 20:09:14.451 [main] Reading renderer_default: default: "", current: "PlayStation 3"
INFO  2013-08-25 20:09:14.452 [main] Checking MPlayer font cache. It can take a minute or so.
DEBUG 2013-08-25 20:09:14.452 [main] launching: mplayer
INFO  2013-08-25 20:09:14.497 [main] Done!
INFO  2013-08-25 20:09:14.507 [main] Searching for plugins in /root/pms-1.90.1/plugins
INFO  2013-08-25 20:09:14.516 [main] No plugins found
INFO  2013-08-25 20:09:14.526 [main] Registering transcoding engine: FFmpeg Audio
INFO  2013-08-25 20:09:14.530 [main] Registering transcoding engine: MEncoder Video
INFO  2013-08-25 20:09:14.530 [main] Registering transcoding engine: FFmpeg
INFO  2013-08-25 20:09:14.531 [main] Registering transcoding engine: VLC Video
DEBUG 2013-08-25 20:09:14.547 [main] FFmpeg supported protocols: []
INFO  2013-08-25 20:09:14.547 [main] Registering transcoding engine: FFmpeg Web Video
INFO  2013-08-25 20:09:14.547 [main] Registering transcoding engine: FFmpeg Web Audio
INFO  2013-08-25 20:09:14.547 [main] Registering transcoding engine: MEncoder Web Video
INFO  2013-08-25 20:09:14.547 [main] Registering transcoding engine: VLC Web Video
INFO  2013-08-25 20:09:14.548 [main] Registering transcoding engine: tsMuxeR
INFO  2013-08-25 20:09:14.548 [main] Registering transcoding engine: Audio High Fidelity
INFO  2013-08-25 20:09:14.549 [main] Registering transcoding engine: VLC Web Audio (Legacy)
INFO  2013-08-25 20:09:14.549 [main] Registering transcoding engine: VLC Web Video (Legacy)
INFO  2013-08-25 20:09:14.549 [main] Registering transcoding engine: dcraw Thumbnailer
INFO  2013-08-25 20:09:14.556 [main] Using address /192.168.1.206 found on network interface: name:epair4b (epair4b)
INFO  2013-08-25 20:09:14.556 [main] Created socket: /192.168.1.206:5001
DEBUG 2013-08-25 20:09:14.671 [main] Sending ALIVE...
DEBUG 2013-08-25 20:09:14.673 [main] Reading uuid: default: null, current: "2d1b9959-104c-4476-b85d-9207f26dc616"
INFO  2013-08-25 20:09:14.673 [main] Using the following UUID configured in PMS.conf: 2d1b9959-104c-4476-b85d-9207f26dc616
INFO  2013-08-25 20:09:14.926 [main] The server should now appear on your renderer
INFO  2013-08-25 20:09:15.841 [New I/O server worker #1-1] No IP filter specified, access granted to /192.168.1.2
INFO  2013-08-25 20:09:15.848 [New I/O server worker #1-1] Media renderer was not recognized. Possible identifying HTTP headers: User-Agent: DAFUPnP, Cache-Control: no-cache, Pragma: no-cache
DEBUG 2013-08-25 20:09:15.862 [New I/O server worker #1-1] HTTP User-Agent: Microsoft-Windows/6.2 UPnP/1.0
INFO  2013-08-25 20:09:15.862 [pool-4-thread-1] Checking IP: 192.168.1.2 for WMP
INFO  2013-08-25 20:09:16.053 [pool-4-thread-1] Renderer WMP found on this address: 192.168.1.2
DEBUG 2013-08-25 20:09:16.056 [pool-4-thread-1] Starting ping -c 3 -s 64000 192.168.1.2
DEBUG 2013-08-25 20:09:16.063 [pool-4-thread-1] Unix process ID (ping): 74034


Is there anything I am missing here? I don't see in the log where it is searching for my media at all...

Any help much appreciated.
Thanks!
tabmow
 
Posts: 2
Joined: Sun Aug 25, 2013 11:18 am

Re: PMS not showing any media on any renderer

Postby tabmow » Tue Aug 27, 2013 10:02 am

Anyone have any ideas here??
tabmow
 
Posts: 2
Joined: Sun Aug 25, 2013 11:18 am

Re: PMS not showing any media on any renderer

Postby adcprod » Thu Sep 12, 2013 1:54 pm

I resolved a similar issue with just Windows machines on XBMC. I removed the WMP.conf and then it was good. I think it was assuming that I wanted to user WMP over XMBC. Maybe there is a way to choose a preference and a fallback, because WMP might be better for music playback since it doesn't need fullscreen (or something close to that).
adcprod
 
Posts: 4
Joined: Thu Sep 12, 2013 1:42 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 13 guests