Freenas 8.3 and PMS 1.82.0

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Freenas 8.3 and PMS 1.82.0

Postby drooper » Mon Jun 24, 2013 9:26 am

I struggled for a while to get PMS working but I found a way to run it on my FreeNAS 8.3 BOX. Maybe it is of some use to other people.

1. Install a plugin Jail (
2. mount a bridge between freenas internals and the jail (avigate to Services -> Plugins -> Management -> Mount Points and add a new mount point)
3. ssh into your freenas by your client
(The following steps requires a couple of hours)
4. su root
jls (will show you the number of your jail)
jexec (number) csh
5. jexec 1 csh (or what number is shown when you entered the jls command)
6. portsnap fetch extract update
7. cd /usr/ports/ports-mgmt/pkg/ && make install clean
8. cd /usr/ports/ports-mgmt/portmaster/ && make install clean

Be sure to use the appropriate options for your system. If you’re not sure, check all the boxes.
press ok
9. echo ‘WITH_PKGNG=yes’ >> /etc/make.conf
10. rehash
11. pkg2ng
12. portmaster -G editors/nano
13. rehash
14. cd /usr/ports/multimedia/mencoder
15. make config
I have installed mencoder with the following options.
Press ok to proceed
16. cd /usr/ports/graphics/frei0r/
17. make config
18. check Enable MMX CPU instructions then press ok
20. portmaster -G multimedia/mencoder
21. pkg_add -v -r ffmpeg
22. pkg_add -v -r javavmwrapper
23 I downloaded diablo-jre-freebsd7.amd64. and copied it in the mounted folder
24 cd /mounted folder
25 tar xvfz diablo-jre-freebsd7.amd64.
26 pkg_add -v diablo-jre-freebsd7.amd64.
27 echo > /etc/libmap.conf
28 Download pms-generic-linux-unix-1.82.0.tgz and copy it to the mounted folder
29 tar xvfz pms-generic-linux-unix-1.82.0.tgz
30 mv pms-1.82.0 /var
31 cd /var/pms-1.82.0
32 sh

Maybe I did forget something, but it worked for me and running ps3 media server on my freenas box.
It''s my first so post so don't blame me to much if something doesn't add up.
Posts: 2
Joined: Mon Jun 24, 2013 8:51 am

Re: Freenas 8.3 and PMS 1.82.0

Postby happy.neko » Tue Jun 25, 2013 3:49 pm

thank you for detailed instructions
have you tried to make it work with open jdk instead of diablo?
Project Member
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Freenas 8.3 and PMS 1.82.0

Postby drooper » Tue Jun 25, 2013 4:44 pm

no I didn't but I will give it a shot.
Posts: 2
Joined: Mon Jun 24, 2013 8:51 am

Re: Freenas 8.3 and PMS 1.82.0

Postby delinobermshield » Tue Sep 03, 2013 11:20 pm

Hi, thanks for the detailed process, worked fine for me.
The only problem i have is with the subtitles , i can't make them appear when i'm streaming movies on my PS3, any clue?
Posts: 1
Joined: Tue Sep 03, 2013 11:12 pm

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 4 guests