Mega CPU usage

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Mega CPU usage

Postby welbo » Sun Jul 29, 2012 6:11 pm

PS3mediaserver version 1.60.0, java version 1.70, Linux Centos 6

I walked by my home server the other day and heard all of the fans running full speed. So I get in on a terminal and ran top to see that java was running at >70% cpu and another process, ksoftirqd was running at >25% cpu. This is while nothing is streaming. I killed ps3mediaserver via the 'service ps3mediaserver stop' command and total cpu usage went down to <3%. I have downloaded and installed ps3mediaserver 1.60.0, with default configuration (completely replaced the rundir), installed java 1.70 and confirmed it is working properly, and the cpu issue is still there. I've noticed that libzen and libmediainfo are not working from the trace output. What should be my next step to troubleshoot this issue?

debug.log output:
Code: Select all
[root@server ps3mediaserver]# cat debug.log
INFO  2012-07-29 12:05:32.416 [main] Starting PS3 Media Server 1.60.0
INFO  2012-07-29 12:05:32.449 [main] by shagrath / 2008-2012
INFO  2012-07-29 12:05:32.453 [main] http://ps3mediaserver.org
INFO  2012-07-29 12:05:32.470 [main] https://github.com/ps3mediaserver/ps3mediaserver
INFO  2012-07-29 12:05:32.471 [main] http://ps3mediaserver.blogspot.com
INFO  2012-07-29 12:05:32.485 [main]
INFO  2012-07-29 12:05:32.495 [main] Build: 097765cc2 (2012-07-17)
INFO  2012-07-29 12:05:32.510 [main] Java: 1.7.0_05-icedtea-Oracle Corporation
INFO  2012-07-29 12:05:32.518 [main] OS: Linux amd64 2.6.32-220.17.1.el6.x86_64
INFO  2012-07-29 12:05:32.519 [main] Encoding: UTF-8
INFO  2012-07-29 12:05:32.538 [main] Memory: 742 MB
INFO  2012-07-29 12:05:32.541 [main]
INFO  2012-07-29 12:05:32.550 [main] Working directory: /usr/local/ps3mediaserver
INFO  2012-07-29 12:05:32.612 [main] Temp folder: /tmp/ps3mediaserver
INFO  2012-07-29 12:05:32.619 [main] Logging config file: /usr/local/ps3mediaserver/logback.xml
INFO  2012-07-29 12:05:32.635 [main] debug.log: /usr/local/ps3mediaserver/debug.log
INFO  2012-07-29 12:05:32.643 [main]
INFO  2012-07-29 12:05:32.653 [main] Profile directory: /root/.config/PMS
INFO  2012-07-29 12:05:32.654 [main] Profile path: /root/.config/PMS/PMS.conf
INFO  2012-07-29 12:05:32.661 [main] Profile status: rw
INFO  2012-07-29 12:05:32.673 [main] Profile name: server.lear.dyndns.org
INFO  2012-07-29 12:05:32.680 [main]
WARN  2012-07-29 12:05:33.229 [main] Error loading libzen: Unable to load library 'zen': libzen.so: cannot open shared object file: No such file or directory
INFO  2012-07-29 12:05:33.239 [main] Loading MediaInfo library
INFO  2012-07-29 12:05:33.619 [main] Error loading MediaInfo library: Unable to load library 'mediainfo': libmediainfo.so: cannot open shared object file: No such file or directory
INFO  2012-07-29 12:05:33.625 [main] Make sure you have libmediainfo and libzen installed
INFO  2012-07-29 12:05:33.626 [main] The server will now use the less accurate ffmpeg parsing method
INFO  2012-07-29 12:05:33.694 [main] Loading renderer configurations from /usr/local/ps3mediaserver/renderers
INFO  2012-07-29 12:05:33.712 [main] Loading configuration file: XBOX360.conf
DEBUG 2012-07-29 12:05:33.714 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/XBOX360.conf
INFO  2012-07-29 12:05:33.759 [main] Loading configuration file: Bravia4500.conf
DEBUG 2012-07-29 12:05:33.769 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/Bravia4500.conf
INFO  2012-07-29 12:05:33.805 [main] Loading configuration file: SamsungWiseLink.conf
DEBUG 2012-07-29 12:05:33.807 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/SamsungWiseLink.conf
INFO  2012-07-29 12:05:33.832 [main] Loading configuration file: Streamium.conf
DEBUG 2012-07-29 12:05:33.844 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/Streamium.conf
INFO  2012-07-29 12:05:33.880 [main] Loading configuration file: OPPOBDP83.conf
DEBUG 2012-07-29 12:05:33.892 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/OPPOBDP83.conf
INFO  2012-07-29 12:05:33.905 [main] Loading configuration file: Panasonic.conf
DEBUG 2012-07-29 12:05:33.920 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/Panasonic.conf
INFO  2012-07-29 12:05:33.959 [main] Loading configuration file: Android.conf
DEBUG 2012-07-29 12:05:33.966 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/Android.conf
INFO  2012-07-29 12:05:33.977 [main] Loading configuration file: PhilipsPFL.conf
DEBUG 2012-07-29 12:05:33.978 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/PhilipsPFL.conf
INFO  2012-07-29 12:05:34.032 [main] Loading configuration file: FreeboxHD.conf
DEBUG 2012-07-29 12:05:34.041 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/FreeboxHD.conf
INFO  2012-07-29 12:05:34.056 [main] Loading configuration file: WMP.conf
DEBUG 2012-07-29 12:05:34.063 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/WMP.conf
INFO  2012-07-29 12:05:34.096 [main] Loading configuration file: DLinkDSM510.conf
DEBUG 2012-07-29 12:05:34.106 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/DLinkDSM510.conf
INFO  2012-07-29 12:05:34.131 [main] Loading configuration file: Showtime3.conf
DEBUG 2012-07-29 12:05:34.145 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/Showtime3.conf
INFO  2012-07-29 12:05:34.180 [main] Loading configuration file: AirPlayer.conf
DEBUG 2012-07-29 12:05:34.192 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/AirPlayer.conf
INFO  2012-07-29 12:05:34.233 [main] Loading configuration file: SMP-N100.conf
DEBUG 2012-07-29 12:05:34.250 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/SMP-N100.conf
INFO  2012-07-29 12:05:34.310 [main] Loading configuration file: PopcornHour.conf
DEBUG 2012-07-29 12:05:34.319 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/PopcornHour.conf
INFO  2012-07-29 12:05:34.334 [main] Loading configuration file: BraviaEX.conf
DEBUG 2012-07-29 12:05:34.346 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/BraviaEX.conf
INFO  2012-07-29 12:05:34.374 [main] Loading configuration file: XBMC.conf
DEBUG 2012-07-29 12:05:34.381 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/XBMC.conf
INFO  2012-07-29 12:05:34.402 [main] Loading configuration file: iPad-iPhone.conf
DEBUG 2012-07-29 12:05:34.409 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/iPad-iPhone.conf
INFO  2012-07-29 12:05:34.449 [main] Loading configuration file: Philips.conf
DEBUG 2012-07-29 12:05:34.459 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/Philips.conf
INFO  2012-07-29 12:05:34.488 [main] Loading configuration file: SonyBluray.conf
DEBUG 2012-07-29 12:05:34.496 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/SonyBluray.conf
INFO  2012-07-29 12:05:34.522 [main] Loading configuration file: WDTVLive.conf
DEBUG 2012-07-29 12:05:34.539 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/WDTVLive.conf
INFO  2012-07-29 12:05:34.560 [main] Loading configuration file: Kuro.conf
DEBUG 2012-07-29 12:05:34.563 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/Kuro.conf
INFO  2012-07-29 12:05:34.594 [main] Loading configuration file: N900.conf
DEBUG 2012-07-29 12:05:34.603 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/N900.conf
INFO  2012-07-29 12:05:34.615 [main] Loading configuration file: OPPOBDP93.conf
DEBUG 2012-07-29 12:05:34.628 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/OPPOBDP93.conf
INFO  2012-07-29 12:05:34.635 [main] Loading configuration file: YamahaRXV671.conf
DEBUG 2012-07-29 12:05:34.659 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/YamahaRXV671.conf
INFO  2012-07-29 12:05:34.661 [main] Loading configuration file: DirecTVHR.conf
DEBUG 2012-07-29 12:05:34.673 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/DirecTVHR.conf
INFO  2012-07-29 12:05:34.707 [main] Loading configuration file: FreecomMusicPal.conf
DEBUG 2012-07-29 12:05:34.709 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/FreecomMusicPal.conf
INFO  2012-07-29 12:05:34.736 [main] Loading configuration file: PS3.conf
DEBUG 2012-07-29 12:05:34.737 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/PS3.conf
INFO  2012-07-29 12:05:34.793 [main] Loading configuration file: SamsungAllShare.conf
DEBUG 2012-07-29 12:05:34.801 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/SamsungAllShare.conf
INFO  2012-07-29 12:05:34.822 [main] Loading configuration file: Realtek.conf
DEBUG 2012-07-29 12:05:34.823 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/Realtek.conf
INFO  2012-07-29 12:05:34.846 [main] Loading configuration file: LGST600.conf
DEBUG 2012-07-29 12:05:34.848 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/LGST600.conf
INFO  2012-07-29 12:05:34.866 [main] Loading configuration file: Bravia5500.conf
DEBUG 2012-07-29 12:05:34.876 [main] Base path set to file:///usr/local/ps3mediaserver/renderers/Bravia5500.conf
INFO  2012-07-29 12:05:34.886 [main] Checking MPlayer font cache. It can take a minute or so.
DEBUG 2012-07-29 12:05:34.894 [main] launching: mplayer
INFO  2012-07-29 12:05:35.306 [main] Done!
INFO  2012-07-29 12:05:35.348 [main] Searching for plugins in /usr/local/ps3mediaserver/plugins
INFO  2012-07-29 12:05:35.363 [main] No plugins found
INFO  2012-07-29 12:05:35.527 [main] Registering transcoding engine: FFmpeg Audio
INFO  2012-07-29 12:05:35.591 [main] Registering transcoding engine: MEncoder
INFO  2012-07-29 12:05:35.593 [main] Registering transcoding engine: FFmpeg
INFO  2012-07-29 12:05:35.595 [main] Registering transcoding engine: MPlayer Audio
INFO  2012-07-29 12:05:35.597 [main] Registering transcoding engine: MEncoder Web
INFO  2012-07-29 12:05:35.600 [main] Registering transcoding engine: MPlayer Video Dump
INFO  2012-07-29 12:05:35.602 [main] Registering transcoding engine: MPlayer Web
INFO  2012-07-29 12:05:35.605 [main] Registering transcoding engine: tsMuxeR
INFO  2012-07-29 12:05:35.607 [main] Registering transcoding engine: Audio High Fidelity
INFO  2012-07-29 12:05:35.623 [main] Registering transcoding engine: VLC Audio Streaming
INFO  2012-07-29 12:05:35.631 [main] Registering transcoding engine: VLC Video Streaming
INFO  2012-07-29 12:05:35.643 [main] Registering transcoding engine: dcraw Thumbnailer
INFO  2012-07-29 12:05:36.538 [main] Using address /10.1.1.1 found on network interface: name:eth1 (eth1)
INFO  2012-07-29 12:05:36.542 [main] Created socket: /10.1.1.1:5001
INFO  2012-07-29 12:05:37.485 [main] Checking shared folder: /home/content
DEBUG 2012-07-29 12:05:37.967 [main] Sending ALIVE...
INFO  2012-07-29 12:05:37.984 [main] Using the following UUID configured in PMS.conf: e724e205-3f31-4b83-9fb5-4888686b9a6f
INFO  2012-07-29 12:05:52.346 [New I/O server worker #1-1] No IP filter specified, access granted to /10.1.1.10
INFO  2012-07-29 12:05:52.497 [pool-5-thread-1] Checking IP: 10.1.1.10 for WMP
INFO  2012-07-29 12:05:52.514 [pool-5-thread-1] Renderer WMP found on this address: DellPC (10.1.1.10)
DEBUG 2012-07-29 12:05:52.610 [pool-5-thread-1] Starting ping -c 3 -s 64000 10.1.1.10
DEBUG 2012-07-29 12:05:52.638 [pool-5-thread-1] Unix process ID (ping): 18654
DEBUG 2012-07-29 12:05:54.648 [pool-5-thread-1] Could not parse time from "3 packets transmitted, 3 received, 0% packet loss, time 2014"
DEBUG 2012-07-29 12:05:54.648 [pool-5-thread-1] Could not parse time from "11.925/11.971/12.044/0.103"
INFO  2012-07-29 12:05:54.648 [pool-5-thread-1] Address /10.1.1.10 has an estimated network speed of: 93 Mb/s
DEBUG 2012-07-29 12:05:56.697 [SpeedStats Failsafe] Stopping Unix process 18654: ping-0
INFO  2012-07-29 12:06:01.383 [main] The server should now appear on your renderer
INFO  2012-07-29 12:06:08.708 [UPNPHelper] No IP filter specified, access granted to /10.1.1.71
DEBUG 2012-07-29 12:06:14.380 [UPNP-AliveMessageSender] Sending ALIVE...
ERROR 2012-07-29 12:06:26.349 [AWT-EventQueue-0] Failed to open file /usr/local/ps3mediaserver/debug.log in default editor
java.io.IOException: Failed to show URI:file:/usr/local/ps3mediaserver/debug.log
        at sun.awt.X11.XDesktopPeer.launch(XDesktopPeer.java:114) ~[na:1.7.0_05-icedtea]
        at sun.awt.X11.XDesktopPeer.open(XDesktopPeer.java:77) ~[na:1.7.0_05-icedtea]
        at java.awt.Desktop.open(Desktop.java:272) ~[na:1.7.0_05-icedtea]
        at net.pms.newgui.TracesTab$2.mouseClicked(TracesTab.java:132) ~[pms.jar:na]
        at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270) [na:1.7.0_05-icedtea]
        at java.awt.Component.processMouseEvent(Component.java:6508) [na:1.7.0_05-icedtea]
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3312) [na:1.7.0_05-icedtea]
        at java.awt.Component.processEvent(Component.java:6270) [na:1.7.0_05-icedtea]
        at java.awt.Container.processEvent(Container.java:2229) [na:1.7.0_05-icedtea]
        at java.awt.Component.dispatchEventImpl(Component.java:4861) [na:1.7.0_05-icedtea]
        at java.awt.Container.dispatchEventImpl(Container.java:2287) [na:1.7.0_05-icedtea]
        at java.awt.Component.dispatchEvent(Component.java:4687) [na:1.7.0_05-icedtea]
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832) [na:1.7.0_05-icedtea]
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501) [na:1.7.0_05-icedtea]
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422) [na:1.7.0_05-icedtea]
        at java.awt.Container.dispatchEventImpl(Container.java:2273) [na:1.7.0_05-icedtea]
        at java.awt.Window.dispatchEventImpl(Window.java:2719) [na:1.7.0_05-icedtea]
        at java.awt.Component.dispatchEvent(Component.java:4687) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:703) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue.access$000(EventQueue.java:102) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue$3.run(EventQueue.java:662) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue$3.run(EventQueue.java:660) [na:1.7.0_05-icedtea]
        at java.security.AccessController.doPrivileged(Native Method) [na:1.7.0_05-icedtea]
        at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76) [na:1.7.0_05-icedtea]
        at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue$4.run(EventQueue.java:676) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue$4.run(EventQueue.java:674) [na:1.7.0_05-icedtea]
        at java.security.AccessController.doPrivileged(Native Method) [na:1.7.0_05-icedtea]
        at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:673) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:97) [na:1.7.0_05-icedtea]
ERROR 2012-07-29 12:06:33.004 [AWT-EventQueue-0] Failed to open file /usr/local/ps3mediaserver/debug.log in default editor
java.io.IOException: Failed to show URI:file:/usr/local/ps3mediaserver/debug.log
        at sun.awt.X11.XDesktopPeer.launch(XDesktopPeer.java:114) ~[na:1.7.0_05-icedtea]
        at sun.awt.X11.XDesktopPeer.open(XDesktopPeer.java:77) ~[na:1.7.0_05-icedtea]
        at java.awt.Desktop.open(Desktop.java:272) ~[na:1.7.0_05-icedtea]
        at net.pms.newgui.TracesTab$2.mouseClicked(TracesTab.java:132) ~[pms.jar:na]
        at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270) [na:1.7.0_05-icedtea]
        at java.awt.Component.processMouseEvent(Component.java:6508) [na:1.7.0_05-icedtea]
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3312) [na:1.7.0_05-icedtea]
        at java.awt.Component.processEvent(Component.java:6270) [na:1.7.0_05-icedtea]
        at java.awt.Container.processEvent(Container.java:2229) [na:1.7.0_05-icedtea]
        at java.awt.Component.dispatchEventImpl(Component.java:4861) [na:1.7.0_05-icedtea]
        at java.awt.Container.dispatchEventImpl(Container.java:2287) [na:1.7.0_05-icedtea]
        at java.awt.Component.dispatchEvent(Component.java:4687) [na:1.7.0_05-icedtea]
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832) [na:1.7.0_05-icedtea]
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501) [na:1.7.0_05-icedtea]
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422) [na:1.7.0_05-icedtea]
        at java.awt.Container.dispatchEventImpl(Container.java:2273) [na:1.7.0_05-icedtea]
        at java.awt.Window.dispatchEventImpl(Window.java:2719) [na:1.7.0_05-icedtea]
        at java.awt.Component.dispatchEvent(Component.java:4687) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:703) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue.access$000(EventQueue.java:102) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue$3.run(EventQueue.java:662) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue$3.run(EventQueue.java:660) [na:1.7.0_05-icedtea]
        at java.security.AccessController.doPrivileged(Native Method) [na:1.7.0_05-icedtea]
        at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76) [na:1.7.0_05-icedtea]
        at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue$4.run(EventQueue.java:676) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue$4.run(EventQueue.java:674) [na:1.7.0_05-icedtea]
        at java.security.AccessController.doPrivileged(Native Method) [na:1.7.0_05-icedtea]
        at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76) [na:1.7.0_05-icedtea]
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:673) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139) [na:1.7.0_05-icedtea]
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:97) [na:1.7.0_05-icedtea]
DEBUG 2012-07-29 12:06:56.064 [UPNP-AliveMessageSender] Sending ALIVE...
INFO  2012-07-29 12:07:35.387 [PMS Listeners Stopper] Sending BYEBYE...
DEBUG 2012-07-29 12:07:35.389 [UPNP-AliveMessageSender] Error while sending periodic alive message: sleep interrupted
DEBUG 2012-07-29 12:07:49.168 [PMS Listeners Stopper] Forcing shutdown of all active processes
INFO  2012-07-29 12:07:49.169 [PMS Listeners Stopper] Stopping server on host 10.1.1.1 and port 5001...
[root@server ps3mediaserver]#



Thanks for the advice.
welbo
welbo
 
Posts: 3
Joined: Sun Jul 29, 2012 5:52 pm

Re: Mega CPU usage

Postby Seve » Tue Jul 31, 2012 4:30 am

You have IcedTea installed for Java which may or may not be the problem?

Try installing Oracle JRE http://www.oracle.com/technetwork/java/ ... index.html

There is a guide for Fedora located here, which is / should also apply to Centos

http://www.mjmwired.net/resources/mjm-f ... .html#java
Seve
 
Posts: 13
Joined: Tue Apr 06, 2010 7:06 am

Re: Mega CPU usage

Postby welbo » Tue Jul 31, 2012 4:52 am

I hoped you had something there, but it didn't help. I also tried it with 1.60.0 (openjdk) originally, with the same problem. The problem seems to have come on by itself (probably after a system update). Any more ideas anyone?
welbo
welbo
 
Posts: 3
Joined: Sun Jul 29, 2012 5:52 pm

Re: Mega CPU usage

Postby Seve » Wed Aug 01, 2012 2:56 am

INFO 2012-07-29 12:05:33.625 [main] Make sure you have libmediainfo and libzen installed


How did you install libzen and libmedinfo ?

Perhaps reinstalling both and or see if there is a rpm avaialabe for Centos ?

BTW
I have always had to use Oracle's Java version with PSM, so I would recommend sticking with that edition.
Seve
 
Posts: 13
Joined: Tue Apr 06, 2010 7:06 am

Re: Mega CPU usage

Postby welbo » Wed Aug 01, 2012 3:03 am

I was a le to install libzen and libmediainfo via rpm shortly after the post. The errors are gone. Ut the high cpu usage for java and ksoftirqd are still there when the media server are running.

Thanks for taking the time to respond.
welbo
welbo
 
Posts: 3
Joined: Sun Jul 29, 2012 5:52 pm

Re: Mega CPU usage

Postby Seve » Wed Aug 01, 2012 5:27 am

The high CPU usage may be due to the type of CPU or it may be due to more than one version of java running etc.?

ksoftirqd may be another issue.

see the man page for ksoftirqd for a better explanation than I can give you.

One thing I would do is at next boot time, enter your BIOS and disable all things such as serial ports / firewire etc. that you are not going to use, save and reboot.


if you have a DE installed look for system monitor / processes

or try

# top

to see what exactly is going on.
Seve
 
Posts: 13
Joined: Tue Apr 06, 2010 7:06 am

Re: Mega CPU usage

Postby mikesofo » Sat Aug 25, 2012 2:18 pm

I face almost the same problem on ubuntu 12.04 64bit. Randomly the java process reaches 100 of cpu usage. If i
quit and restart the ps3mediaserver the issue resolves for a couple of hours... I am not sure what starts this problem.
any ideas?
mikesofo
 
Posts: 1
Joined: Sat Aug 25, 2012 2:11 pm

Re: Mega CPU usage

Postby shayh » Wed Sep 26, 2012 6:24 am

Have the same issue on windows 7
C2Q8400 one core at 100%


Starting PS3 Media Server 1.70.1
Java: 1.7.0_07-Oracle Corporation
shayh
 
Posts: 1
Joined: Wed Sep 26, 2012 6:15 am

Re: Mega CPU usage

Postby phu5ion » Thu Nov 08, 2012 2:24 am

I'm getting the same experience.

AMD X3 720
Xubuntu 12.04 - Linux amd64 3.2.0-32-generic
PS3 Media Server 1.60.0+git+mencoder35003-1 (ppa:happy-neko)
Java: 1.6.0_24-Sun Microsystems Inc.
phu5ion
 
Posts: 4
Joined: Thu Nov 08, 2012 2:20 am


Return to Linux/Unix Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 4 guests