CentOS 6 PS3 MS 1.53 and MKV No Subtitles?

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

CentOS 6 PS3 MS 1.53 and MKV No Subtitles?

Postby Schorschi » Sat Jun 16, 2012 3:06 am

Ok, I had PS3 MS 1.50.1 pretty much working as needed on CentOS 6, but my hardware was under powered, so with the release of 1.53, I decided to improve the hardware. That done, I installed CentOS 6, installed PS3 MS 1.53, it works... for AVI files, I get subtitles, but for MKV files, nada. GNOME MPlayer works plays the MKV files fine with subtitles. All I see in the is the following, see below, but I am not sure how to interpet the information.

Code: Select all
DEBUG 2012-06-15 18:44:38.702 [Thread-59] New_Face failed. Maybe the font path is wrong.
DEBUG 2012-06-15 18:44:38.703 [Thread-59] Please supply the text font file (~/.mplayer/subfont.ttf).
DEBUG 2012-06-15 18:44:38.703 [Thread-59] subtitle font: load_sub_face failed.
DEBUG 2012-06-15 18:44:38.705 [Thread-59] New_Face failed. Maybe the font path is wrong.
DEBUG 2012-06-15 18:44:38.705 [Thread-59] Please supply the text font file (~/.mplayer/subfont.ttf).
DEBUG 2012-06-15 18:44:38.706 [Thread-59] subtitle font: load_sub_face failed.


At first I thought this was just the query for if I had set a subtitle true type font. But not sure. Since MPlayer plays the MKV file with subtitles fine? I don't see why PS3 MS would not find the default font as well? I don't recall having this issue with 1.50.1. Any help greatly appreciated.

One other quirk, if I click on the debug.log button in the PS3 MS GUI, I get a java.io.exception, that seems odd as well! The debug.log file is of course their at the specific path, so not sure why the exception is thrown.

Code: Select all
ERROR 2012-06-15 18:46:11.787 [AWT-EventQueue-0] Failed to open file /opt/pms/pms-1.53.0/debug.log in default editor
java.io.IOException: Failed to show URI:file:/opt/pms/pms-1.53.0/debug.log
        at sun.awt.X11.XDesktopPeer.launch(XDesktopPeer.java:93) ~[na:1.6.0_24]
        at sun.awt.X11.XDesktopPeer.open(XDesktopPeer.java:61) ~[na:1.6.0_24]
        at java.awt.Desktop.open(Desktop.java:272) ~[na:1.6.0_24]
        at net.pms.newgui.TracesTab$2.mouseClicked(TracesTab.java:144) ~[pms.jar:na]
        at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270) [na:1.6.0_24]
        at java.awt.Component.processMouseEvent(Component.java:6271) [na:1.6.0_24]
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3267) [na:1.6.0_24]
        at java.awt.Component.processEvent(Component.java:6033) [na:1.6.0_24]
        at java.awt.Container.processEvent(Container.java:2045) [na:1.6.0_24]
        at java.awt.Component.dispatchEventImpl(Component.java:4629) [na:1.6.0_24]
        at java.awt.Container.dispatchEventImpl(Container.java:2103) [na:1.6.0_24]
        at java.awt.Component.dispatchEvent(Component.java:4455) [na:1.6.0_24]
Last edited by chocolateboy on Sat Jun 16, 2012 2:14 pm, edited 1 time in total.
Reason: reformatted
Schorschi
 
Posts: 11
Joined: Mon Nov 28, 2011 10:29 pm

Re: CentOS 6 PS3 MS 1.53 and MKV No Subtitles?

Postby happy.neko » Sun Jun 17, 2012 5:55 pm

Your problems are caused by outdated mencoder build. Look here viewtopic.php?f=3&t=12387&start=80#p70332 for instructions how to extract precompiled binaries from my ubuntu package and here viewtopic.php?f=3&t=14556#p70277 how to configure PS3MS to use them.

You also need libmediainfo installed for PS3MS to function properly. You can grab it here http://mediainfo.sourceforge.net/ru/Download/CentOS
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: CentOS 6 PS3 MS 1.53 and MKV No Subtitles?

Postby happy.neko » Sun Jun 17, 2012 7:52 pm

Wrote better instructions viewtopic.php?f=3&t=14605 as they may be useful for other users.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: Bing [Bot], Exabot [Bot], Yahoo [Bot] and 3 guests