Audio playing at >x2 speed since upgrade to 1.51.0

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Audio playing at >x2 speed since upgrade to 1.51.0

Postby dr_faulk » Sun Apr 01, 2012 10:25 pm

Chaps, I ran the latest update via Ubuntu software centre the other day, and have noticed the audio on mkv files (at least, that's all I've tested) playing really quickly. Video plays fine. I may have updated some other dependent packages that could be part of the cause. Hoping ye can help me narrow it down to whether it's a PMS itself or something else.

Here's all the info I have:

1- Your computer specs (cpu, memory, O/S)

CPU: AMD A4-3400 APU with Radeon HD Graphics (Dual Core 2.7 Ghz)
RAM: 4Gb DDR3
O/S: Ubuntu R11.10 (oneiric); Kernal Linux 3.0.0-17-generic

and the precise version of PMS that you're using

PMS 1.51.0-mencoder34587-1 (ppa:happy-neko)
Build: f1bc902f8 (Thurs Mar 15)

2- Device you are streaming to (PS3, XBox360, etc) and the .conf file if using a custom renderer profile

PS3 120 Gig 'Fat' Model (2008)
Cong file attached in second post below

3- Your local network setup:

PC <-> Netopia router <-> Cisco Modem <-> PS3

4- Which engine you are using if you're transcoding (MEncoder, AviSynth/MEncoder, TSmuxer)

MEncoder for video; FFmpeg for audio

5- Detailed information on what is not working

PSM has always worked perfectly for me. It was working perfectly just until the other day when I made these two changes:

I've configured Ubuntu's Software center to tune in to your repository. During last week, an update was made available for PMS. I installed the update. Now, while the video stream works perfectly, the audio stream is playing at double speed.

Shortly after I installed this update, I also installed/updated the following packages via apt-get:

yasm
zlib-devel
bzip2-devel
fribidi-devel
dbus-glib-devel (gui)
libgudev1-devel (gui)
webkitgtk-devel (gui)
libnotify-devel (gui)
gstreamer-devel (gui)
gstreamer-plugins-base-devel (gui)

Perhaps, there's a dependency in there that I've managed to bork?

6- From the "Traces" tab: a debug.log file excerpt

Attached

7- The text output from MediaInfo

I haven't tried this, as the videos worked fine before the update.
Attachments
PMS_Debug_010412.txt.gz
Debug Log
(1.98 KiB) Downloaded 50 times
dr_faulk
 
Posts: 4
Joined: Sun Apr 01, 2012 10:12 pm

Re: Audio playing at >x2 speed since upgrade to 1.51.0

Postby dr_faulk » Sun Apr 01, 2012 10:26 pm

Here's the conf file
Attachments
PS3ConfCopy.txt.gz
Config file
(1.1 KiB) Downloaded 52 times
dr_faulk
 
Posts: 4
Joined: Sun Apr 01, 2012 10:12 pm

Re: Audio playing at >x2 speed since upgrade to 1.51.0

Postby dr_faulk » Sun Apr 01, 2012 10:29 pm

Okay, wait - I see that 1.52 was released shortly after. Why is Ubuntu Software centre not picking this up?
dr_faulk
 
Posts: 4
Joined: Sun Apr 01, 2012 10:12 pm

Re: Audio playing at >x2 speed since upgrade to 1.51.0

Postby dr_faulk » Sun Apr 01, 2012 10:46 pm

Gah! 1.52 has its own issues. 'Data is corrupt' messages on PS3, with PSM's logs shows java errors when trying to run MEncoder.

I'll continue to fiddle with 1.52, but if anyone could tell me:

- Does PSM depend on the above-listed packages, that I updated?
- Why has 1.52 not come through via Ubuntu Software Centre?

Thank you.
dr_faulk
 
Posts: 4
Joined: Sun Apr 01, 2012 10:12 pm

Re: Audio playing at >x2 speed since upgrade to 1.51.0

Postby happy.neko » Mon Apr 02, 2012 11:53 am

1. ps3mediaserver depends on flac, imagemagick, openjdk-6-jre, ia32-libs [amd64], ttf-ubuntu-font-family. You can't break it with apt-get update.

2. Try to disable "Use LPCM for audio" as you problem fix.

3. Samples (http://mediafire.com/) of problematic files will be much appreciated. Or at least mediainfo (http://pastebin.com/).
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 7 guests