Why PMS show "... no inputstream to return for [MEncoder]"?

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Why PMS show "... no inputstream to return for [MEncoder]"?

Postby mwgong » Tue Jan 24, 2012 3:06 am

I just installed PMS 1.50 on ubuntu server 11.10, and installed related packages.

When I tried to stream a MPEG4 file to a SONY TV, PMS didn't work. And following is shown in the log file
...
[New I/O server worker #1-2] ERROR 19:42:59.366 There is no inputstream to return for CCTV.2012.Spring.Festival.Celebration.Party-01_mpeg4.avi [MEncoder]
...

What does the message really mean ? Did I miss anything or was my config file wrong ?

Please advise.

Thanks.
mwgong
 
Posts: 3
Joined: Tue Jan 24, 2012 2:54 am

Re: Why PMS show "... no inputstream to return for [MEncoder

Postby happy.neko » Tue Jan 24, 2012 6:53 am

happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Why PMS show "... no inputstream to return for [MEncoder

Postby mwgong » Thu Jan 26, 2012 2:05 am

The deb requires openjdk-6-jre to be installed, but I already installed Sun Java on my server.

Is there a quick way to fix the inputstream error under the Sun Java ?
mwgong
 
Posts: 3
Joined: Tue Jan 24, 2012 2:54 am

Re: Why PMS show "... no inputstream to return for [MEncoder

Postby mwgong » Sat Jan 28, 2012 11:14 pm

I installed 1.50.0 on Windows 7, and used all the default settings. Interestingly, the same file is played fine on the same TV.

So it seems the PMS on Windows is better than the PMS on Linux.

Can anyone advise how to do trouble shooting for the "no inputstream to return" issue ?

Thanks.
mwgong
 
Posts: 3
Joined: Tue Jan 24, 2012 2:54 am

Re: Why PMS show "... no inputstream to return for [MEncoder

Postby happy.neko » Sun Jan 29, 2012 2:49 pm

mwgong wrote:The deb requires openjdk-6-jre to be installed, but I already installed Sun Java on my server.

It should run under sun-jre.
openjdk-6-jre is required because recent Ubuntu releases drop sun-jre from repositories.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests