Command logs

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Command logs

Postby hamvil » Mon Jan 16, 2012 3:42 pm

Hi,

is there a way to see how are mencoder and tsmuxer called by PMS? Something like a full debug log.

Thanks
hamvil
 
Posts: 3
Joined: Mon Jan 16, 2012 3:41 pm

Re: Command logs

Postby Raptor399 » Mon Jan 16, 2012 9:37 pm

hamvil wrote:is there a way to see how are mencoder and tsmuxer called by PMS? Something like a full debug log.

Recent versions of PMS log the exact command line to the debug.log.
Just copy the line from that file.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Command logs

Postby hamvil » Tue Jan 17, 2012 9:09 am

Thanks. I've found it.

Do you known if the mencoder package shipped with recent linux distribution is compiled with some sub-titles related option? I'm compiling the latest mencoder (and ffmpeg) from source on by NAS (a netgear readynas), but I cannot get subtitles with either PMS or Mediatomb (which is another DLNA server). So I conclude that the problem must be mencoder.

Any hints?
hamvil
 
Posts: 3
Joined: Mon Jan 16, 2012 3:41 pm

Re: Command logs

Postby Raptor399 » Tue Jan 17, 2012 9:49 am

As far as I know the regular PMS Linux build does not ship with its own compiled binaries.
However, you could try happy.neko's package.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Command logs

Postby hamvil » Tue Jan 17, 2012 10:12 am

Yes I know, my problem is the following:

PC: PMS 1.50 + mencoder (the one coming with fedora 16) -> works fine with hardcoded subtitles on my PS3

ReadyNAS: PMS 1.50 + mencoder (compiled from the latest svn) -> video and audio work fine but subtitles are not embedded, also it seems that the version that I'm compiling from source does not support the options -subfont-autoscale and -subfont-text-scale (I had to remove these options from the code in order to continue). I double checked in the debug.log the mencoder what actually called without these two options.

Same result if I replace PMS with mediatomb on the ReadyNAS. Tested with the same avi video and the same srt subtitle.

R.
hamvil
 
Posts: 3
Joined: Mon Jan 16, 2012 3:41 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 5 guests