Easy setup guide for Ubuntu / Debian (DEB packages and repo)

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby emmellst » Thu Jul 19, 2012 3:17 am

Exactly the same symptoms here. I was trying to upgrade (hadn't touched it since 1.20...), running Debian Squeeze... and I absolutely cannot get the ps3 to see the media server. Everything is running, seemingly, no obvious blocks, exceptions or problems in either pms.conf or debug.log. Connectivity is absolutely there, nothing has changed since I was running 1.20 successfully. There is no firewall between the server and the ps3... but searching for media servers turns up nothing, and ps3mediaserver never appears.... Thoughts?

Debug.log: http://pastebin.com/Nmutgk7U
PMS.conf: http://pastebin.com/JWaP5Y8v

Any thoughts or help would be GREATLY appreciated.... I should've let it be!
emmellst
 
Posts: 2
Joined: Thu Jul 19, 2012 3:10 am

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby emmellst » Thu Jul 19, 2012 3:22 am

Go figure, when I finally post, I find it.

It wasn't picking up my network interface properly. Manually entered the correct IP and interface and away she went...
emmellst
 
Posts: 2
Joined: Thu Jul 19, 2012 3:10 am

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby 8140david » Thu Jul 19, 2012 8:54 am

@emmelist:

So you entered a certain IP in PMS configuration, is that it?
What IP did you enter, so I have an idea?
On my computer, I have 2 basic choices: 127.0.0.1 and 192.168.0.10

Also, how can I make sure no firewall is working when I use PMS?
Normally, I control the firewall through Firestarter...

Thanks in advance for your help!
8140david
 
Posts: 8
Joined: Sun Dec 12, 2010 11:44 am

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby 8140david » Thu Jul 19, 2012 10:28 am

Here is what ifconfig says:

eth0 Link encap:Ethernet HWaddr 00:21:70:c5:6c:91
inet adr:192.168.0.10 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: 2a01:e35:2e36:86c0:9030:bde8:9b95:6cee/64 Scope:Global
adr inet6: 2a01:e35:2e36:86c0:221:70ff:fec5:6c91/64 Scope:Global
adr inet6: fe80::221:70ff:fec5:6c91/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:32200 erreurs:0 :0 overruns:0 frame:0
TX packets:21126 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:41528672 (41.5 MB) Octets transmis:2067750 (2.0 MB)
Interruption:22 Mémoire:f6fe0000-f7000000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:3082 erreurs:0 :0 overruns:0 frame:0
TX packets:3082 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:314540 (314.5 KB) Octets transmis:314540 (314.5 KB)

So in PMS configuration, what should I indicate?
8140david
 
Posts: 8
Joined: Sun Dec 12, 2010 11:44 am

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby gauched » Thu Jul 19, 2012 6:34 pm

ERROR 2012-07-15 13:33:50.137 [main] A serious error occurred during PMS init
java.net.SocketException: No such device
at java.net.PlainDatagramSocketImpl.join(Native Method) ~[na:1.6.0_24]
at java.net.AbstractPlainDatagramSocketImpl.join(AbstractPlainDatagramSocketImpl.java:168) ~[na:1.6.0_24]
at java.net.MulticastSocket.joinGroup(MulticastSocket.java:300) ~[na:1.6.0_24]
at net.pms.network.UPNPHelper.getNewMulticastSocket(UPNPHelper.java:149) ~[pms.jar:na]
at net.pms.network.UPNPHelper.sendAlive(UPNPHelper.java:115) ~[pms.jar:na]
at net.pms.PMS.init(PMS.java:531) [pms.jar:na]
at net.pms.PMS.createInstance(PMS.java:801) [pms.jar:na]
at net.pms.PMS.main(PMS.java:873) [pms.jar:na]


Any thoughts on what might be causing this?

Thanks.
gauched
 
Posts: 23
Joined: Sat Nov 27, 2010 10:30 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby happy.neko » Thu Jul 19, 2012 7:43 pm

"java.net.SocketException: No such device" means your network interface is not up during ps3ms startup. Restart it later and everything should work fine.
Try full reinstall (sudo apt-get purge ps3mediaserver). And how your PC is connected to LAN?
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby gauched » Fri Jul 20, 2012 5:49 pm

happy.neko wrote:"java.net.SocketException: No such device" means your network interface is not up during ps3ms startup. Restart it later and everything should work fine.
Try full reinstall (sudo apt-get purge ps3mediaserver). And how your PC is connected to LAN?


It's a wired connection. Yes, you're right that if I restart it after booting then it works fine. However, that's what I'm trying to avoid having to do.

Or perhaps you meant something else? Are you suggesting that I need to change something in order to get it started later? I'll try a reinstall, but can't see that helping because PMS is the last thing I installed anyway.
gauched
 
Posts: 23
Joined: Sat Nov 27, 2010 10:30 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby happy.neko » Fri Jul 20, 2012 10:32 pm

gauched wrote:
happy.neko wrote:"java.net.SocketException: No such device" means your network interface is not up during ps3ms startup. Restart it later and everything should work fine.
Try full reinstall (sudo apt-get purge ps3mediaserver). And how your PC is connected to LAN?


It's a wired connection. Yes, you're right that if I restart it after booting then it works fine. However, that's what I'm trying to avoid having to do.

Or perhaps you meant something else? Are you suggesting that I need to change something in order to get it started later? I'll try a reinstall, but can't see that helping because PMS is the last thing I installed anyway.

You can try this setting General Configuration => Force IP of the server: 0.0.0.0
Save and restart PC.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby gauched » Sat Jul 21, 2012 1:23 pm

happy.neko wrote:You can try this setting General Configuration => Force IP of the server: 0.0.0.0
Save and restart PC.


Tried that and it still doesn't work. Here's the log: http://pastebin.com/9fSAq1cr

If I then restart the service (with 0.0.0.0 still in place) everything works fine and here's the log: http://pastebin.com/azrXMHF8

Then I tried changing the IP to my server's (static) IP of 192.168.10.191 and I got no error on startup, but it still didn't appear on my PS3 (even after searching for media servers). Here's the log after a reboot: http://pastebin.com/HPC4RpjS . Again, everything works fine if I then restart the service.

Here's my output from ifconfig:

Code: Select all
administrator@Leo:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:25:22:ab:62:c6 
          inet addr:192.168.10.191  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fe80::225:22ff:feab:62c6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:498 errors:0 dropped:0 overruns:0 frame:0
          TX packets:372 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:51132 (51.1 KB)  TX bytes:62367 (62.3 KB)
          Interrupt:45 Base address:0xc000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:328 (328.0 B)  TX bytes:328 (328.0 B)


Any more ideas?
gauched
 
Posts: 23
Joined: Sat Nov 27, 2010 10:30 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby siXor » Sat Jul 21, 2012 7:58 pm

Hi! I've installed the package and it works perfect, almost.

I can play .mkvs like never before, and all other files as well but I have a subtitle problem: There's NO subtitle. When i tried playing the movie on computer, vlc, I get subtitle but on with ps3 media server they just don't excist. Is there some kind of option where I can turn subtitles on?
siXor
 
Posts: 2
Joined: Sat Jul 21, 2012 7:50 pm

PreviousNext

Return to Linux/Unix Support

Who is online

Users browsing this forum: Google [Bot] and 6 guests