Unsupported Data -- can't play some AVIs and MKVs

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Unsupported Data -- can't play some AVIs and MKVs

Postby shelbydz » Thu Dec 08, 2011 5:14 am

Is this due to an outdated version of ffmpeg? I have several AVIs and MKVs that just refuse to play on my PS3 or 360. The corresponding line I get from the debug.log is:

Code: Select all
[pool-6-thread-1] DEBUG 19:20:10.250 Starting ffmpeg -ss 1 -i "/home/shelbydz/Videos/MST3KRocketship X-M.avi" -an -an -s 320x180 -vframes 1 -f image2 pipe:
[pool-6-thread-2] DEBUG 19:20:10.265 Attaching thread: ffmpeg
[pool-6-thread-2] DEBUG 19:20:10.268 Unix process ID (ffmpeg): 26097
[pool-6-thread-1] DEBUG 19:20:10.291 Attaching thread: ffmpeg
[pool-6-thread-1] DEBUG 19:20:10.291 Unix process ID (ffmpeg): 26104
[Thread-27] DEBUG 19:20:12.673 Stopping Unix process 26082: ffmpeg


I'm running Ubuntu 11.4, 32bit. It's not all AVIs, it's not all MKVs.
the installed ffmpeg version appears to be FFmpeg version 0.6.2-4:0.6.2-1ubuntu1.1. with the following info:
Code: Select all
  libavutil     50.15. 1 / 50.15. 1
  libavcodec    52.72. 2 / 52.72. 2
  libavformat   52.64. 2 / 52.64. 2
  libavdevice   52. 2. 0 / 52. 2. 0
  libavfilter    1.19. 0 /  1.19. 0
  libswscale     0.11. 0 /  0.11. 0
  libpostproc   51. 2. 0 / 51. 2. 0
FFmpeg 0.6.2-4:0.6.2-1ubuntu1.1
libavutil     50.15. 1 / 50.15. 1
libavcodec    52.72. 2 / 52.72. 2
libavformat   52.64. 2 / 52.64. 2
libavdevice   52. 2. 0 / 52. 2. 0
libavfilter    1.19. 0 /  1.19. 0
libswscale     0.11. 0 /  0.11. 0
libpostproc   51. 2. 0 / 51. 2. 0


Maybe my libraries are out of date? Thoughts? It seems the latest v of ffmpeg is 0.8.7, so this is pretty out of date.

thanks!
shelbydz
 
Posts: 1
Joined: Thu Dec 08, 2011 5:03 am

Return to Linux/Unix Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests