PMS on Ubuntu 11.10

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PMS on Ubuntu 11.10

Postby zaphod_trillian » Tue Dec 06, 2011 6:08 am

Hi,
I had PMS 1.30 running on my previous Ubuntu 11.04 install. I have upgraded Ubuntu from 11.10. I was unable to get the trayicon, as well as the GUI to show up. I upgraded PMS to 1.50 since I hoped that would fix the issue. I am still not able to get the GUI as well as the trayIcon to show up.
I checked the web and read suggestions about setting the default-java to sun jdk 1.60. Even after that I was unable to see the GUI. (Although all along I can see the PMS on my Sony Bravia EX700)

Here is my stack trace

java.awt.AWTException: TrayIcon couldn't be displayed.
at sun.awt.X11.XTrayIconPeer.<init>(XTrayIconPeer.java:268)
at sun.awt.X11.XToolkit.createTrayIcon(XToolkit.java:864)
at java.awt.TrayIcon.addNotify(TrayIcon.java:669)
at java.awt.SystemTray.add(SystemTray.java:237)
at net.pms.util.PMSUtil.addSystemTray(PMSUtil.java:73)
at net.pms.newgui.LooksFrame.<init>(LooksFrame.java:290)
at net.pms.PMS.init(PMS.java:362)
at net.pms.PMS.createInstance(PMS.java:914)
at net.pms.PMS.main(PMS.java:1008)


Any help appreciated.
zaphod_trillian
 
Posts: 1
Joined: Tue Dec 06, 2011 6:02 am

Re: PMS on Ubuntu 11.10

Postby boiler91 » Fri Dec 23, 2011 4:27 pm

I am having a very similar problem.

1. I recently aquired a Dell Inspiron 170L with 512 Mb Ram, Celeron 2.8 GHz processor. I am trying to use it as a fileserver/media streaming box.
2. I am trying to stream to my PS3 with PMS 1.5
3. Computer is wired to router, PS3 is wireless
4. I am not transcoding. I have tried the .avi files and they play fine when physically on the PS3
5. When I first ran PMS the GUI popped up and it worked fine except the .avi files I try to play say unsupported data on my PS3. After a restart of Ubuntu I can't open the GUI. I have the most up to date version of Java.

Just FYI, if you can't tell this is about my 4th time using any type of Linux. My first was Yellow Dog on my PS3 so please take it easy on me and speak real slow. Thanks.

Here is the debug log from my home folder

Code: Select all
[main] INFO  10:23:42.769 Starting PS3 Media Server 1.50.0
[main] INFO  10:23:42.787 by shagrath / 2008-2011
[main] INFO  10:23:42.788 http://ps3mediaserver.org
[main] INFO  10:23:42.790 http://code.google.com/p/ps3mediaserver
[main] INFO  10:23:42.798 http://ps3mediaserver.blogspot.com
[main] INFO  10:23:42.799
[main] INFO  10:23:42.800 Java: 1.6.0_23-Sun Microsystems Inc.
[main] INFO  10:23:42.802 OS: Linux i386 3.0.0-14-generic
[main] INFO  10:23:42.803 Encoding: UTF-8
[main] INFO  10:23:42.806 Working directory: /home/matt/pms-linux-1.50.0
[main] INFO  10:23:42.821 Temp folder: /tmp/ps3mediaserver
[main] INFO  10:23:42.823 Logging config file: /home/matt/pms-linux-1.50.0/logback.xml
[main] INFO  10:23:42.831 debug.log: /home/matt/pms-linux-1.50.0/debug.log
[main] INFO  10:23:42.852
[main] INFO  10:23:42.853 Profile directory: /home/matt/.config/PMS
[main] INFO  10:23:42.867 Profile path: /home/matt/.config/PMS/PMS.conf
[main] INFO  10:23:42.868 Profile status: rw
[main] INFO  10:23:42.870 Profile name: FileServer
[main] INFO  10:23:42.878
[main] WARN  10:23:43.269 Error loading libzen: Unable to load library 'zen': libzen.so: cannot open shared object file: No such file or directory
[main] INFO  10:23:43.293 Loading MediaInfo library
[main] INFO  10:23:43.350 Error loading MediaInfo library: Unable to load library 'mediainfo': libmediainfo.so: cannot open shared object file: No such file or directory
[main] INFO  10:23:43.351 Make sure you have libmediainfo and libzen installed
[main] INFO  10:23:43.358 The server will now use the less accurate ffmpeg parsing method
[main] INFO  10:23:43.367 Loading renderer configurations from /home/matt/pms-linux-1.50.0/renderers
[main] INFO  10:23:43.374 Loading configuration file: AirPlayer.conf
[main] INFO  10:23:43.394 Loading configuration file: WDTVLive.conf
[main] INFO  10:23:43.398 Loading configuration file: iPad-iPhone.conf
[main] INFO  10:23:43.409 Loading configuration file: Realtek.conf
[main] INFO  10:23:43.423 Loading configuration file: WMP.conf
[main] INFO  10:23:43.562 Loading configuration file: SamsungWiseLink.conf
[main] INFO  10:23:43.574 Loading configuration file: XBMC.conf
[main] INFO  10:23:43.598 Loading configuration file: Android.conf
[main] INFO  10:23:43.601 Loading configuration file: SamsungAllShare.conf
[main] INFO  10:23:43.612 Loading configuration file: PS3.conf
[main] INFO  10:23:43.623 Loading configuration file: BraviaEX.conf
[main] INFO  10:23:43.639 Loading configuration file: Philips.conf
[main] INFO  10:23:43.649 Loading configuration file: N900.conf
[main] INFO  10:23:43.653 Loading configuration file: Kuro.conf
[main] INFO  10:23:43.663 Loading configuration file: PopcornHour.conf
[main] INFO  10:23:43.668 Loading configuration file: Panasonic.conf
[main] INFO  10:23:43.679 Loading configuration file: XBOX360.conf
[main] INFO  10:23:43.701 Loading configuration file: Showtime3.conf
[main] INFO  10:23:43.713 Loading configuration file: SonyBluray.conf
[main] INFO  10:23:43.717 Loading configuration file: Bravia4500.conf
[main] INFO  10:23:43.733 Loading configuration file: Bravia5500.conf
[main] INFO  10:23:43.762 Loading configuration file: FreecomMusicPal.conf
[main] INFO  10:23:43.775 Loading configuration file: Streamium.conf
[main] INFO  10:23:43.780 Loading configuration file: FreeboxHD.conf
[main] INFO  10:23:43.819 Checking MPlayer font cache. It can take a minute or so.
[main] DEBUG 10:23:43.823 launching: mplayer
[main] ERROR 10:23:43.856 Cannot launch MPlayer / Check the presence of mplayer ...
java.io.IOException: Cannot run program "mplayer": java.io.IOException: error=2, No such file or directory
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:475) ~[na:1.6.0_23]
   at net.pms.PMS.checkProcessExistence(PMS.java:272) [pms.jar:na]
   at net.pms.PMS.init(PMS.java:439) [pms.jar:na]
   at net.pms.PMS.createInstance(PMS.java:914) [pms.jar:na]
   at net.pms.PMS.main(PMS.java:1008) [pms.jar:na]
Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory
   at java.lang.UNIXProcess.<init>(UNIXProcess.java:164) ~[na:1.6.0_23]
   at java.lang.ProcessImpl.start(ProcessImpl.java:81) ~[na:1.6.0_23]
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:468) ~[na:1.6.0_23]
   ... 4 common frames omitted
[main] INFO  10:23:43.878 Done!
[main] INFO  10:23:43.982 Searching for plugins in /home/matt/pms-linux-1.50.0/plugins
[main] INFO  10:23:43.988 No plugins found
[main] INFO  10:23:44.013 Registering transcoding engine: FFmpeg Audio
[main] INFO  10:23:44.053 Registering transcoding engine: MEncoder
[main] INFO  10:23:44.055 Registering transcoding engine: MPlayer Audio
[main] INFO  10:23:44.066 Registering transcoding engine: MEncoder Web
[main] INFO  10:23:44.068 Registering transcoding engine: MPlayer Video Dump
[main] INFO  10:23:44.078 Registering transcoding engine: MPlayer Web
[main] INFO  10:23:44.081 Registering transcoding engine: tsMuxeR
[main] INFO  10:23:44.092 Registering transcoding engine: Audio High Fidelity
[main] INFO  10:23:44.109 Registering transcoding engine: VLC Audio Streaming
[main] INFO  10:23:44.111 Registering transcoding engine: VLC Video Streaming
[main] INFO  10:23:44.126 Registering transcoding engine: Raws Thumbnailer
[main] INFO  10:23:44.705 Scanning network interface eth0 (eth0)
[main] INFO  10:23:44.708 Using address /192.168.0.25 found on network interface: name:eth0 (eth0)
[main] INFO  10:23:44.717 Created socket: /192.168.0.25:5001
[main] DEBUG 10:23:45.695 Sending ALIVE...
[main] INFO  10:23:45.778 Using the following UUID configured in PMS.conf: 1a24a937-3002-3600-9790-f643fac0fcaa
[New I/O server worker #1-1] INFO  10:23:47.852 No IP filter specified, access granted to /192.168.0.24
[New I/O server worker #1-2] INFO  10:23:47.918 No IP filter specified, access granted to /192.168.0.11
[pool-3-thread-1] INFO  10:23:48.003 Checking ip:192.168.0.24 for Popcorn Hour
[pool-3-thread-2] INFO  10:23:48.020 Checking ip:192.168.0.11 for WMP
[pool-3-thread-2] INFO  10:23:48.229 Renderer WMP found on this address: Bonesaw.local (192.168.0.11)
[pool-3-thread-2] DEBUG 10:23:48.386 Starting ping -c 3 -s 64000 192.168.0.11
[pool-3-thread-2] DEBUG 10:23:48.525 Unix process ID (ping): 1752
[New I/O server worker #1-1] INFO  10:23:49.441 No IP filter specified, access granted to /192.168.0.7
[pool-3-thread-3] INFO  10:23:49.502 Checking ip:192.168.0.7 for Playstation 3
[Thread-5] DEBUG 10:23:50.390 Stopping Unix process 1752: ping
[main] INFO  10:23:50.421 The server should now appear on your renderer
[pool-3-thread-2] INFO  10:23:50.432 Address /192.168.0.11 has an estimated network speed of: 60 Mb/s
[pool-3-thread-1] INFO  10:23:53.166 Renderer Popcorn Hour found on this address: 192.168.0.24
[pool-3-thread-1] DEBUG 10:23:53.176 Starting ping -c 3 -s 64000 192.168.0.24
[pool-3-thread-1] DEBUG 10:23:53.188 Unix process ID (ping): 1762
[pool-3-thread-3] INFO  10:23:54.629 Renderer Playstation 3 found on this address: 192.168.0.7
[pool-3-thread-3] DEBUG 10:23:54.631 Starting ping -c 3 -s 64000 192.168.0.7
[pool-3-thread-3] DEBUG 10:23:54.640 Unix process ID (ping): 1768
[Thread-11] DEBUG 10:23:55.177 Stopping Unix process 1762: ping
[pool-3-thread-1] INFO  10:23:55.192 Address /192.168.0.24 has an estimated network speed of: 14 Mb/s
Last edited by Raptor399 on Sat Dec 24, 2011 11:20 pm, edited 1 time in total.
Reason: Edited for code fragments
boiler91
 
Posts: 1
Joined: Fri Dec 23, 2011 3:03 pm

Re: PMS on Ubuntu 11.10

Postby jomom » Fri Jan 06, 2012 3:30 am

same problem here, but I was able to get the initial gui to show up the first time I ran pms.sh
once I minimized, it disappeared

second time nothing
jomom
 
Posts: 6
Joined: Tue Nov 30, 2010 8:37 pm

Re: PMS on Ubuntu 11.10

Postby muzique » Mon Jan 09, 2012 6:49 pm

Hi, I'm a newbie to Linux and am having a similar problem!
Had PmServ 1.23.0 running on ubuntu 11.04 Studio and upgraded to PMS 1.50, it worked fine! On complete reinstall of Ubuntu 11.10 cannot start either PMS 1.23.0 or 1.50.1. Followed all instruction and installed all required software (ffmpeg, mencoder, Sun Java 6 etc) but it will not run at ALL!!!
Please Help!
muzique
 
Posts: 3
Joined: Mon Jan 09, 2012 6:30 pm

Re: PMS on Ubuntu 11.10

Postby muzique » Mon Jan 09, 2012 6:57 pm

Just Run "PMS.jar" with Sun Java 6 Runtime and PMS started?!?!? I don't know why PMS.sh will not run though?

update 1: PS3 cannot open the video files if run this way, says "data type is not supported"!

update 2: After restarting PMS 1.50 (run using Sun Java) it can no longer pick up the PS3!

HELP!!!!

Someone please help!!!!!
Update 3: PMS does not detect PS3 but PS3 picks up PMS!!!!! Playing files using PS3 direct does not work, "data type is not supported", but using Transcode SOME files play!!!!!
muzique
 
Posts: 3
Joined: Mon Jan 09, 2012 6:30 pm

Re: PMS on Ubuntu 11.10

Postby thoren » Tue Jan 10, 2012 11:28 am

as "debug.log" says, you must install "mplayer". Install "ffmpeg" too.
As usual, all is this forum "FAQ" :
viewtopic.php?f=6&t=3507
https://help.ubuntu.com/community/Ps3MediaServer
PMS : 1.40 with only TsMuxer engine enabled
OS/Hardware : Linux Ubuntu 10.04 on a "weak" but very useful "MSI Wind U100" netbook !
thoren
 
Posts: 38
Joined: Fri Sep 30, 2011 4:18 pm

Re: PMS on Ubuntu 11.10

Postby DeWalt68 » Sat Jan 14, 2012 3:51 am

I'm another noobie, same problem, how ever running "PMS.Jar" with sun Java 6 doesn't work, it came up once, then never again. Xbox 360, can see it on the net work, but i cant use the GUI to add my media files,
DeWalt68
 
Posts: 3
Joined: Sat Jan 14, 2012 3:44 am

Re: PMS on Ubuntu 11.10

Postby DeWalt68 » Sun Jan 22, 2012 3:43 am

viewtopic.php?f=3&t=13046&p=63941&hilit=PMS.sh#p63941

download 1.50.1+svn1020 from here,

works like a BOSS.
DeWalt68
 
Posts: 3
Joined: Sat Jan 14, 2012 3:44 am

Re: PMS on Ubuntu 11.10

Postby muzique » Sun Jan 22, 2012 7:26 am

Problem solved!!

I installed Ubuntu 64bit instead of 32bit version, installed all required codecs and players and installed the amd64 version of PMS. Works like a charm!!
muzique
 
Posts: 3
Joined: Mon Jan 09, 2012 6:30 pm

Re: PMS on Ubuntu 11.10

Postby slese » Sat Feb 04, 2012 2:21 am

Just installed PMS on Ubuntu 11.10, Sandy bridge CPU, Laptop.
Installed Cinnamon (Hate Unity)
Works well.
slese
 
Posts: 1
Joined: Sat Feb 04, 2012 2:16 am


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 6 guests