Cannot find libmediainfo / libzen

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Cannot find libmediainfo / libzen

Postby gauched » Sun Nov 20, 2011 10:44 am

Hi,

I get the following error on starting 1.50.0 on a headless Ubuntu 11.10 box:
Code: Select all
[main] WARN  09:36:47.924 Error loading libzen: Unable to load library 'zen': libzen.so: cannot open shared object file: No such file or directory
[main] INFO  09:36:47.924 Loading MediaInfo library
[main] INFO  09:36:47.927 Error loading MediaInfo library: Unable to load library 'mediainfo': libmediainfo.so: cannot open shared object file: No such file or directory
[main] INFO  09:36:47.927 Make sure you have libmediainfo and libzen installed
[main] INFO  09:36:47.927 The server will now use the less accurate ffmpeg parsing method

I've added mediainfo to my software sources:
Code: Select all
deb http://ppa.launchpad.net/shiki/mediainfo/ubuntu oneiric main
deb-src http://ppa.launchpad.net/shiki/mediainfo/ubuntu oneiric main

And I've installed mediainfo:
Code: Select all
sudo apt-get install mediainfo
Reading package lists... Done
Building dependency tree       
Reading state information... Done
mediainfo is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 45 not upgraded.

If I attempt to install either libzen or libmediainfo explicitly I get an error:
Code: Select all
sudo apt-get install libzen
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libzen

If I attempt to find libzen or libmediainfo I can see that it's there:
Code: Select all
sudo find / -name libzen*
/usr/share/doc/libzen0
/usr/lib/libzen.so.0.0.0
/usr/lib/libzen.so.0
/var/lib/dpkg/info/libzen0.md5sums
/var/lib/dpkg/info/libzen0.list
/var/lib/dpkg/info/libzen0.shlibs
/var/lib/dpkg/info/libzen0.postinst
/var/lib/dpkg/info/libzen0.postrm
/var/cache/apt/archives/libzen0_0.4.20-1~ppa1~natty1_amd64.deb
/var/cache/apt/archives/libzen0_0.4.22-1ubuntu1_amd64.deb

Does anyone know how I can fix this issue?
gauched
 
Posts: 23
Joined: Sat Nov 27, 2010 10:30 pm

Re: Cannot find libmediainfo / libzen

Postby gauched » Sun Nov 20, 2011 10:51 am

Aaagh! Sorry, I somehow missed this post: viewtopic.php?f=3&t=12003

Basically, had to sym link the libraries so that PMS can find them. Not sure why but I don't know linux...anyway it works for me now.
gauched
 
Posts: 23
Joined: Sat Nov 27, 2010 10:30 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: Google [Bot] and 9 guests