Possible bug: negative buffer when transcoding with 1.10.5

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Possible bug: negative buffer when transcoding with 1.10.5

Postby Drag0nFly » Sun Mar 15, 2009 5:07 pm

I am experiencing a very weird problem after upgrading to 1.10.5 (from 10.4). All other versions of PMS have worked flawlessly. (No other component of the system has been changed.)

Debug output follows at the end of this message.


My config:
==========

32-bit Ubuntu Interpid Ibex (2.6.27-11-generic), 2x Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz, ~3Gb memory, 100Mbit wired connection to PS3

MEncoder SVN-r28403-4.3.2 (C) 2000-2009 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz (Family: 6, Model: 15, Stepping: 6)

FFmpeg version r11872+debian_3:0.svn20080206-12ubuntu3, Copyright (c) 2000-2008 Fabrice Bellard, et al.
configuration: --enable-gpl --enable-pp --enable-swscaler --enable-x11grab --prefix=/usr --enable-libgsm --enable-libtheora --enable-libvorbis --enable-pthreads --disable-strip --enable-libfaad --enable-libfaadbin --enable-liba52 --enable-liba52bin --enable-libdc1394 --disable-armv5te --disable-armv6 --disable-altivec --disable-vis --enable-shared --disable-static
libavutil version: 49.6.0
libavcodec version: 51.50.0
libavformat version: 52.7.0
libavdevice version: 52.0.0
built on Oct 3 2008 22:40:31, gcc: 4.3.2

java version "1.6.0_10"
Java(TM) SE Runtime Environment (build 1.6.0_10-b33)
Java HotSpot(TM) Server VM (build 11.0-b15, mixed mode)


Fault description:
================

Very often when attempting to send a mencoder-transcoded stream (over 50% of the time), the stream "halts"; i.e nothing is output on the PS3 and the PS3 Media Server GUI reports negative buffer status. Stopping and restarting the stream does not clear up the process.

Excerpt from debug.log (complete output is attached)--

[...]
[Thread-408] DEBUG 16:13:27.524 AINIT: 0.200
[Thread-408] DEBUG 16:13:27.557 AINIT: 0.200
[Thread-408] DEBUG 16:13:27.595 AINIT: 0.200
[Timer-28] DEBUG 16:13:27.632 Buffered Space: -63488 bytes / inputs: 1
[Thread-408] DEBUG 16:13:27.633 AINIT: 0.200
[Thread-408] DEBUG 16:13:27.668 AINIT: 0.200
[Thread-408] DEBUG 16:13:27.703 AINIT: 0.200
[...]
[Thread-408] DEBUG 16:13:32.174 AINIT: 0.200
[Thread-408] DEBUG 16:13:32.216 AINIT: 0.200
[Thread-408] DEBUG 16:13:32.261 AINIT: 0.200
[Thread-411] DEBUG 16:13:32.283 Resume Read: readCount=65536 / writeCount=2048
[Thread-411] DEBUG 16:13:32.283 Suspend Read: readCount=98304 / writeCount=2048
[Thread-408] DEBUG 16:13:32.304 AINIT: 0.200
[Thread-408] DEBUG 16:13:32.347 AINIT: 0.200
[Thread-408] DEBUG 16:13:32.390 AINIT: 0.200
[...]
[Thread-408] DEBUG 16:13:33.567 AINIT: 0.200
[Thread-408] DEBUG 16:13:33.614 AINIT: 0.200
[Timer-28] DEBUG 16:13:33.632 Buffered Space: -96256 bytes / inputs: 1
[Thread-408] DEBUG 16:13:33.662 AINIT: 0.200
[Thread-408] DEBUG 16:13:33.707 AINIT: 0.200


I am providing two complete debug.log files attached to this message--debug.log.1.04 (working) & debug.log-1.10.5 (not working)
The config is also included (same config for 1.04 as for 1.10.5. Also tested with blank config on 1.10.5)

btw. -- the only modification I have done to the install is to symlink 'ffmpeg' from each of the two PMS directories, as it complains about not finding it (despite being in the $PATH)
Attachments
config.zip
PMS.conf
(414 Bytes) Downloaded 70 times
debug.zip
debug.log-1.04.txt - working
debug.log-1.10.5.txt - not working
(59.01 KiB) Downloaded 56 times
Drag0nFly
 
Posts: 11
Joined: Thu Feb 12, 2009 6:59 pm

Re: Possible bug: negative buffer when transcoding with 1.10.5

Postby shagrath » Sun Mar 15, 2009 5:36 pm

remove the -speed 1.042709376 -ofps 25 in expert settings, it's not working quite well
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: Possible bug: negative buffer when transcoding with 1.10.5

Postby Drag0nFly » Sun Mar 15, 2009 5:51 pm

Thought I already tried that--but I now see it manages to play well without doing 3:2 pulldown...
However, this was the only reason for transcoding these types of files (to get rid of the damn 24p judder!) :)
The PS3 plays these natively, but as we all know it doesn't have an option to disable 24p for DivX media; making these files basically unwatchable.

Hope this option will be functioning again soon. Anyway thanks for providing a really awesome program.
Drag0nFly
 
Posts: 11
Joined: Thu Feb 12, 2009 6:59 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 6 guests