PMS server not visible

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PMS server not visible

Postby eldrad95 » Mon Jul 25, 2011 7:43 pm

Hi,

I have installed pms on linux ubuntu server (no gui). I open on ufw 5001 port and force this port on pms.
I test to view the server on a windows 7, ubuntu desktop (using UPnP inspector), xbox 360 and sharp TV without success, the pms server still not visible.
the service is started.

my config file :

folders = \/mnt\/donnees\/Medias
hostname = Hestia
port = 5001
language =
thumbnails = true
thumbnail_seek_pos = 1
nbcores = 2
turbomode = false
minimized = false
hidevideosettings = false
usecache = false
charsetencoding = 850
engines = mencoder,avsmencoder,tsmuxer,mplayeraudio,ffmpegaudio,tsmuxeraudio,vlcvideo,mencoderwebvideo,mplayervideodump,mplayerwebaudio,vlcaudio,ffmpegdvrmsremux
autoloadsrt = true
avisynth_convertfps = true
avisynth_script = #AviSynth script is now fully customisable !\u0001#You must use the following variables (\"clip\" being the avisynth variable of the movie):\u0001#<movie>: insert the complete DirectShowSource instruction [ clip=DirectShowSource(movie, convertfps) ]\u0001#<sub>: insert the complete TextSub\/VobSub instruction if there's any detected srt\/sub\/idx\/ass subtitle file\u0001#<moviefilename>: variable of the movie filename, if you want to do all this by yourself\u0001#Be careful, the custom script MUST return the clip object\u0001<movie>\u0001<sub>\u0001return clip
transcode_block_multiple_connections = false
tsmuxer_forcefps = true
tsmuxer_preremux_pcm = false
tsmuxer_preremux_ac3 = false
audiochannels = 6
audiobitrate = 384
maximumbitrate = 0
skiploopfilter = false
enable_archive_browsing = false
mencoder_fontconfig = false
mencoder_font =
mencoder_forcefps = false
mencoder_usepcm = false
mencoder_intelligent_sync = true
mencoder_decode =
mencoder_encode = keyint=5:vqscale=1:vqmin=2
mencoder_vobsub_subtitle_quality = 3
mencoder_overscan_compensation_width = 0
mencoder_overscan_compensation_height = 0
mencoder_nooutofsync = true
mencoder_audiolangs = fre,jpn,ger,eng
mencoder_sublangs = fre,eng
mencoder_audiosublangs =
mencoder_subfribidi = false
mencoder_ass_scale = 1.0
mencoder_ass_margin = 10
mencoder_ass_outline = 1
mencoder_ass_shadow = 1
mencoder_noass_scale = 3
mencoder_noass_subpos = 2
mencoder_noass_blur = 1
mencoder_noass_outline = 1
mencoder_subcp = cp1252
mencoder_ass = true
mencoder_disablesubs = false
mencoder_yadif = false
mencoder_scaler = false
mencoder_scalex = 0
mencoder_scaley = 0
ffmpeg = -g 1 -qscale 1 -qmin 2


Anybody see where is the problem ?
eldrad95
 
Posts: 1
Joined: Mon Jul 25, 2011 7:36 pm

Re: PMS server not visible

Postby Dynalon » Mon Aug 08, 2011 10:15 pm

at first it always helps to see if the port is really open. On another unix/linux box from within the network, try a portscan to see if the port is open, i.e. use nmap:
Code: Select all
nmap -p 5001 192.168.1.10


where 192.168.1.10 should be replaced by the IP of the ps3ms server. If the port is open from the outside, thats ok, if its filtered or closed something is wrong with the network/firewall setup of the ubuntu server with ps3ms. If the port is open there are still other possibilites which you can check (google might help):

-your ubuntu ps3ms box filters any broadcast or multicast packets => check firewall settings and sysctl values
-your network router / hub / switch supresses certain broadcast, or broadcasts are not forwarded between wired and wireless networks (had this problem on a linksys / cisco WiFi router)
Dynalon
 
Posts: 2
Joined: Thu Jul 28, 2011 5:30 pm

Re: PMS server not visible

Postby Schorschi » Mon Nov 28, 2011 10:52 pm

I have a Sharp TV (80 inch, Quad)... And two separate instances of PMS... one Windows based, one Linux based...

My Windows based version of PMS is seen, but when I walk down the directories, sub folders are shown, but unless file type is AVI and only AVI, so transcoding issue apparently. Any files with MKV extension no shown. Windows XBMC as a client does not have this issue.

Linux based PMS, Sharp DLNA inconsistently sees Linux PMS instance, if I leave the DLNA web application up for a few minutes, the PMS Linux instance may appear, once it does, everything seems to work fine. MKV files for example play as expected. But sometimes the Sharp DLNA discovery just does not see the Linux instance as consistently as the Windows based instance.

Eitherway Windows or Linux based PMS, SSDP is a slow discovery process, usually you need to let 3 or 4 minutes pass before (new) DLNA services appear.
Schorschi
 
Posts: 11
Joined: Mon Nov 28, 2011 10:29 pm

Re: PMS server not visible

Postby Schorschi » Sun Dec 11, 2011 10:11 pm

Well, I for the most part have everything working. PMS on Fedora 15 works, but I was not convinced Fedora 15 is where I wanted to be, so I setup CentOS 6.1, and got PMS working on it as well. Of course I have PMS running on Windows 2008 R2 SP1 as well. If anyone wanted more details on setup on Fedora 15 or CentOS 6.1, if sufficient interest, I may document my steps, but truth be told, just reading the forums, provided all the details I needed. I have decades of IT experience with Windows, and about a decade of serious experience with Linux, not to mention other OSes, including Apple, cough. But all my Apple experience is dated, I have not touched a Macintosh as a developer or end-user in at least 6 years. I retired my poor old MacIIx that ran MacOS 7.5 to the great binary grave yard years ago. But I digress...

Getting back on topic... the interesting thing is, the Sharp TV always consistently finds the Windows based version of PMS, in a fraction of a second, but the Fedora 15 and CentOS 6.1 variants I have to let the DLNA ciient in the TV discover them. No amount of rescanning by explicitly telling the TV to scan for new PMS instances seems to get either Linux based instance discovered any faster. The only customization I have done to PMS.jar at this point is to add a sharp.png file to the client resources folder, so my sharp TV has a nice picture in the PMS GUI.

The only gripes I have are part PMS related, and part Sharp TV related. The Sharp TV only has a 100mb Ethernet port. That sucks. A 1gb port would have been much better. On the PMS side, I when transcoding 720p based video stutters off and on, yes I have tried every trick noted in the forums, and nothing seems to help, in fact about every 7 minutes, the playback just freezes and I have to pause and resume via the TV DLNA interface for continued playback. I am not sure why PMS by design does not support a more flexible pre-caching configuration when transcoding? Would seem very obvious this would improve things, nor does it make sense that the transcode meter never seems to show exhaustion of the buffer when the stutter happens, so I guess the 100mb port issue maybe at heart of the problem. Don't even ask me about 1080p... I can't get anything transcoded that is 1080p to work even relatively ok, never mind, well enough to enjoy playback. To be fair to PMS... I am not running PMS on kick-ass hardware... all 3 of my PMS servers are on simple single core 3.0Ghz Pentium based systems, which have a lot of memory (3GB), but no CPU muscle to speak of. I have an older dual-core laptop that has 2 i5 2.2 Ghz cores, that I plan to put PMS on, to see if that helps the TV based DLNA stutter, so I will update this thread once I try that in the near future. I also have an Xbox360 I have yet to test with, so if that stutters as well. It may also be that my 1Gb network (which is likely busier than the average end-user) maybe part of the issue.

At the moment I have iptables disabled on the Fedora/CentOS instances, only because I have been lazy in updating the rules set. Also, I limit the PMS traffic to a specific IP/interface, and use a port # not already assigned in /etc/services. The default of 5001 is already defined... someone should change this in the PMS code base. Last, if the given Linux instance is multihomed (which all my PMS instances are, Linux and Windows) and each interface has its own name, and routing rules... for example in DNS, IP address 192.168.1.10 is 'Me', and 192.168.1.11 is 'You'... PMS always uses the name of the first IP address found on the Linux instance, even if, PMS is bound to a specific IP... this just bad form, the name should match the DNS registration for the given IP. The Windows based variant of PMS does not behave this way! Go figure, Windows variant always finds the right name for the IP bound to the PMS service.

Below is my renderer file, it is based on past forum entry information, so I am not sure it is 100% right, it works, but it could be or should be vetted. Also below is the pms script I use to run PMS headless. It is also based on information in the forums. Both the renderer file and script are provided as-is. I have no plans to support either for any use other than my own. That said, if anyone has any feedback, feel free to comment in this thread. But, everyone, if you don't like either, then don't use them, and don't waste any time bitching about what works or does not work in either, they are for educational use, illustrative of what worked for me. Plain and simple, nothing more.

By the way... my installation of PMS is off of /opt/pms, and the version information is part of the absolute path, this was done to allow me to archive older versions of PMS if desired, with just a simple change to the /etc/init.d/pms script when applicable.

My /etc/init.d/pms script...

Code: Select all
#!/bin/sh
#
#  chkconfig: - 91 50
#  description: Starts and stops the ps3mediaserver
#  pidfile: /usr/local/PMS/PMS.pid
#  config: /usr/local/PMS/PMS.conf
#

if [ -f /etc/init.d/functions ]; then
   . /etc/init.d/functions
elif [ -f /etc/rc.d/init.d/functions ]; then
   . /etc/rc.d/init.d/functions
else
   exit 1
fi


# Avoid using root's TMPDIR
unset TMPDIR

if [ -f /etc/sysconfig/network ] ; then
   . /etc/sysconfig/network
   [ ${NETWORKING} = "no" ] && exit 1
fi

VERSION='pms-linux-1.50.0'

SERVICE_NAME='pms'
PMS_DIR="/opt/${SERVICE_NAME}/${VERSION}/"
PROG_FILE='PMS.sh'
PROC_NAME="${SERVICE}.jar"
CONFIG_FILE='/root/.config/PMS/PMS.conf'
LOG_FILE=/var/log/PMS.log
PID_FILE="/opt/${SERVICE_NAME}/${VERSION}/PMS.pid"
LOCK_FILE='/var/lock/subsys/PMS'
RETVAL=0

start() {
   if [ ! -f $PID_FILE ]; then
      echo -n $"Starting $SERVICE_NAME: "
      cd $PMS_DIR
      daemon "$PMS_DIR/$PROG_FILE 2>1 > $LOG_FILE &"
   else
      rhstatus
   fi

   RETVAL=$?
   [ $RETVAL -eq 0 ] && touch $LOCK_FILE && echo `ps x o pid,args|grep $PROC_NAME|grep -v grep|awk {'print $1'}` > $PID_FILE || RETVAL=1
   echo

   return $RETVAL
}

stop() {
   if [ -f $PID_FILE ]; then
      echo -n $"Stopping $SERVICE_NAME: "
      killproc -p $PID_FILE
   else
      rhstatus
   fi

   RETVAL=$?
   [ $RETVAL -eq 0 ] && rm -f $PID_FILE && rm -f $LOCK_FILE
   echo

   return $RETVAL
}

restart() {
   stop
   start
}

rhstatus() {
   status -p $PID_FILE $SERVICE_NAME
   return $?
}

case "$1" in
   start)
      start
      ;;
   stop)
      stop
      ;;
   restart)
      restart
      ;;
   status)
      rhstatus
      ;;
   *)
      echo $"Usage: $0 {start|stop|restart|status}"
      $RETVAL = 3
esac

exit $RETVAL


My sharp.conf file...

Code: Select all
RendererName = Sharp Aquos LED Television
RendererIcon = sharp.png
UserAgentSearch = SHARP
UserAgentAdditionalHeader = X-AV-Client-Info
UserAgentAdditionalHeaderSearch = AQUOS
Video = true
Audio = true
Image = true
SeekByTime = true
DLNALocalizationRequired = true
CreateDLNATreeFaster = true
TranscodeVideo = MPEGAC3
TranscodeAudio = MP3
DefaultVBVBufSize = false
MuxH264ToMpegTS = true
MuxDTSToMpeg = false
WrapDTSIntoPCM = false
MuxLPCMToMpeg = false
MaxVideoBitrateMbps = 0
MaxVideoWidth = 1920
MaxVideoHeight = 1080
H264Level41Limited = true
TranscodeAudioTo441kHz = false
TranscodeFastStart = false
TranscodedVideoFileSize = -1
MimeTypesChanges=audio/wav=audio/L16|video/mp4=video/mpeg
ForceJPGThumbnails = false
MediaInfo=false
ChunkedTransfer = false
AutoExifRotate = true
TranscodeExtensions=dvr-ms,dvr,mkv,dv,ty,mov,ogm,hdmov,hdm,rmv,rmvb,rm,asf,evo,asx,flv,m2v,mpe,mod,tivo,ty,tmf,ts,tp,m2p,mp4,m4v,avi,wmv,wm,divx,div,flac,mlp,fla,wma,m4a,aac,dts,mka,ape,ogg,shn,mpc,ra,mp2,wv,oma,aa3,gif,png,arw,cr2,crw,dng,raf,mrw,nef,pef,tif,tiff
StreamExtensions=
Supported = f:mpegps|mpegts  v:mpeg2|mp4|h264         a:ac3|lpcm|aac|mpa  m:video/mpeg
Supported = f:mp3 m:audio/mpeg
Supported = f:wav m:audio/L16
Supported = f:jpg m:image/jpeg


Last, to those that have documented hints, clues, and working implements in the forums, of which I have shamelessly drawn insight, benefit, or outright copied, to create my above configuration file and script, I wish to express my thanks. Without the information 10s if not 100s of people provided, installing, configuring, and using PMS via this forum, would have been much harder.
Last edited by Raptor399 on Sun Dec 11, 2011 11:12 pm, edited 1 time in total.
Reason: Edited for code fragments
Schorschi
 
Posts: 11
Joined: Mon Nov 28, 2011 10:29 pm

Re: PMS server not visible

Postby Raptor399 » Sun Dec 11, 2011 11:14 pm

Thanks for sharing, Schorschi! :-)
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PMS server not visible

Postby Schorschi » Wed Dec 14, 2011 7:43 am

Well, I am not done yet! I still am working on the right combination of iptables rules for my Linux box, I really want to lock the thing down, before I let anyone in the house use it. And, I still am trying to track down why I have some playback chop/stutter/freezes on devices with 100mb NICs (Xbox360, and TV). Using XBMC as a client on a smaller PC with a 1gb NIC, playback is wonderful, even at 720p... 1080p is beyond what the small PC can handle. Updates to follow. By the way, I dropped using Fedora 15, and am now using CentOS 6.1. Fedora over the last couple of years, is just having to many issues, at least based on my experience, so using CentOS which a bit less closer to the edge should be a rock, once I get everything tuned. If anyone is interested, I have notes on CentOS i386 and x86_64 variants. Has anyone tried to run PMS in virtual machines, say KVM or otherwise? Should work, as long as the virtualization of the network with its inherent latency is not to bad.
Schorschi
 
Posts: 11
Joined: Mon Nov 28, 2011 10:29 pm

Re: PMS server not visible

Postby gladiator » Fri Dec 23, 2011 3:59 pm

Hey,

I'm trying to run PMS on an OpenVZ (debian) container - and no luck so far, i think due to incorrect iptables rules -> more info can be found here:
viewtopic.php?f=3&t=10013
I would also appreciate any help. Thanks!
gladiator
 
Posts: 6
Joined: Tue Feb 22, 2011 3:04 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 1 guest