Files with accented chars not displayed: Bravia KDL-32EX5

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Files with accented chars not displayed: Bravia KDL-32EX5

Postby Milan1992 » Wed Jun 08, 2011 9:51 am

Sorry but my English isn't so well:)

So, I was trying to find informations about my problem, but is can't find it on the forum so I thinkd I will open a new topic for it. My problem is that PMS don't show the files in the file list on my Sony BRAVIA KDL-32EX500 (maybe it can be important) which files's names include accent charactes for example: áéíóöúü. Is it possible to fix it or will it be fixed in any future release?

I hope somebody can help for me to fix my problems and compleate my ideas:) I will watch this topic always to get information!


Info:
Server is runing behind double router 1 (belkin 54g) which connect to the web and 1 (tplink TL-R460) which is only share the net connection as a switch. So The belkin54g rooting the net, DHCP is runing on it.
The revicers are 2 TV: Sony BRAVIA KDL-32EX500
Server use Ubuntu server 10.10 32bit version and connect to the LAN with a 100mbit Realtek Lan card which is integrated to the mainboard.
Ram: 1GB DDR1
VGA: not important (no GUI)
CPU: AMD Atom 2,0Ghz (single core)

PMS version:1.21.1

mplayer, mencoder are installed on the system

Here is my PMS.conf:
Code: Select all
thumbnail_seek_pos = 30
thumbnails = true
use_mplayer_for_video_thumbs = true
mencoder_ass = true
mencoder_nooutofsync = false
mencoder_mux_compatible = true
mencoder_audiosublangs = en,off;eng,off
mencoder_disablesubs = true
mencoder_encode = keyint=1:vqscale=1:vqmin=2
mencoder_forcefps = false
mencoder_usepcm = false
mencoder_remux_ac3 = true
folders = /home/szerver/film
autoloadsrt = false
notranscode = avi,mp3,m2ts,ts
tsmuxer_forcefps = false
embed_dts_in_pcm = true
chapter_support = true
fix_25fps_av_mismatch = false
skiploopfilter = false
hide_transcode_folder = true
hidevideosettings = true
hide_extensions = true
hide_enginenames = true
Last edited by Milan1992 on Wed Jun 08, 2011 4:35 pm, edited 3 times in total.
Milan1992
 
Posts: 5
Joined: Wed Jun 08, 2011 9:30 am


Re: Files with accented chars not displayed: Bravia KDL-32EX

Postby Milan1992 » Fri Jun 10, 2011 4:59 pm

I have updated the PMS to the last version 1.23 but it can't show the files wich filess name's include é,á,ó... So It display Hazinyuszi.avi but cant display Háznyuszi.avi which would be correct in hungary.
Ha véletlen valaki magyar is olvasná akkor leírom magyarul is, hátha segít:) A legújabb verzió van az 1.23-as, de nem jeleníti meg ez se azokat a fileokat aminek a neve ékezetes karaktert tartalmaz Hazinyuszi.avi látszik Házinyuszi.avi nem. a prblémát UTF-8 ISO összeférhetetlenségre -> rosszul kódolt filenévre vezettük vissza a linuxgurukkal találgatás útján:S

It can be problem if the file name is in ISO and not in UTF-8 or it is not important? If it is improtant which format i need? Thx for reply for my 1st post, and sorry for the shutdown question, but i cant find the file name problem in your posted links:(
Milan1992
 
Posts: 5
Joined: Wed Jun 08, 2011 9:30 am

Re: Files with accented chars not displayed: Bravia KDL-32EX

Postby chocolateboy » Fri Jun 10, 2011 7:46 pm

viewtopic.php?f=3&t=9205&p=45618#p45618 (bottom post)

e.g.

Code: Select all
LANG=hu_HU
export LANG


or:

Code: Select all
LANG=hu_HU.ISO-8859-2
export LANG


or:

Code: Select all
LANG=hu_HU.UTF-8
export LANG


https://help.ubuntu.com/community/Locale
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Files with accented chars not displayed: Bravia KDL-32EX

Postby Milan1992 » Sat Jun 11, 2011 9:33 am

Oh Thx. I hope it will help;-)

Thx, it work:) Example to past it:
Code: Select all
#!/bin/sh

LANG=hu_HU.UTF-8
export LANG


DIRNAME=`dirname $0`

# OS specific support (must be 'true' or 'false').
...
Milan1992
 
Posts: 5
Joined: Wed Jun 08, 2011 9:30 am


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 9 guests