PS3 Media Server v1.09.1 BETA

General discussion about PS3 Media Server (no support or requests)

Re: PS3 Media Server v1.09.1 BETA

Postby shagrath » Sat Feb 21, 2009 10:44 pm

alexis2044 wrote:Installed, tried playing a movie (withouth changing a single setting) and it freezes at random points - just freezes and doesnt move on. Restarting the movie from the ps3 will make it play again, only to freeze in 5-10 minutes. I get errors on the server that Mencoder has stopped working when this happens. This all on a vista x64 system..


I need the debug.log file please
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PS3 Media Server v1.09.1 BETA

Postby Topguy » Sat Feb 21, 2009 11:24 pm

The DTS feature is really nice... when tsMuxer works anyway.

The build I'm using is r289 from SVN, compiled with ant on Linux, but copied to and ran on Windows XP.

Both the files tested in this debug.log had problems yesterday but it seems like you fixed a null-pointer exeption so now only one fails (the Animatrix file). I get the "tsMuxeR.exe has encountered a problem and needs to close. We are sorry for the inconvenience." requester everytime it fail.

Its a shame that TsMuxer is so unstable for some files. It makes it difficult to decide to have the "Keep DTS audio" enabled since it fails on many of my files. The DTS feature should definitly get a item in #Video-Settings#

The merging of mencoder and Tsmuxer as transcoding engines is in a very confusing state at the moment since sometimes it will use both when I choose only "mencoder" and I even managed to get mencoder when I chose [TsMuxer] under #Transcoding# with some settings.
Attachments
debug_and_conf.rar
(35.13 KiB) Downloaded 93 times
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: PS3 Media Server v1.09.1 BETA

Postby Redlum » Sun Feb 22, 2009 3:03 am

Same build for OSX: http://files.exonet.nl/ps3/PMS-1.09.1-beta.zip (just zipped, no dmg)
Redlum
Project Member
 
Posts: 371
Joined: Mon Jan 12, 2009 9:13 pm

Re: PS3 Media Server v1.09.1 BETA

Postby wjharing » Sun Feb 22, 2009 9:25 am

Hi, i noticed v1.09 is now only broadcasting ALIVE every 3 minutes, whereas 1.03/1.04 did this a lot more frequently. As a result I now don't see PSMS appearing straight away on the PS3 the moment I switch it on, and have to rescan for media server a couple of times. That is my only annoyance with 1.09.

Would it be possible to increase frequency of the ALIVE broadcasting again (or make it an option for users to set). (ps in my opinion, the ALIVE broadcating messages should be removed from the status window as well, as an option.

Wouter
wjharing
 
Posts: 30
Joined: Sat Jan 31, 2009 11:01 am

Re: PS3 Media Server v1.09.1 BETA

Postby Mozze » Sun Feb 22, 2009 10:34 am

Streaming support for DTS / DTS-HD core (DVD ISOs not supported yet)

ISO-streaming does not work at all for any of my rips. I have a couple of "Shaun the Sheep" ISO's that is played every weekend for my little girl. After upgrading to the BETA I only get still images. All titles are also listed twice when I enter the ISO-folder via XMB.

The file Stargate.The.Ark.Of.Truth.2008.720p.BluRay.x264-CiNEFiLE.mkv has been a pain in the **. It just wont play unless I mkv2vob it first. PMS transcodes like a madman and if I pause it filles the buffer, but no sound or video when pressing play again. The buffer empties. The stats for the file is.
Video.......: x264 @ 4630 kbps
Audio.......: English 5.1 DTS 1509kbit/s
Subtitles...: English
Length......: 111 min 51 sec
Size........: 4.37 gigs

Only msg from the trace is:
Thread-150] TRACE 18:26:43.515 Starting transcode/remux of Stargate.The.Ark.Of.Truth.2008.720p.BluRay.x264-CiNEFiLE.mkv
no errormsg what so ever, but it wont play.

On the other hand, this application rocks! Every person I know with a PS3 is now using PMS, and we love it :)
AMD PHENOM X4 2.8GHz - 8,0GB RAM - GA-MA790FXT-UD5P - GbLAN
Mozze
 
Posts: 17
Joined: Sat Feb 07, 2009 1:30 pm

Re: PS3 Media Server v1.09.1 BETA

Postby shagrath » Sun Feb 22, 2009 12:05 pm

Topguy wrote:The DTS feature is really nice... when tsMuxer works anyway.


no the error is from me, not from tsMuxer... it seems I picked the wrong audio track (ac3) and try to parse it as a DTS track, hence the errors...
but I need to dig a little more in the log to confirm (it becomes a little complicated :p)

about the other problems (dvd iso for example), I know the beta / current revision is a little instable for now, but it's the price to pay to have a good product with great new features :)

I posted the beta without really tested anything other than DTS/MKV/TS/MOV whatever muxer

stay tuned :)
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PS3 Media Server v1.09.1 BETA

Postby omel » Sun Feb 22, 2009 12:10 pm

Problems withl mkv playback with 1.09

I have Installed, and tried playing a movie and it freezes at random points - just freezes and doesnt move on. it happens to times for me yesterday and i give up trying to see the movie

back to the 1.04.... damn.. I like the DTS feature

back to the drawing room :roll:
omel
 
Posts: 37
Joined: Mon Jan 19, 2009 1:52 pm

Re: PS3 Media Server v1.09.1 BETA

Postby shagrath » Sun Feb 22, 2009 12:13 pm

I need the debug.log !! otherwise you will never get the DTS feature :)

I posted the beta for people to help, not just complain it's not working
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PS3 Media Server v1.09.1 BETA

Postby Mozze » Sun Feb 22, 2009 2:18 pm

shagrath wrote:I need the debug.log !! otherwise you will never get the DTS feature :)

Point taken, log is enclosed ;)

Her is what I did:
- Tried to play "Shaun_the_Sheep.ISO" (that have been working on previous builds), but all I get is a still image.
- Played Stargate.-snip-.mpg (been trough mkv2vob) and DTS is playing fine!
- Tried to play Stargate.-snip-.mkv but get no picture nor sound.
- Streamed WALL-E.-snip-.mkv and it plays fine, BUT with AC3 5.1 sound..
Attachments
debug.rar
(47.42 KiB) Downloaded 78 times
Last edited by Mozze on Sun Feb 22, 2009 6:11 pm, edited 1 time in total.
AMD PHENOM X4 2.8GHz - 8,0GB RAM - GA-MA790FXT-UD5P - GbLAN
Mozze
 
Posts: 17
Joined: Sat Feb 07, 2009 1:30 pm

Re: PS3 Media Server v1.09.1 BETA

Postby ExSport » Sun Feb 22, 2009 2:29 pm

Please delete exact names of movies or do you want to close this forum?
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

PreviousNext

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 7 guests