Samsung AllShare uPnP/DLNA

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Re: Samsung AllShare uPnP/DLNA

Postby kta66 » Tue Mar 05, 2013 8:36 pm

Hi!

I don't know if you have experienced the same issue as I, but basically when trying to play a transcoded file the TV would display a black screen for some 30 seconds and then exit. After some debugging and testing various options, I finally found an option to set in SamsungAllShare.conf that fixed my issue: "ChunkedTransfer=true"

I tried this on PMS 1.72.0, and I have a Samsung UE46ES5505.

Here is my full SamsungAllShare.conf:
Code: Select all
RendererName=Samsung AllShare
RendererIcon=samsung.png
UserAgentSearch=SEC_HHP_
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(\w{3}_\w{3}_\w{2}-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_\w{2}-\w{2}\d{2}\w\d{3}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{3}/\d.\d)
Video=true
Audio=true
Image=true
TranscodeVideo=MPEGPSAC3
TranscodeAudio=LPCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=true
WrapDTSIntoPCM=false
MuxLPCMToMpeg=true
MaxVideoBitrateMbps=25
MaxVideoWidth=0
MaxVideoHeight=0
MimeTypesChanges=audio/wav=audio/L16|video/x-matroska=video/avi|video/x-flv=video/mp4|audio/mp3=audio/L16|video/mp4=video/mpeg
TranscodeExtensions=flv,wav
StreamExtensions=mkv,mp3,mp4,avi,mov
SubtitleHttpHeader=CaptionInfo.sec
ForceJPGThumbnails=true
MediaInfo=false
ChunkedTransfer=true
SeekByTime=false


Also, it appears that AllShare can play wmv-3 files, but not wmv-1 or wmv-2. Don't know how to explicitly allow streaming of wmv-3 but transcoding of the other formats. Any pointers would be appreciated.


Cheers!
/kta
kta66
 
Posts: 1
Joined: Tue Mar 05, 2013 8:20 pm

Re: Samsung AllShare uPnP/DLNA

Postby dmitche3 » Fri Mar 08, 2013 2:27 am

Thank you. Nice going. I'm still receiving a message using mencoder that "The file may not play properly" but it does play the video.

I should have thought of this as the the Samsung TVs (and others) open and close the connection after receiving X blocks of data. I noticed that while capturing packets to resolve the thumbnails not working.

BTW for others trying this. I had troubles just adding the one line. I didn't spend time to compare my entire .conf file but when I copied your entire file contents it did work. It might just be that I had a few too many changes to the standard 'allshare.conf' file. :)

Once I get through my medical emergencies I hope to look into this why the warning and what it is really trying to tell the user.
dmitche3
 
Posts: 30
Joined: Mon Jan 21, 2013 11:55 pm

Re: Samsung AllShare uPnP/DLNA

Postby 520025 » Sun Mar 10, 2013 5:19 pm

Hello, everyone

I have already used PMS for several months, it works perfect for me.

I am using Ubuntu server 12.04 + GUI, and PMS 1.71 to stream video (most MKV) to my samsung ES6710 TV.

It works very nice. However there was one thing bother me very much. The external subtitles sometimes work, sometime do not work at all even the video title showed as .....{external subtitles}. It is noted that both of the MKV do not show any subtitles when using xbmc other player or direct play on samsung tv from USB memory.

So I carefully compared the these two kinds of MKV by MKVToolnix, and found out something interesting. If the MKV file only contains video and audio in it, the external subtitles will work. If the MKV file contain video, audio and subtitle in it(the subtitle seems empty, do not show subtitle by xbmc or other player) , the external subtitles will not work.
Then I deleted those empty subtitles from the MKV inside, and make a new MKV only have video and audio. After I reset the PMS, the external subtitle showed perfectly.

I have read a lot complains about the external subtitles failure. Probably they also have some empty subtitle insider of the MKV. Hope my information could help.

Hope next version you guys can fix this issue.
520025
 
Posts: 2
Joined: Sun Mar 10, 2013 4:39 pm

Re: Samsung AllShare uPnP/DLNA

Postby 520025 » Sun Mar 10, 2013 5:35 pm

harrytheangel wrote:
Nambit wrote:
kalivas wrote:So nobody has resolved the issue of transcoding on the 2012 Samsungs using PS3MS? It seems like there isn't a solution out there currently, every reply I've read with a similar problem describe the same issue (black screen for about a minute, does not play)

If anybody has managed to fix this it would be appreciated if you could share your solution, thanks!


I've supplied a debug/trace earlier in the thread... awaiting to see what they say.


Hello all

Does someone have some idea how to resolve that problem ? I experience the same issue, no transcoding, black screen for around 30 seconds, buffer -95 xxx MB and disconnect. TV Samsung (new one - 2012, bought few days ago), model UE46EH5300. I should mention that streaming works fine without transcoding .
I attach my debug, renderers conf file and PMS.conf

Cheers and thanks in advance.

PMS.conf
Code: Select all
thumbnails = true
image_thumbnails = true
alternativeffmpegpath = D:\\Programy\\ps3_media_server_172\\win32\\dvrms\\ffmpeg_MPGMUX.exe
mencoder_ass = false
mencoder_fontconfig = true
mencoder_ass_defaultstyle = true
uuid = 32064709-eac0-3b41-a50c-f63fbb71ddb7
folders = E:\\stuff\\filmy
mencoder_subcp = cp1250
http_engine_v2 = true


renderers conf
Code: Select all
# ps3mediaserver renderer profile for Samsung Allshare
#http://ps3mediaserver.org/forum/viewtopic.php?f=15&t=8889&start=0
#Conf: Version 1.4.0

RendererName=Samsung AllShare
RendererIcon=samsung.png
UserAgentSearch=UE46EH5300
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(\w{3}_\w{3}_\w{2}-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_\w{2}-\w{2}\d{2}\w\d{3}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{3}/\d.\d)
Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGAC3
TranscodeAudio=PCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=true
WrapDTSIntoPCM=false
MuxLPCMToMpeg=true
MaxVideoBitrateMbps=25
MaxVideoWidth=0
MaxVideoHeight=0
MimeTypesChanges=audio/wav=audio/L16|video/x-matroska=video/avi|video/x-flv=video/mp4|audio/mp3=audio/L16|video/mp4=video/mpeg
TranscodeExtensions=flv,wav
StreamExtensions=mkv,mp3,mp4,avi,mov



I have the exactly same problem about transcoding. Maybe the transcoding failure is not because of PMS, it is due to the computer.
As far as I know, transconding is a heavy CPU consumption work. Maybe our computer cpu is not powerful enough to transcode video efficiently. As suggested by PLEX media center, Intel Core 2 Duo processor 2.4 GHz or betterAt least 2GB RAM was suggested if transcoding required
520025
 
Posts: 2
Joined: Sun Mar 10, 2013 4:39 pm

Re: Samsung AllShare uPnP/DLNA

Postby co0l3r » Sat Apr 13, 2013 10:48 pm

Hello =)
plz help me
i Have a PS3 Media server 1.70 headless on debian
and Samsung Allshare TV
All worked fine until today
No changes to config of server/tv made
But Tv got an error while browsing my folders:
Error MEDIA will return to home screen
.
Upgraded to 1.80 (not solved my problem)
reset to default values my tv not solved my problem =(
after reboot of server all working for 10-15 min an then getting this error
server has enough resources free
df -h
Filesystem Size Used Avail Use% Mounted on
rootfs 26G 2.5G 22G 10% /
udev 10M 0 10M 0% /dev
tmpfs 87M 860K 86M 1% /run
/dev/disk/by-uuid/07ba4abb-d2c7-440b-b988-a6b9d5f19f51 26G 2.5G 22G 10% /
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 573M 0 573M 0% /run/shm
/dev/sda3 266G 188M 253G 1% /data
/dev/sdc1 2.7T 2.5T 116G 96% /tmpstorage2
/dev/sdb3 1.8T 1.6T 85G 95% /tmpstorage1
/tmpstorage1;/tmpstorage2 4.4T 4.0T 201G 96% /data/storage1

and enough ram:
total used free shared buffers cached
Mem: 860 793 67 0 3 683
-/+ buffers/cache: 105 754
Swap: 2001 0 2001

cpu load
01:43:41 up 2:50, load average: 2.35, 1.95, 2.15
all permissions in "shared folder" is 777
owned by PMS user
pms starts as PMS user

what more information can I provide to help solve problem?
config:
ps3mediaserver renderer profile for Samsung TVs with AllShare DLNA
# http://ps3mediaserver.org/forum/viewtop ... =15&t=8889
# Conf: Version 1.4.4

RendererName=Samsung AllShare
RendererIcon=samsung.png
UserAgentSearch=SEC_HHP_

# Recent firmware (0016 and 0019) has been reported to no longer send additional headers info
# Leaving this in for backwards compatibility with older firmware
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(\w{3}_\w{3}_\w{2}-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_\w{2}-\w{2}\d{2}\w\d{3}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{3}/\d.\d)

Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGPSAC3
TranscodeAudio=LPCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=true
WrapDTSIntoPCM=false
MuxLPCMToMpeg=true
MaxVideoBitrateMbps=25
MaxVideoWidth=0
MaxVideoHeight=0
MimeTypesChanges=audio/wav=audio/L16|video/x-matroska=video/avi|video/x-flv=video/mp4|audio/mp3=audio/L16|video/mp4=video/mpeg
TranscodeExtensions=flv,wav
StreamExtensions=mkv,mp3,mp4,avi,mov
SubtitleHttpHeader=CaptionInfo.sec




pms.conf -in default values;


logs:
Code: Select all
INFO  2013-04-14 01:07:59.494 [main] GUI environment not available
INFO  2013-04-14 01:07:59.497 [main] Switching to console mode
INFO  2013-04-14 01:07:59.501 [main] Starting PS3 Media Server 1.80.0
INFO  2013-04-14 01:07:59.502 [main] by shagrath / 2008-2012
INFO  2013-04-14 01:07:59.502 [main] http://ps3mediaserver.org
INFO  2013-04-14 01:07:59.503 [main] https://github.com/ps3mediaserver/ps3mediaserver
INFO  2013-04-14 01:07:59.504 [main]
INFO  2013-04-14 01:07:59.505 [main] Build: a2f3e866b (2013-04-02)
INFO  2013-04-14 01:07:59.505 [main] Java: 1.6.0_26-Sun Microsystems Inc.
INFO  2013-04-14 01:07:59.506 [main] OS: Linux i386 3.2.0-4-686-pae
INFO  2013-04-14 01:07:59.506 [main] Encoding: UTF-8
INFO  2013-04-14 01:07:59.506 [main] Memory: 742 MB
INFO  2013-04-14 01:07:59.507 [main]
INFO  2013-04-14 01:07:59.507 [main] Working directory: /usr/local/pms-1.80.0
INFO  2013-04-14 01:07:59.556 [main] Temp directory: /tmp/ps3mediaserver
INFO  2013-04-14 01:07:59.557 [main] Logging config file: /usr/local/pms-1.80.0/logback.headless.xml
INFO  2013-04-14 01:07:59.558 [main] debug.log: /usr/local/pms-1.80.0/debug.log
INFO  2013-04-14 01:07:59.558 [main]
INFO  2013-04-14 01:07:59.559 [main] Profile directory: /root/.config/PMS
INFO  2013-04-14 01:07:59.559 [main] Profile path: /root/.config/PMS/PMS.conf
INFO  2013-04-14 01:07:59.560 [main] Profile permissions: rw
INFO  2013-04-14 01:07:59.562 [main] Profile name: PaNdOrik BoX
INFO  2013-04-14 01:07:59.563 [main]
INFO  2013-04-14 01:08:00.030 [main] Loading MediaInfo library
INFO  2013-04-14 01:08:00.285 [main] Loaded MediaInfoLib - v0.7.58
INFO  2013-04-14 01:08:00.355 [main] Loading renderer configurations from /usr/local/pms-1.80.0/renderers
INFO  2013-04-14 01:08:00.375 [main] Loading configuration file: SamsungWiseLink.conf
INFO  2013-04-14 01:08:00.393 [main] Loading configuration file: DirecTVHR.conf
INFO  2013-04-14 01:08:00.402 [main] Loading configuration file: SMP-N100.conf
INFO  2013-04-14 01:08:00.410 [main] Loading configuration file: WDTVLive.conf
INFO  2013-04-14 01:08:00.414 [main] Loading configuration file: YamahaRXV671.conf
INFO  2013-04-14 01:08:00.416 [main] Loading configuration file: Bravia4500.conf
INFO  2013-04-14 01:08:00.420 [main] Loading configuration file: PopcornHour.conf
INFO  2013-04-14 01:08:00.423 [main] Loading configuration file: Showtime3.conf
INFO  2013-04-14 01:08:00.430 [main] Loading configuration file: iPad-iPhone.conf
INFO  2013-04-14 01:08:00.434 [main] Loading configuration file: Realtek.conf
INFO  2013-04-14 01:08:00.437 [main] Loading configuration file: PhilipsPFL.conf
INFO  2013-04-14 01:08:00.446 [main] Loading configuration file: FreecomMusicPal.conf
INFO  2013-04-14 01:08:00.450 [main] Loading configuration file: FreeboxHD.conf
INFO  2013-04-14 01:08:00.453 [main] Loading configuration file: WMP.conf
INFO  2013-04-14 01:08:00.456 [main] Loading configuration file: Android.conf
INFO  2013-04-14 01:08:00.459 [main] Loading configuration file: BraviaEX.conf
INFO  2013-04-14 01:08:00.464 [main] Loading configuration file: Kuro.conf
INFO  2013-04-14 01:08:00.476 [main] Loading configuration file: XBOX360.conf
INFO  2013-04-14 01:08:00.481 [main] Loading configuration file: SonyBluray.conf
INFO  2013-04-14 01:08:00.487 [main] Loading configuration file: SamsungAllShare.conf
INFO  2013-04-14 01:08:00.491 [main] Loading configuration file: OPPOBDP93.conf
INFO  2013-04-14 01:08:00.494 [main] Loading configuration file: Philips.conf
INFO  2013-04-14 01:08:00.497 [main] Loading configuration file: AirPlayer.conf
INFO  2013-04-14 01:08:00.520 [main] Loading configuration file: XBMC.conf
INFO  2013-04-14 01:08:00.524 [main] Loading configuration file: Streamium.conf
INFO  2013-04-14 01:08:00.527 [main] Loading configuration file: PS3.conf
INFO  2013-04-14 01:08:00.533 [main] Loading configuration file: Samsung-SMT-G7400.conf
INFO  2013-04-14 01:08:00.539 [main] Loading configuration file: DLinkDSM510.conf
INFO  2013-04-14 01:08:00.543 [main] Loading configuration file: LGST600.conf
INFO  2013-04-14 01:08:00.547 [main] Loading configuration file: N900.conf
INFO  2013-04-14 01:08:00.550 [main] Loading configuration file: BraviaHX.conf
INFO  2013-04-14 01:08:00.554 [main] Loading configuration file: Bravia5500.conf
INFO  2013-04-14 01:08:00.557 [main] Loading configuration file: OPPOBDP83.conf
INFO  2013-04-14 01:08:00.559 [main] Loading configuration file: Panasonic.conf
INFO  2013-04-14 01:08:00.564 [main] Loading configuration file: YamahaRXA1010.conf
INFO  2013-04-14 01:08:00.566 [main] Checking MPlayer font cache. It can take a minute or so.
INFO  2013-04-14 01:08:03.413 [main] Done!
INFO  2013-04-14 01:08:03.489 [main] Searching for plugins in /usr/local/pms-1.80.0/plugins
INFO  2013-04-14 01:08:03.511 [main] No plugins found
INFO  2013-04-14 01:08:03.615 [main] Registering transcoding engine: FFmpeg Audio
INFO  2013-04-14 01:08:03.651 [main] Registering transcoding engine: MEncoder
INFO  2013-04-14 01:08:03.664 [main] Registering transcoding engine: FFmpeg
INFO  2013-04-14 01:08:03.666 [main] Registering transcoding engine: VLC
INFO  2013-04-14 01:08:03.668 [main] Registering transcoding engine: MPlayer Audio
INFO  2013-04-14 01:08:03.668 [main] Registering transcoding engine: FFmpeg Web Video
INFO  2013-04-14 01:08:03.669 [main] Registering transcoding engine: MEncoder Web
INFO  2013-04-14 01:08:03.670 [main] Registering transcoding engine: MPlayer Video Dump
INFO  2013-04-14 01:08:03.670 [main] Registering transcoding engine: MPlayer Web
INFO  2013-04-14 01:08:03.674 [main] Registering transcoding engine: tsMuxeR
INFO  2013-04-14 01:08:03.675 [main] Registering transcoding engine: Audio High Fidelity
INFO  2013-04-14 01:08:03.676 [main] Registering transcoding engine: VLC Audio Streaming
INFO  2013-04-14 01:08:03.677 [main] Registering transcoding engine: VLC Video Streaming
INFO  2013-04-14 01:08:03.678 [main] Registering transcoding engine: dcraw Thumbnailer
INFO  2013-04-14 01:08:03.718 [main] Using address /10.15.1.232 found on network interface: name:eth0 (eth0)
INFO  2013-04-14 01:08:03.719 [main] Created socket: /10.15.1.232:5001
INFO  2013-04-14 01:08:04.025 [main] Checking shared folder: /data/storage1
INFO  2013-04-14 01:08:04.156 [main] Using the following UUID configured in PMS.conf: cd598158-0df1-41ed-b77a-c34fe5d20331
INFO  2013-04-14 01:08:04.417 [main] The server should now appear on your renderer
INFO  2013-04-14 01:08:44.833 [UPNPHelper] No IP filter specified, access granted to /10.15.1.193
INFO  2013-04-14 01:08:59.943 [UPNPHelper] No IP filter specified, access granted to /10.15.1.3
INFO  2013-04-14 01:09:03.914 [pool-4-thread-1] Checking IP: 10.15.1.3 for Samsung AllShare
INFO  2013-04-14 01:09:09.473 [pool-4-thread-1] Renderer Samsung AllShare found on this address: 10.15.1.3
INFO  2013-04-14 01:09:25.537 [UPNPHelper] No IP filter specified, access granted to /10.15.1.249

---------------
debug.log:
Code: Select all
oot@pandorik:/usr/local/pms# cat debug.log
INFO  2013-04-14 01:07:59.494 [main] GUI environment not available
INFO  2013-04-14 01:07:59.497 [main] Switching to console mode
INFO  2013-04-14 01:07:59.501 [main] Starting PS3 Media Server 1.80.0
INFO  2013-04-14 01:07:59.502 [main] by shagrath / 2008-2012
INFO  2013-04-14 01:07:59.502 [main] http://ps3mediaserver.org
INFO  2013-04-14 01:07:59.503 [main] https://github.com/ps3mediaserver/ps3mediaserver
INFO  2013-04-14 01:07:59.504 [main]
INFO  2013-04-14 01:07:59.505 [main] Build: a2f3e866b (2013-04-02)
INFO  2013-04-14 01:07:59.505 [main] Java: 1.6.0_26-Sun Microsystems Inc.
INFO  2013-04-14 01:07:59.506 [main] OS: Linux i386 3.2.0-4-686-pae
INFO  2013-04-14 01:07:59.506 [main] Encoding: UTF-8
INFO  2013-04-14 01:07:59.506 [main] Memory: 742 MB
INFO  2013-04-14 01:07:59.507 [main]
INFO  2013-04-14 01:07:59.507 [main] Working directory: /usr/local/pms-1.80.0
INFO  2013-04-14 01:07:59.556 [main] Temp directory: /tmp/ps3mediaserver
INFO  2013-04-14 01:07:59.557 [main] Logging config file: /usr/local/pms-1.80.0/logback.headless.xml
INFO  2013-04-14 01:07:59.558 [main] debug.log: /usr/local/pms-1.80.0/debug.log
INFO  2013-04-14 01:07:59.558 [main]
INFO  2013-04-14 01:07:59.559 [main] Profile directory: /root/.config/PMS
INFO  2013-04-14 01:07:59.559 [main] Profile path: /root/.config/PMS/PMS.conf
INFO  2013-04-14 01:07:59.560 [main] Profile permissions: rw
INFO  2013-04-14 01:07:59.562 [main] Profile name: PaNdOrik BoX
INFO  2013-04-14 01:07:59.563 [main]
INFO  2013-04-14 01:08:00.030 [main] Loading MediaInfo library
INFO  2013-04-14 01:08:00.285 [main] Loaded MediaInfoLib - v0.7.58
INFO  2013-04-14 01:08:00.355 [main] Loading renderer configurations from /usr/local/pms-1.80.0/renderers
INFO  2013-04-14 01:08:00.375 [main] Loading configuration file: SamsungWiseLink.conf
INFO  2013-04-14 01:08:00.393 [main] Loading configuration file: DirecTVHR.conf
INFO  2013-04-14 01:08:00.402 [main] Loading configuration file: SMP-N100.conf
INFO  2013-04-14 01:08:00.410 [main] Loading configuration file: WDTVLive.conf
INFO  2013-04-14 01:08:00.414 [main] Loading configuration file: YamahaRXV671.conf
INFO  2013-04-14 01:08:00.416 [main] Loading configuration file: Bravia4500.conf
INFO  2013-04-14 01:08:00.420 [main] Loading configuration file: PopcornHour.conf
INFO  2013-04-14 01:08:00.423 [main] Loading configuration file: Showtime3.conf
INFO  2013-04-14 01:08:00.430 [main] Loading configuration file: iPad-iPhone.conf
INFO  2013-04-14 01:08:00.434 [main] Loading configuration file: Realtek.conf
INFO  2013-04-14 01:08:00.437 [main] Loading configuration file: PhilipsPFL.conf
INFO  2013-04-14 01:08:00.446 [main] Loading configuration file: FreecomMusicPal.conf
INFO  2013-04-14 01:08:00.450 [main] Loading configuration file: FreeboxHD.conf
INFO  2013-04-14 01:08:00.453 [main] Loading configuration file: WMP.conf
INFO  2013-04-14 01:08:00.456 [main] Loading configuration file: Android.conf
INFO  2013-04-14 01:08:00.459 [main] Loading configuration file: BraviaEX.conf
INFO  2013-04-14 01:08:00.464 [main] Loading configuration file: Kuro.conf
INFO  2013-04-14 01:08:00.476 [main] Loading configuration file: XBOX360.conf
INFO  2013-04-14 01:08:00.481 [main] Loading configuration file: SonyBluray.conf
INFO  2013-04-14 01:08:00.487 [main] Loading configuration file: SamsungAllShare.conf
INFO  2013-04-14 01:08:00.491 [main] Loading configuration file: OPPOBDP93.conf
INFO  2013-04-14 01:08:00.494 [main] Loading configuration file: Philips.conf
INFO  2013-04-14 01:08:00.497 [main] Loading configuration file: AirPlayer.conf
INFO  2013-04-14 01:08:00.520 [main] Loading configuration file: XBMC.conf
INFO  2013-04-14 01:08:00.524 [main] Loading configuration file: Streamium.conf
INFO  2013-04-14 01:08:00.527 [main] Loading configuration file: PS3.conf
INFO  2013-04-14 01:08:00.533 [main] Loading configuration file: Samsung-SMT-G7400.conf
INFO  2013-04-14 01:08:00.539 [main] Loading configuration file: DLinkDSM510.conf
INFO  2013-04-14 01:08:00.543 [main] Loading configuration file: LGST600.conf
INFO  2013-04-14 01:08:00.547 [main] Loading configuration file: N900.conf
INFO  2013-04-14 01:08:00.550 [main] Loading configuration file: BraviaHX.conf
INFO  2013-04-14 01:08:00.554 [main] Loading configuration file: Bravia5500.conf
INFO  2013-04-14 01:08:00.557 [main] Loading configuration file: OPPOBDP83.conf
INFO  2013-04-14 01:08:00.559 [main] Loading configuration file: Panasonic.conf
INFO  2013-04-14 01:08:00.564 [main] Loading configuration file: YamahaRXA1010.conf
INFO  2013-04-14 01:08:00.566 [main] Checking MPlayer font cache. It can take a minute or so.
DEBUG 2013-04-14 01:08:00.567 [main] launching: mplayer
INFO  2013-04-14 01:08:03.413 [main] Done!
INFO  2013-04-14 01:08:03.489 [main] Searching for plugins in /usr/local/pms-1.80.0/plugins
INFO  2013-04-14 01:08:03.511 [main] No plugins found
INFO  2013-04-14 01:08:03.615 [main] Registering transcoding engine: FFmpeg Audio
INFO  2013-04-14 01:08:03.651 [main] Registering transcoding engine: MEncoder
INFO  2013-04-14 01:08:03.664 [main] Registering transcoding engine: FFmpeg
INFO  2013-04-14 01:08:03.666 [main] Registering transcoding engine: VLC
INFO  2013-04-14 01:08:03.668 [main] Registering transcoding engine: MPlayer Audio
INFO  2013-04-14 01:08:03.668 [main] Registering transcoding engine: FFmpeg Web Video
INFO  2013-04-14 01:08:03.669 [main] Registering transcoding engine: MEncoder Web
INFO  2013-04-14 01:08:03.670 [main] Registering transcoding engine: MPlayer Video Dump
INFO  2013-04-14 01:08:03.670 [main] Registering transcoding engine: MPlayer Web
INFO  2013-04-14 01:08:03.674 [main] Registering transcoding engine: tsMuxeR
INFO  2013-04-14 01:08:03.675 [main] Registering transcoding engine: Audio High Fidelity
INFO  2013-04-14 01:08:03.676 [main] Registering transcoding engine: VLC Audio Streaming
INFO  2013-04-14 01:08:03.677 [main] Registering transcoding engine: VLC Video Streaming
INFO  2013-04-14 01:08:03.678 [main] Registering transcoding engine: dcraw Thumbnailer
INFO  2013-04-14 01:08:03.718 [main] Using address /10.15.1.232 found on network interface: name:eth0 (eth0)
INFO  2013-04-14 01:08:03.719 [main] Created socket: /10.15.1.232:5001
INFO  2013-04-14 01:08:04.025 [main] Checking shared folder: /data/storage1
DEBUG 2013-04-14 01:08:04.152 [main] Sending ALIVE...
INFO  2013-04-14 01:08:04.156 [main] Using the following UUID configured in PMS.conf: cd598158-0df1-41ed-b77a-c34fe5d20331
INFO  2013-04-14 01:08:04.417 [main] The server should now appear on your renderer
DEBUG 2013-04-14 01:08:14.411 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:08:34.414 [UPNP-AliveMessageSender] Sending ALIVE...
INFO  2013-04-14 01:08:44.833 [UPNPHelper] No IP filter specified, access granted to /10.15.1.193
INFO  2013-04-14 01:08:59.943 [UPNPHelper] No IP filter specified, access granted to /10.15.1.3
INFO  2013-04-14 01:09:03.914 [pool-4-thread-1] Checking IP: 10.15.1.3 for Samsung AllShare
INFO  2013-04-14 01:09:09.473 [pool-4-thread-1] Renderer Samsung AllShare found on this address: 10.15.1.3
DEBUG 2013-04-14 01:09:09.802 [pool-4-thread-1] Starting ping -c 3 -s 64000 10.15.1.3
DEBUG 2013-04-14 01:09:09.871 [pool-4-thread-1] Unix process ID (ping): 7242
DEBUG 2013-04-14 01:09:11.805 [SpeedStats Failsafe] Stopping Unix process 7242: ping-0
INFO  2013-04-14 01:09:25.537 [UPNPHelper] No IP filter specified, access granted to /10.15.1.249
DEBUG 2013-04-14 01:11:34.415 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:14:34.417 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:17:34.419 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:20:34.422 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:23:34.511 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:26:34.551 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:29:37.013 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:32:37.046 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:35:37.322 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2013-04-14 01:38:37.353 [UPNP-AliveMessageSender] Sending ALIVE...
Last edited by meskibob on Sun Apr 14, 2013 7:21 pm, edited 1 time in total.
Reason: Reformatted.
co0l3r
 
Posts: 1
Joined: Sat Apr 13, 2013 10:34 pm

Re: Samsung AllShare uPnP/DLNA

Postby badincite » Sun Apr 14, 2013 7:19 pm

I have a 2012 samsung tv, and it doesn't use the transcoding and my pc has a intel i7 in it. Any way to turn of the subtitles when its not using a transcoder?
badincite
 
Posts: 7
Joined: Sun Sep 09, 2012 3:49 pm

Re: Samsung AllShare uPnP/DLNA

Postby Duda » Mon Apr 22, 2013 5:31 pm

Hi all,

I've a little problem. I'm able to seek movie (+/-15s) but no fast forward or rewind. When I try ("2" on screen ;) ) buttons I see information that rewind is not supported. Is this because of video transcoding settings? I have set "SeekByTime" to "true".

My TV is connected by cable to router and my notebook is connected by wifi (G type).


Untitled-1.jpg
Untitled-1.jpg (47.37 KiB) Viewed 1989 times
Duda
 
Posts: 1
Joined: Mon Apr 22, 2013 5:12 pm

Re: Samsung AllShare uPnP/DLNA

Postby kastaldi » Wed May 15, 2013 5:52 pm

Hello everybody.

I have a problem, maybe is a noob question but I searched this forum and googled around but I didn't find the answer.

I play some videos (divx avi) on a Samsung Allshare 6600. There are external (srt) subtitles.
When I use Minidlna 1.1.0 on a Linux PC, I press the Tools button on the remote and my TV shows a Subtitles option so I can enable/disable subtitles directly from the TV. When I use PMS 1.81.0 (SamsungAllShare.conf 1.4.4), no matter which settings I enable (load automatically subtitles, subtitles language priority, use ass/asa subtitles, and so on), the Subtitles option on my tv is missing. It is quite frustrating because each time I have to enable/disable subtitles manually from PMS.
Maybe I should also try changing video decoding engine but I wonder what happens because I thought Minidlna was inferior compared to PMS.

Thanks.
kastaldi
 
Posts: 5
Joined: Fri Apr 13, 2012 4:17 pm

Re: Samsung AllShare uPnP/DLNA

Postby broadbean » Sat May 18, 2013 2:56 pm

kastaldi wrote:Hello everybody.

I have a problem, maybe is a noob question but I searched this forum and googled around but I didn't find the answer.


I'm in the same boat. I think 1.72.0 was ok, then I upgraded to 1.81.0 and it broke.
broadbean
 
Posts: 1
Joined: Sat May 18, 2013 2:46 pm

Re: Samsung AllShare uPnP/DLNA

Postby clmc » Sat May 18, 2013 6:34 pm

Guys, for some reason, when you use PMS with a Allshare Samsung TV, the TV can't read the external subtitles when the movie has internal subtitles.

A workaround for this problem is: download a program called mkvmerge GUI and remove all the internal subtitles. It takes less than 2 minutes for a 5 gb movie. It's really easy, even my grandmother can do it.

Check this video on youtube:
http://www.youtube.com/watch?v=P2mpKHxEqmA
clmc
 
Posts: 1
Joined: Sat May 18, 2013 6:28 pm

PreviousNext

Return to Alternative Media Renderers

Who is online

Users browsing this forum: No registered users and 2 guests