Sony SMP-N100

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Re: Sony SMP-N100

Postby MakDaddy » Wed May 09, 2012 7:08 am

I can't get mine to connect at all. I stream to PS3 just fine. But the sony is upstairs and the media server never even appears in the list.
MakDaddy
 
Posts: 3
Joined: Wed Jul 20, 2011 8:25 pm

Re: Sony SMP-N100

Postby mrw1986 » Sun Jul 01, 2012 8:15 am

Hey guys,

I know this is an old thread, however I have a working .conf file for the SMP-N100. I've had this working for over a year now and never posted it because honestly I never thought about it. It took me several hours of playing to get it to work, but it plays mkv, avi, mpeg, the whole nine. I've only come across a couple files it couldn't play out of over 250+ tested files. Please note, for "RendererIcon=D:\\Program Files (x86)\\PS3 Media Server\\sonysmpn100.png" I have my own icon, you may need to change this depending on your setup.

Here it is:

Code: Select all
# ps3mediaserver renderer profile for Sony SMP-N100
# Refer to PS3.conf for help
RendererName=Sony SMP-N100
RendererIcon=D:\\Program Files (x86)\\PS3 Media Server\\sonysmpn100.png

# ============================================================================
# Sony Bluray uses the following headers:
#
# User-Agent: UPnP/1.0
# X-AV-Client-Info: av=5.0; cn="Sony Corporation"; mn="Media Player"; mv="2.0";
# X-AV-Physical-Unit-Info: pa="Media Player";
# ---
# User-Agent: UPnP/1.0 DLNADOC/1.50
# X-AV-Client-Info: av=5.0; cn="Sony Corporation"; mn="Media Player"; mv="2.0";
# X-AV-Physical-Unit-Info: pa="Media Player";
# ============================================================================
# The User-Agent strings are too generic to match
#UserAgentSearch=
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(cn="Sony Corporation"; mn="Media Player")
Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGTSAC3
TranscodeAudio=LPCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=false
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
#MimeTypesChanges=
DLNALocalizationRequired=true
TranscodeExtensions=mkv,flv
#StreamExtensions=
MediaParserV2_ThumbnailGeneration=false

# For Sony Bluray players and Bravia TVs
ForceJPGThumbnails=true
# For Sony Bluray players
ChunkedTransfer=true

# Specs below taken from http://www.sony.co.uk/product/blu-ray-disc-player/bdp-s370#pageType=TechnicalSpecs
# then fine-tuned by lengthy trial and error since so much of that advertised spec is inaccurate.
# US models don't support video/divx mime type but European and Canadian models do.
# Subtitles in mkv files are only displayed if mime type is video/divx.
# Vob subtitles are not supported.
# See also http://forum.serviio.org/viewtopic.php?f=11&t=2004 for more DLNA-related info on these players.

MediaInfo=true
# --- video ---
Supported = f:mpegps|mpegts   v:mpeg1|mpeg2   a:ac3|dts|lpcm|mpa|mp3   m:video/mpeg
Supported = f:mpegts   v:h264|vc1   a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/vnd.dlna.mpeg-tts
Supported = f:mp4|m4v   v:mp4|h264   a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/mpeg
######### NON-US MODELS: CHANGE THE FOLLOWING 2 MIME-TYPES TO m:video/divx
Supported = f:avi|divx   v:divx|mp4   a:ac3|lpcm|mpa|mp3   m:video/mpeg
Supported = f:mkv   v:mp4|divx|h264   a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/vnd.dlna.mpeg-tts
# --- audio ---
Supported = f:wma   n:2   m:audio/mpeg
Supported = f:mp3   n:2   m:audio/mpeg
Supported = f:lpcm n:2 s:48000 m:audio/L16
# --- image ---
Supported = f:jpg   m:image/jpeg



Try it out and let me know how it works! I'm not really good at troubleshooting, but I'll do my best. This was literally trial and error for me.
mrw1986
 
Posts: 12
Joined: Thu Jun 28, 2012 3:32 pm

Re: Sony SMP-N100

Postby Eighthman » Mon Jul 30, 2012 4:01 am

Thank you, MrW. Your conf file does indeed work. I tried to make my own a while back, but was unsuccessful. I just got a new Mac, and returned to have my media streaming running again.
Eighthman
 
Posts: 2
Joined: Sun Jul 10, 2011 6:24 am

Re: Sony SMP-N100

Postby mrw1986 » Mon Jul 30, 2012 5:40 pm

I'm glad it's working ok!
mrw1986
 
Posts: 12
Joined: Thu Jun 28, 2012 3:32 pm

Re: Sony SMP-N100

Postby chocolateboy » Sat Aug 04, 2012 2:46 pm

SonyBluray.conf:

Code: Select all
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(cn="Sony Corporation"; mn="Blu-ray Disc Player")


SMP-N100.conf:

Code: Select all
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(cn="Sony Corporation"; mn="Blu-ray Disc Player|.*Home Theat(re|er) System|Media Player")


The SMP-N100.conf is pre-empting and breaking support for Sony Blu-ray players. Can you suggest a better way to identify this renderer (i.e. via another header)?
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Sony SMP-N100

Postby mrw1986 » Sat Aug 04, 2012 2:51 pm

If you use my header (the original) and not the one the other guy made it works fine. It's the one a few posts up. All he did was copy one of the already made renderer files which caused issues.
mrw1986
 
Posts: 12
Joined: Thu Jun 28, 2012 3:32 pm

Re: Sony SMP-N100

Postby chocolateboy » Sat Aug 04, 2012 3:17 pm

Thanks. Done.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Sony SMP-N100

Postby tirionlanister » Tue Aug 14, 2012 7:31 am

Thanks for the file, my Sony SNP-n100 has become more sophisticated. I could not play mkv but now I can easily do it.
Last edited by chocolateboy on Tue Aug 14, 2012 8:17 am, edited 2 times in total.
Reason: rm blogspam
tirionlanister
 
Posts: 1
Joined: Tue Aug 14, 2012 7:14 am

Re: Sony SMP-N100

Postby mrw1986 » Tue Aug 14, 2012 9:49 am

You're very welcome :)
mrw1986
 
Posts: 12
Joined: Thu Jun 28, 2012 3:32 pm

Re: Sony SMP-N100

Postby skeety » Wed Jul 17, 2013 8:24 pm

So I have it showing up...but it keeps telling me, whether I pick MPG, M2TS, AVI, etc....Unsupported / Corrup file.

Any ideas?
skeety
 
Posts: 16
Joined: Thu May 20, 2010 8:08 pm

PreviousNext

Return to Alternative Media Renderers

Who is online

Users browsing this forum: Bing [Bot] and 3 guests